aboutsummaryrefslogtreecommitdiff
path: root/devel/libunicode
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-29 19:29:25 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-29 19:29:25 +0000
commit331773a5478dcac79399a6e4e87e5ede711d39d3 (patch)
tree37cd4a7db0ea4b0a2751b810254026c163bcac05 /devel/libunicode
parent53d3581af0d93aec3ce6dc5512e6b41df3ee7dc1 (diff)
downloadports-331773a5478dcac79399a6e4e87e5ede711d39d3.tar.gz
ports-331773a5478dcac79399a6e4e87e5ede711d39d3.zip
libunicode is a library for manipulating Unicode characters and
strings. It understands both the UTF-8 and UCS-2 encodings, and has a framework for adding support for new encodings.
Notes
Notes: svn path=/head/; revision=29994
Diffstat (limited to 'devel/libunicode')
-rw-r--r--devel/libunicode/Makefile25
-rw-r--r--devel/libunicode/distinfo1
-rw-r--r--devel/libunicode/pkg-comment1
-rw-r--r--devel/libunicode/pkg-descr5
-rw-r--r--devel/libunicode/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/libunicode/Makefile b/devel/libunicode/Makefile
new file mode 100644
index 000000000000..34e89316eb6b
--- /dev/null
+++ b/devel/libunicode/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libunicode
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libunicode
+PORTVERSION= 0.4
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/libunicode
+
+MAINTAINER= ade@FreeBSD.org
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALL_SHLIBS= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/devel/libunicode/distinfo b/devel/libunicode/distinfo
new file mode 100644
index 000000000000..2c8e66582827
--- /dev/null
+++ b/devel/libunicode/distinfo
@@ -0,0 +1 @@
+MD5 (libunicode-0.4.tar.gz) = d788ed7595a0250931f421068f4a0083
diff --git a/devel/libunicode/pkg-comment b/devel/libunicode/pkg-comment
new file mode 100644
index 000000000000..bc28bfad96d5
--- /dev/null
+++ b/devel/libunicode/pkg-comment
@@ -0,0 +1 @@
+A library for manipulating Unicode characters and strings
diff --git a/devel/libunicode/pkg-descr b/devel/libunicode/pkg-descr
new file mode 100644
index 000000000000..b27a4d6b0b48
--- /dev/null
+++ b/devel/libunicode/pkg-descr
@@ -0,0 +1,5 @@
+libunicode is a library for manipulating Unicode characters and
+strings. It understands both the UTF-8 and UCS-2 encodings, and has a
+framework for adding support for new encodings.
+
+WWW: http://www.gnome.org/
diff --git a/devel/libunicode/pkg-plist b/devel/libunicode/pkg-plist
new file mode 100644
index 000000000000..e774596d2797
--- /dev/null
+++ b/devel/libunicode/pkg-plist
@@ -0,0 +1,5 @@
+bin/unicode-config
+include/unicode.h
+lib/libunicode.a
+lib/libunicode.so
+lib/libunicode.so.0