aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-04-04 04:53:26 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-04-04 04:53:26 +0000
commitc0c47dcd0cc0e65591a8af1ef4da414120e0fa51 (patch)
treeb585cb6e5fbef97c86cb5462ab12164bf9d9080f /devel/libvirt/Makefile
parentb4cc6413dc8df9b8c2656168306b649287f3cc08 (diff)
downloadports-c0c47dcd0cc0e65591a8af1ef4da414120e0fa51.tar.gz
ports-c0c47dcd0cc0e65591a8af1ef4da414120e0fa51.zip
- Update to 0.9.11
- bring in libssh2 support and tests Changes: http://libvirt.org/news.html Feature safe: yes
Notes
Notes: svn path=/head/; revision=294184
Diffstat (limited to 'devel/libvirt/Makefile')
-rw-r--r--devel/libvirt/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index abbfbd4e75ab..48589fc46a1e 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libvirt
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.11
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/
@@ -18,7 +18,8 @@ LICENSE= LGPL3
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
gcrypt.18:${PORTSDIR}/security/libgcrypt \
xml2.5:${PORTSDIR}/textproc/libxml2 \
- gnutls.47:${PORTSDIR}/security/gnutls
+ gnutls.47:${PORTSDIR}/security/gnutls \
+ ssh2.1:${PORTSDIR}/security/libssh2
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake autoconf
@@ -30,8 +31,11 @@ CONFIGURE_ARGS= --without-libssh2 \
--without-hal \
--without-udev \
--without-netcf \
- --without-network
-CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+ --without-network \
+ --with-libssh2
+
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes
USE_GNOME= gnomehack
@@ -65,4 +69,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|conf_DATA = libvirt.conf|conf_DATA = libvirt.conf.sample|' \
${WRKSRC}/src/Makefile.am
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} check
+
.include <bsd.port.mk>