aboutsummaryrefslogtreecommitdiff
path: root/devel/libvirt
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2015-09-29 14:49:45 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2015-09-29 14:49:45 +0000
commit3ec809fa419d8ea7bafe1e6afdab5eb6e596d263 (patch)
treef2e4725a3f737ba9438f3c5c0c4ba002a64e87a7 /devel/libvirt
parent2ac5a0fd2fa6603650db6855500294440305529e (diff)
downloadports-3ec809fa419d8ea7bafe1e6afdab5eb6e596d263.tar.gz
ports-3ec809fa419d8ea7bafe1e6afdab5eb6e596d263.zip
Fix plist on non-amd64 archs
When the arch-specific option is defined and OPTIONS_SUB is enabled, PLIST_SUB is populated accordingly on the target arch. However, on other archs PLIST_SUB is not populated and that results in a broken pkg-plist. Fix this by explicitly adding '@comment ' for the option feature if it's not in PLIST_SUB. Reported by: jgh Pointy hat to: novel
Notes
Notes: svn path=/head/; revision=398181
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 8ff35dd00e9d..52c0813d5c50 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -100,6 +100,10 @@ STRIP_FILES+= lib/libvirt/connection-driver/libvirt_driver_bhyve.so
PLIST_FILES+= lib/libvirt/connection-driver/libvirt_driver_bhyve.so
.endif
+.if !${PLIST_SUB:MXEN}
+PLIST_SUB+= XEN="@comment "
+.endif
+
post-patch:
.if ${OSVERSION} < 900000
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||' \