aboutsummaryrefslogtreecommitdiff
path: root/devel/libxalloc
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-04-03 01:23:32 +0000
committerSteve Price <steve@FreeBSD.org>1999-04-03 01:23:32 +0000
commit93071141f4dacba9aaa173df583a430fbd1f2c94 (patch)
tree47d789de2e588f0d6d6ffaeec37023f963a9d502 /devel/libxalloc
parent0f4a701afd02e334f5f94a17a5e30fe9823b76af (diff)
downloadports-93071141f4dacba9aaa173df583a430fbd1f2c94.tar.gz
ports-93071141f4dacba9aaa173df583a430fbd1f2c94.zip
Import of libxalloc version 1.0.3.
A memory allocation library with error checking. PR: 6474 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=17581
Diffstat (limited to 'devel/libxalloc')
-rw-r--r--devel/libxalloc/Makefile26
-rw-r--r--devel/libxalloc/distinfo1
-rw-r--r--devel/libxalloc/files/patch-aa35
-rw-r--r--devel/libxalloc/pkg-comment1
-rw-r--r--devel/libxalloc/pkg-descr3
-rw-r--r--devel/libxalloc/pkg-plist8
6 files changed, 74 insertions, 0 deletions
diff --git a/devel/libxalloc/Makefile b/devel/libxalloc/Makefile
new file mode 100644
index 000000000000..4b6f26bef665
--- /dev/null
+++ b/devel/libxalloc/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libxalloc
+# Version required: 1.0.3
+# Date created: 12 April 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xalloc-1.0.3
+PKGNAME= libxalloc-1.0.3
+CATEGORIES= devel
+MASTER_SITES= http://home.sol.no/~sverrehu/pub-unix/files/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+USE_GMAKE= yes
+
+post-install:
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/libxalloc
+ @ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/libxalloc
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libxalloc
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libxalloc/distinfo b/devel/libxalloc/distinfo
new file mode 100644
index 000000000000..27ec1b1ed0ff
--- /dev/null
+++ b/devel/libxalloc/distinfo
@@ -0,0 +1 @@
+MD5 (xalloc-1.0.3.tar.gz) = 64ba37476b6b47c9fc2ea63c1e1f53d5
diff --git a/devel/libxalloc/files/patch-aa b/devel/libxalloc/files/patch-aa
new file mode 100644
index 000000000000..ef7bfb08ce84
--- /dev/null
+++ b/devel/libxalloc/files/patch-aa
@@ -0,0 +1,35 @@
+--- Makefile.orig Sun Jul 5 12:15:59 1998
++++ Makefile Fri Apr 2 15:26:22 1999
+@@ -8,10 +8,10 @@
+ ###########################################################################
+
+ # Define SHARED as 1 for Linux shared ELF library
+-#SHARED = 1
++SHARED = 1
+
+ ifeq ($(SHARED),1)
+-LIBTARGET = lib$(DIST).so.$(VERSION)
++LIBTARGET = lib$(DIST).so.$(VERMAJ)
+ LIBTARGETSO = lib$(DIST).so
+ LIBTARGETSOMAJ = $(LIBTARGETSO).$(VERMAJ)
+ CCSHRD = -fPIC
+@@ -27,7 +27,7 @@
+ INSTBASEDIR = /usr/local
+ INSTLIBDIR = $(INSTBASEDIR)/lib
+ INSTINCDIR = $(INSTBASEDIR)/include
+-INSTALL = install -m 644
++INSTALL = install -c -m 644
+ MKDIRP = install -d -m 755
+
+ ###########################################################################
+@@ -66,9 +66,7 @@
+ $(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
+ $(INSTALL) $(LIBHEAD) $(INSTINCDIR)
+ ifeq ($(SHARED),1)
+- ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
+- ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
+- echo "If you use GNU/Linux, remember to run ldconfig"
++ ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSO)
+ endif
+
+ clean:
diff --git a/devel/libxalloc/pkg-comment b/devel/libxalloc/pkg-comment
new file mode 100644
index 000000000000..608a9fd5ccc3
--- /dev/null
+++ b/devel/libxalloc/pkg-comment
@@ -0,0 +1 @@
+A memory allocation library with error checking.
diff --git a/devel/libxalloc/pkg-descr b/devel/libxalloc/pkg-descr
new file mode 100644
index 000000000000..874dd540d4b8
--- /dev/null
+++ b/devel/libxalloc/pkg-descr
@@ -0,0 +1,3 @@
+xalloc is a memory allocation library with error checking.
+It contains wrappers including error checking for memory
+allocating C-functions.
diff --git a/devel/libxalloc/pkg-plist b/devel/libxalloc/pkg-plist
new file mode 100644
index 000000000000..18dc2193836b
--- /dev/null
+++ b/devel/libxalloc/pkg-plist
@@ -0,0 +1,8 @@
+include/xalloc.h
+lib/libxalloc.so
+lib/libxalloc.so.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+share/doc/libxalloc/CREDITS
+share/doc/libxalloc/README
+@dirrm share/doc/libxalloc