aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-allegro/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-05-01 17:28:17 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-05-01 17:28:17 +0000
commitc1eba2d83eb1b997b5906a1458529c5c6a6a2fa4 (patch)
treeae044c026c4c8ae63ae3e6cd375428c689780f05 /devel/linux-allegro/Makefile
parent205f4f916c424ba649de05e7db3c1c34afa55d33 (diff)
downloadports-c1eba2d83eb1b997b5906a1458529c5c6a6a2fa4.tar.gz
ports-c1eba2d83eb1b997b5906a1458529c5c6a6a2fa4.zip
- convert to use bsd.linux-rpm.mk (get rid of include of linux-gtk/Makefile) [1]
- use fixed plists [1] - category "linux" added to those ports without it [1] - update some ports to a recent FC3 one [1] - remove plists/... for Alpha (there's no support since linux_base-8 for Alpha anymore) - don't hardcode version numbers in some plists, use PLIST_SUB instead (any errors are mine, don't keep them, send them to me) Regarding linux-ungif I declare a maintainer timeout (one month, Boris tried to contact the maintainer) and also pull the "sweeping commit"-card (the port which it uses as some kind of master port can not be used for this anymore). Besides this, I don't think he will be upset when other people do the work instead of adding an entry to his TODO list. :-) This commit brings us just before the switch of the default linux base port to the fc3 one, modulo some bugs which may appear. So: Beta testers wanted! To test: sed -i.old -e 's:linux-XFree86-libs:linux-xorg-libs:' /usr/ports/Mk/bsd.port.mk echo OVERRIDE_LINUX_BASE_PORT=fc3 >> /etc/make.conf portupgrade -f -o emulators/linux_base-fc3 -f linux_base-8 portupgrade -o x11/linux-xorg-libs linux-XFree86-libs portupgrade linux-\* The first two steps are necessary to switch to fc3 as the new default linux base port, the last 3 steps to upgrade to fc3. And feel free to send a big "Thank you!" to Boris, he did a lot of the work! I just provided some hints and answered some questions (besides from committing all the necessary changes for FC3 and doing some minor changes+comments/improvements to/of his work), even when he tries to tell you something else. ;-) Submitted by: Boris Samorodov <bsam@ipt.ru> [1]
Notes
Notes: svn path=/head/; revision=161107
Diffstat (limited to 'devel/linux-allegro/Makefile')
-rw-r--r--devel/linux-allegro/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/devel/linux-allegro/Makefile b/devel/linux-allegro/Makefile
index 3926708da4c9..e19998825d5c 100644
--- a/devel/linux-allegro/Makefile
+++ b/devel/linux-allegro/Makefile
@@ -7,23 +7,25 @@
PORTNAME= allegro
PORTVERSION= 4.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel linux
MASTER_SITES= http://membres.lycos.fr/ebotcazou/allegro/
-PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Cross-platform game programming library (linux version)
-BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
-RUN_DEPENDS=
-
-USE_LINUX= yes
-USE_LINUX_PREFIX= yes
+USE_LINUX_RPM= yes
ONLY_FOR_ARCHS= i386 amd64
+DIST_SUBDIR= rpm
+INSTALLS_SHLIB= yes
+USE_XLIB= yes
+SRC_DISTFILES=
-RPM_SET= ${PORTNAME}-${PORTVERSION}-1.${ARCH}.rpm
-PLIST= ${MASTERDIR}/pkg-plist
MD5_FILE= ${MASTERDIR}/distinfo
-.include "../../x11-toolkits/linux-gtk/Makefile"
+post-extract:
+ @cd ${WRKSRC}/usr/lib; \
+ ${LN} -s liballeg-4.0.3.so liballeg.so.4.0
+
+.include <bsd.port.mk>