aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-allegro
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-22 22:56:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-22 22:56:48 +0000
commitf82a8bcc2ae05b76b9c8fd0ae653faedd3c7d747 (patch)
tree9ad2e67f89e0be169d8000cbeb0561d39951cc2c /devel/linux-allegro
parentc4bcc8cf2840d7c4e0b5424cf7aeaaebc83c373a (diff)
downloadports-f82a8bcc2ae05b76b9c8fd0ae653faedd3c7d747.tar.gz
ports-f82a8bcc2ae05b76b9c8fd0ae653faedd3c7d747.zip
Linux version of Allegro, the cross-platform library for game development.
Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=94734
Diffstat (limited to 'devel/linux-allegro')
-rw-r--r--devel/linux-allegro/Makefile38
-rw-r--r--devel/linux-allegro/distinfo1
-rw-r--r--devel/linux-allegro/pkg-descr4
-rw-r--r--devel/linux-allegro/pkg-plist21
4 files changed, 64 insertions, 0 deletions
diff --git a/devel/linux-allegro/Makefile b/devel/linux-allegro/Makefile
new file mode 100644
index 000000000000..31521b556a97
--- /dev/null
+++ b/devel/linux-allegro/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: linux-allegro
+# Date created: 18 Nov 2003
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= allegro
+PORTVERSION= 4.0.3
+CATEGORIES= devel linux
+MASTER_SITES= http://membres.lycos.fr/ebotcazou/allegro/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1.${MACHINE_ARCH}
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Cross-platform game programming library (linux version)
+
+USE_LINUX_PREFIX= yes
+LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+
+ONLY_FOR_ARCHS= i386
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @${PREFIX}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
+ @${LDCONFIG_LINUX}
+ @${RMDIR} ${PREFIX}/var/tmp
+
+.include <bsd.port.mk>
diff --git a/devel/linux-allegro/distinfo b/devel/linux-allegro/distinfo
new file mode 100644
index 000000000000..dfef22c0c6b3
--- /dev/null
+++ b/devel/linux-allegro/distinfo
@@ -0,0 +1 @@
+MD5 (rpm/allegro-4.0.3-1.i386.rpm) = 551dc0c1c6756991daa9e71fd5f73faf
diff --git a/devel/linux-allegro/pkg-descr b/devel/linux-allegro/pkg-descr
new file mode 100644
index 000000000000..9948d05c3844
--- /dev/null
+++ b/devel/linux-allegro/pkg-descr
@@ -0,0 +1,4 @@
+Allegro is a cross-platform library intended for use in computer games and
+other types of multimedia programming.
+
+WWW: http://www.talula.demon.co.uk/allegro/
diff --git a/devel/linux-allegro/pkg-plist b/devel/linux-allegro/pkg-plist
new file mode 100644
index 000000000000..69958d0f2a8f
--- /dev/null
+++ b/devel/linux-allegro/pkg-plist
@@ -0,0 +1,21 @@
+etc/allegrorc
+usr/lib/allegro/4.0/alleg-artsdigi.so
+usr/lib/allegro/4.0/alleg-dga2.so
+usr/lib/allegro/4.0/alleg-fbcon.so
+usr/lib/allegro/4.0/alleg-svgalib.so
+usr/lib/allegro/4.0/alleg-vga.so
+usr/lib/allegro/4.0/modules.lst
+usr/lib/liballeg.so.4.0
+usr/lib/liballeg-4.0.3.so
+usr/share/allegro/keyboard.dat
+usr/share/allegro/language.dat
+usr/share/doc/allegro-4.0.3/AUTHORS
+usr/share/doc/allegro-4.0.3/CHANGES
+usr/share/doc/allegro-4.0.3/linux.txt
+usr/share/doc/allegro-4.0.3/readme.txt
+usr/share/doc/allegro-4.0.3/THANKS
+usr/share/doc/allegro-4.0.3/unix.txt
+@dirrm usr/share/doc/allegro-4.0.3
+@dirrm usr/share/allegro
+@dirrm usr/lib/allegro/4.0
+@dirrm usr/lib/allegro