aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-f10-sdl12
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-17 02:12:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-17 02:12:55 +0000
commit203a7b96e5c7c68d7472093721977e3d0275fdf4 (patch)
tree5c86553566bcf095d215c6aef7713ab4f6c46415 /devel/linux-f10-sdl12
parentfccb6415b8be5a8e2a441673f77d7dec57070f04 (diff)
downloadports-203a7b96e5c7c68d7472093721977e3d0275fdf4.tar.gz
ports-203a7b96e5c7c68d7472093721977e3d0275fdf4.zip
New port linux-sdl12 version 1.2.2.1: Cross-platform multi-media
development API (linux version) Submitted by: Martin Matuska <matuska@wu-wien.ac.at> Reviewed by: Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=48856
Diffstat (limited to 'devel/linux-f10-sdl12')
-rw-r--r--devel/linux-f10-sdl12/Makefile41
-rw-r--r--devel/linux-f10-sdl12/distinfo.alpha1
-rw-r--r--devel/linux-f10-sdl12/distinfo.i3861
-rw-r--r--devel/linux-f10-sdl12/pkg-comment1
-rw-r--r--devel/linux-f10-sdl12/pkg-descr10
-rw-r--r--devel/linux-f10-sdl12/pkg-plist.alpha8
-rw-r--r--devel/linux-f10-sdl12/pkg-plist.i3868
7 files changed, 70 insertions, 0 deletions
diff --git a/devel/linux-f10-sdl12/Makefile b/devel/linux-f10-sdl12/Makefile
new file mode 100644
index 000000000000..abe32c4bb0e4
--- /dev/null
+++ b/devel/linux-f10-sdl12/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: linux-gtk
+# Date created: 8 October 2001
+# Whom: Martin Matuska <matuska@wu-wien.ac.at>
+# Based on: emulators/linux_base by marcel@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl
+PORTVERSION= 1.2.2.1
+CATEGORIES= devel linux
+MASTER_SITES= http://www.libsdl.org/release/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME:U}-${PORTVERSION:S/.1$/-1/}.${MACHINE_ARCH}
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= matuska@wu-wien.ac.at
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+
+USE_LINUX_PREFIX= yes
+LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+
+ONLY_FOR_ARCHS= i386 alpha
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${RPMDIR}/${DISTFILES}
+ @${LDCONFIG_LINUX}
+
+.include <bsd.port.mk>
diff --git a/devel/linux-f10-sdl12/distinfo.alpha b/devel/linux-f10-sdl12/distinfo.alpha
new file mode 100644
index 000000000000..561470d95e6f
--- /dev/null
+++ b/devel/linux-f10-sdl12/distinfo.alpha
@@ -0,0 +1 @@
+MD5 (rpm/SDL-1.2.2-1.alpha.rpm) = 35a5dce5bd3a82ae47288282350cb187
diff --git a/devel/linux-f10-sdl12/distinfo.i386 b/devel/linux-f10-sdl12/distinfo.i386
new file mode 100644
index 000000000000..9f4f75d8d792
--- /dev/null
+++ b/devel/linux-f10-sdl12/distinfo.i386
@@ -0,0 +1 @@
+MD5 (rpm/SDL-1.2.2-1.i386.rpm) = 373dc3cf57ddfa1f90bf99b16b57c7c6
diff --git a/devel/linux-f10-sdl12/pkg-comment b/devel/linux-f10-sdl12/pkg-comment
new file mode 100644
index 000000000000..7845ec8e5422
--- /dev/null
+++ b/devel/linux-f10-sdl12/pkg-comment
@@ -0,0 +1 @@
+Cross-platform multi-media development API (linux version)
diff --git a/devel/linux-f10-sdl12/pkg-descr b/devel/linux-f10-sdl12/pkg-descr
new file mode 100644
index 000000000000..3c378f3d553e
--- /dev/null
+++ b/devel/linux-f10-sdl12/pkg-descr
@@ -0,0 +1,10 @@
+Unstable development version of the SDL library (linux version).
+
+This library is designed to make it easy to write games that run
+on UNIX, Win32 and BeOS using the various native high-performance
+media interfaces, (for video, audio, etc) and presenting a single
+source-code level API to your application. This is a fairly low
+level API, but using this, completely portable applications can be
+written with a great deal of flexibility.
+
+WWW: http://www.libsdl.org/
diff --git a/devel/linux-f10-sdl12/pkg-plist.alpha b/devel/linux-f10-sdl12/pkg-plist.alpha
new file mode 100644
index 000000000000..4cf03f2b997a
--- /dev/null
+++ b/devel/linux-f10-sdl12/pkg-plist.alpha
@@ -0,0 +1,8 @@
+usr/doc/SDL-1.2.2/BUGS
+usr/doc/SDL-1.2.2/COPYING
+usr/doc/SDL-1.2.2/CREDITS
+usr/doc/SDL-1.2.2/README-SDL.txt
+usr/lib/libSDL-1.1.so.0
+usr/lib/libSDL-1.2.so.0
+usr/lib/libSDL-1.2.so.0.0.2
+@dirrm usr/doc/SDL-1.2.2
diff --git a/devel/linux-f10-sdl12/pkg-plist.i386 b/devel/linux-f10-sdl12/pkg-plist.i386
new file mode 100644
index 000000000000..4cf03f2b997a
--- /dev/null
+++ b/devel/linux-f10-sdl12/pkg-plist.i386
@@ -0,0 +1,8 @@
+usr/doc/SDL-1.2.2/BUGS
+usr/doc/SDL-1.2.2/COPYING
+usr/doc/SDL-1.2.2/CREDITS
+usr/doc/SDL-1.2.2/README-SDL.txt
+usr/lib/libSDL-1.1.so.0
+usr/lib/libSDL-1.2.so.0
+usr/lib/libSDL-1.2.so.0.0.2
+@dirrm usr/doc/SDL-1.2.2