aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-understand_c
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-18 04:04:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-18 04:04:55 +0000
commite628f2910c04ae8f7039cc6308ef04d2fb41d182 (patch)
tree2478fcf2ea29bc2e44504376e8aae73687aac4f4 /devel/linux-understand_c
parent061a4e9c5782a7ee1656671bdd9c5d6e72ccac06 (diff)
downloadports-e628f2910c04ae8f7039cc6308ef04d2fb41d182.tar.gz
ports-e628f2910c04ae8f7039cc6308ef04d2fb41d182.zip
correctly brandelf linux binaries
Notes
Notes: svn path=/head/; revision=47930
Diffstat (limited to 'devel/linux-understand_c')
-rw-r--r--devel/linux-understand_c/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/linux-understand_c/Makefile b/devel/linux-understand_c/Makefile
index 0ccbda883580..f6187dc59742 100644
--- a/devel/linux-understand_c/Makefile
+++ b/devel/linux-understand_c/Makefile
@@ -22,6 +22,7 @@ NO_BUILD= yes
PREFIX_LINUX?= ${LINUXBASE}
STRIP= ${LINUXBASE}/usr/bin/strip
+BRANDELF?= /usr/bin/brandelf
FMT?= /usr/bin/fmt
CONF_DIRS= compilers configs fonts license
@@ -100,6 +101,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/pc-linux_elf/${file} \
${PREFIX}/lib/understand_c/bin/pc-linux_elf
@${STRIP} ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
+ @${BRANDELF} -t Linux ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
@if [ ! -f ${PREFIX}/bin/${file} ]; \
then \
${LN} -sf understand_c ${PREFIX}/bin/${file} ; \