aboutsummaryrefslogtreecommitdiff
path: root/devel/linuxthreads
diff options
context:
space:
mode:
authorTor Egge <tegge@FreeBSD.org>2002-06-18 20:32:21 +0000
committerTor Egge <tegge@FreeBSD.org>2002-06-18 20:32:21 +0000
commit05e2e6dbaffe2ff4a8f2d64f948f9c5830b5cc82 (patch)
treec6bef19d86b89b8095ef06339c6270090c5e565b /devel/linuxthreads
parentb2045a45ae0be3ee8013d3080bfde5dde0b0c028 (diff)
downloadports-05e2e6dbaffe2ff4a8f2d64f948f9c5830b5cc82.tar.gz
ports-05e2e6dbaffe2ff4a8f2d64f948f9c5830b5cc82.zip
Register PIC archives when INSTALL_PIC_ARCHIVE has been defined.
Defining INSTALL_LIBLTHREAD_PIC_ARCHIVE causes installation and registration of PIC archive for liblthread, which can be used to generate a shared liblthread library for a different gcc installation. Bump port revision.
Notes
Notes: svn path=/head/; revision=61524
Diffstat (limited to 'devel/linuxthreads')
-rw-r--r--devel/linuxthreads/Makefile15
-rw-r--r--devel/linuxthreads/files/patch-aa6
-rw-r--r--devel/linuxthreads/pkg-plist4
3 files changed, 23 insertions, 2 deletions
diff --git a/devel/linuxthreads/Makefile b/devel/linuxthreads/Makefile
index 537b3121c24e..6be439482f37 100644
--- a/devel/linuxthreads/Makefile
+++ b/devel/linuxthreads/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linuxthreads
PORTVERSION= 2.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= glibc
@@ -27,6 +27,9 @@ BROKEN="Requires FreeBSD 4.0 or newer"
USING_GCC3=true
MAKE_ENV+= USING_GCC3=true
.endif
+.if defined(INSTALL_LIBLTHREAD_PIC_ARCHIVE)
+MAKE_ENV+= INSTALL_LIBLTHREAD_PIC_ARCHIVE=yes
+.endif
threads_files := README.FreeBSD clone.S clone.h freebsd-compat.h getgr_r.c \
gethostby_r.c getnetby_r.c getprotoby_r.c getpw_r.c getservby_r.c \
@@ -156,6 +159,16 @@ PLIST_SUB+= PIC:="@comment "
.else
PLIST_SUB+= PIC:=""
.endif
+.if defined(INSTALL_PIC_ARCHIVE)
+PLIST_SUB+= PICARCHIVE:=""
+.else
+PLIST_SUB+= PICARCHIVE:="@comment "
+.endif
+.if defined(INSTALL_PIC_ARCHIVE) || defined(INSTALL_LIBLTHREAD_PIC_ARCHIVE)
+PLIST_SUB+= LIBLTHREADPICARCHIVE:=""
+.else
+PLIST_SUB+= LIBLTHREADPICARCHIVE:="@comment "
+.endif
.if defined(USING_GCC3)
PLIST_SUB+= GCC3ONLY:=""
PLIST_SUB+= LTHREADSHMAJOR:="3"
diff --git a/devel/linuxthreads/files/patch-aa b/devel/linuxthreads/files/patch-aa
index 02ef0dbe362c..60aad9eba75d 100644
--- a/devel/linuxthreads/files/patch-aa
+++ b/devel/linuxthreads/files/patch-aa
@@ -13,7 +13,7 @@ diff -ru ../../work/linuxthreads-2.2.3/Examples/Makefile ./Examples/Makefile
diff -ru ../../work/linuxthreads-2.2.3/Makefile ./Makefile
--- ../../work/linuxthreads-2.2.3/Makefile Wed Apr 25 21:50:59 2001
+++ ./Makefile Thu Jun 7 23:13:52 2001
-@@ -1,128 +1,84 @@
+@@ -1,128 +1,88 @@
-# Copyright (C) 1996,1997,1998,1999,2000,2001 Free Software Foundation, Inc.
-# This file is part of the GNU C Library.
+LIB=lthread
@@ -24,6 +24,10 @@ diff -ru ../../work/linuxthreads-2.2.3/Makefile ./Makefile
+.endif
+SHLIB_MINOR= 2
+
++.if defined(INSTALL_LIBLTHREAD_PIC_ARCHIVE)
++INSTALL_PIC_ARCHIVE= yes
++.endif
++
+.if !defined(MACHINE_ARCH)
+MACHINE_ARCH != /usr/bin/uname -m
+.endif
diff --git a/devel/linuxthreads/pkg-plist b/devel/linuxthreads/pkg-plist
index a916d791d674..d56248adfe35 100644
--- a/devel/linuxthreads/pkg-plist
+++ b/devel/linuxthreads/pkg-plist
@@ -1,15 +1,19 @@
lib/liblthread.a
%%PROFILE:%%lib/liblthread_p.a
+%%LIBLTHREADPICARCHIVE:%%lib/liblthread_pic.a
%%PIC:%%lib/liblthread.so
%%PIC:%%lib/liblthread.so.%%LTHREADSHMAJOR:%%.2
lib/liblgcc_r.a
%%PROFILE:%%lib/liblgcc_r_p.a
+%%PICARCHIVE:%%lib/liblgcc_r_pic.a
%%GCC3ONLY:%%lib/liblstdc++.a
%%GCC3ONLY:%%%%PROFILE:%%lib/liblstdc++_p.a
+%%GCC3ONLY:%%%%PICARCHIVE:%%lib/liblstdc++_pic.a
%%GCC3ONLY:%%%%PIC:%%lib/liblstdc++.so
%%GCC3ONLY:%%%%PIC:%%lib/liblstdc++.so.4
%%GCC3ONLY:%%lib/liblsupc++.a
%%GCC3ONLY:%%%%PROFILE:%%lib/liblsupc++_p.a
+%%GCC3ONLY:%%%%PICARCHIVE:%%lib/liblsupc++_pic.a
include/pthread/linuxthreads/pthread.h
include/pthread/linuxthreads/semaphore.h
include/pthread/linuxthreads/pt-machine.h