aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2012-07-16 22:55:45 +0000
committerBrooks Davis <brooks@FreeBSD.org>2012-07-16 22:55:45 +0000
commit49fbc3779652a451ea63441493cca76f23816517 (patch)
tree478ae95a5be566d5100e6179506493ea0ebfdb62 /devel/llvm-devel
parentf643b4fb05639495400f531de42b94df6a4bf360 (diff)
downloadports-49fbc3779652a451ea63441493cca76f23816517.tar.gz
ports-49fbc3779652a451ea63441493cca76f23816517.zip
Update to a 3.2 snapshot. OPTIONSng-ify. Reduce diffs with non-devel
ports.
Notes
Notes: svn path=/head/; revision=300985
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile83
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo4
-rw-r--r--devel/llvm-devel/pkg-plist238
4 files changed, 198 insertions, 129 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 406b94453616..17c08bb8828c 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= llvm
-DISTVERSION= 3.1.r${SVN_REV}
+DISTVERSION= 3.2.r${SVN_REV}
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -34,29 +34,52 @@ USE_PYTHON_BUILD= yes
MAKE_JOBS_SAFE= yes
# Suggested tweaks from http://llvm.org/docs/Packaging.html
-MAKE_ARGS+= REQUIRES_RTTI=1
CONFIGURE_ARGS+= --enable-shared
+MAKE_ARGS+= REQUIRES_RTTI=1
LIBNAME= libLLVM-${DISTVERSION:C/\.r[0-9]*//}svn.so
+CONFIGURE_ARGS+= --enable-bindings=none
+
+OPTIONS_DEFINE= ASSERTS DOCS LTOPLUGIN
+
+ASSERTS_DESC= Enable assertions (thread unsafe)
+LTOPLUGIN_DESC= Build LTO plugin (requires gold)
+
+MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
+ llvm-bcanalyzer.1 llvm-cov.1 llvm-config.1 llvm-diff.1 \
+ llvm-dis.1 llvm-extract.1 llvm-link.1 llvm-nm.1 \
+ llvm-prof.1 llvm-ranlib.1 llvm-stress.1 opt.1 tblgen.1
+
+LLVM_RELEASE= ${PORTVERSION:C/\.r[0-9]*//}
+PLIST_SUB+= LLVM_RELEASE=${LLVM_RELEASE}
+
+.include <bsd.port.options.mk>
+
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
.else
CONFIGURE_ARGS+= --enable-optimized
.endif
-CONFIGURE_ARGS+= --enable-bindings=none
-
-OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off \
- LTOPLUGIN "Build LTO plugin (requires gold)" off
-
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+CONFIGURE_ARGS+= --enable-docs
+BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+.else
CONFIGURE_ARGS+= --disable-docs
.endif
-MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
- llvm-bcanalyzer.1 llvm-cov.1 llvm-config.1 llvm-diff.1 \
- llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
- llvm-prof.1 llvm-ranlib.1 llvm-stress.1 opt.1 tblgen.1
+.if ${PORT_OPTIONS:MASSERTS}
+CONFIGURE_ARGS+= --enable-assertions
+.else
+CONFIGURE_ARGS+= --disable-assertions
+.endif
+
+.if ${PORT_OPTIONS:MLTOPLUGIN}
+BUILD_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
+CONFIGURE_ARGS+= --with-binutils-include=${LOCALBASE}/include
+PLIST_FILES+= lib/LLVMgold.so
+.endif
.include <bsd.port.pre.mk>
@@ -81,19 +104,6 @@ CONFIGURE_ARGS+= --enable-pic --with-pic
CONFIGURE_ARGS+= --with-optimize-option=-O2
.endif
-.ifdef(WITH_ASSERTS)
-CONFIGURE_ARGS+= --enable-assertions
-.else
-CONFIGURE_ARGS+= --disable-assertions
-.endif
-
-.ifdef(WITH_LTOPLUGIN)
-BUILD_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
-RUN_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
-CONFIGURE_ARGS+= --with-binutils-include=${LOCALBASE}/include
-PLIST_FILES+= lib/LLVMgold.so
-.endif
-
.if defined(BOOTSTRAP) || defined(SVN_FETCH)
FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
@@ -115,17 +125,20 @@ post-patch:
${REINPLACE_CMD} -e 's|\(PROJ_mandir.*:=\).*$$|\1${MANPREFIX}/man|g' \
${WRKSRC}/Makefile.config.in
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-build:
- @cd ${WRKSRC}/docs/CommandGuide && ${GMAKE} ${MAN1}
+ @cd ${WRKSRC}/docs && ${GMAKE} -f Makefile.sphinx man html
.endif
post-install:
- mv ${PREFIX}/lib/${LIBNAME} ${PREFIX}/lib/${LIBNAME}.0
- ln -s ${LIBNAME}.0 ${PREFIX}/lib/${LIBNAME}
-.if defined(NOPORTDOCS)
+ ${MV} ${PREFIX}/lib/${LIBNAME} ${PREFIX}/lib/${LIBNAME}.0
+ ${LN} -s ${LIBNAME}.0 ${PREFIX}/lib/${LIBNAME}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/html
+ find ${WRKSRC}/docs/_build/html -type f | \
+ xargs -I _DOC_ ${INSTALL_DATA} _DOC_ ${DOCSDIR}/html/
.for man in ${MAN1}
- @${INSTALL_MAN} ${WRKSRC}/docs/CommandGuide/${man} \
+ @${INSTALL_MAN} ${WRKSRC}/docs/_build/man/${man} \
${MANPREFIX}/man/man1/
.endfor
.endif
@@ -145,19 +158,19 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/llvm* \
bin/macho-dump \
bin/opt \
- lib/LLVMHello.so \
lib/BugpointPasses.so \
+ lib/LLVMHello.so \
lib/libLTO.* \
lib/libLLVM* \
- lib/libprofile_rt.so \
- lib/libprofile_rt.a
+ lib/libprofile_rt.a \
+ lib/libprofile_rt.so
PLIST_DIR_LIST= include/llvm-c \
include/llvm
build-plist:
${RM} -f ${PLIST}
cd ${PREFIX} && \
(ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
- ${SED} -e 's|${PORTVERSION}|%%PORTVERSION%%|' | \
+ ${SED} -e 's|${LLVM_RELEASE}|%%LLVM_RELEASE%%|' | \
${SORT} >> ${PLIST}
${FIND} ${DOCSDIR} -type f | \
${SED} -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | \
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 9b88a515891a..6d7c115cd43f 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 154687
+SVN_REV= 160283
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 5e2208cfbe91..7c2d76eac2e3 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-3.1.r154687.tar.bz2) = d63d8bb08c85076d3b7398b062370b3617eb25c24e4a275c1ada7d634b30dc24
-SIZE (llvm-3.1.r154687.tar.bz2) = 8631665
+SHA256 (llvm-3.2.r160283.tar.bz2) = 3dfae804e7765bfacfb4347ada59e174fa9f4a272ee86b17ae6882e5f3e56ca7
+SIZE (llvm-3.2.r160283.tar.bz2) = 8961712
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index dfb79eb60201..be25e6ca24db 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -10,7 +10,6 @@ bin/llvm-diff
bin/llvm-dis
bin/llvm-dwarfdump
bin/llvm-extract
-bin/llvm-ld
bin/llvm-link
bin/llvm-mc
bin/llvm-nm
@@ -21,7 +20,6 @@ bin/llvm-readobj
bin/llvm-rtdyld
bin/llvm-size
bin/llvm-stress
-bin/llvm-stub
bin/llvm-tblgen
bin/macho-dump
bin/opt
@@ -34,6 +32,7 @@ include/llvm-c/EnhancedDisassembly.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/Initialization.h
include/llvm-c/LinkTimeOptimizer.h
+include/llvm-c/Linker.h
include/llvm-c/Object.h
include/llvm-c/Target.h
include/llvm-c/TargetMachine.h
@@ -113,9 +112,7 @@ include/llvm/Analysis/CaptureTracking.h
include/llvm/Analysis/CodeMetrics.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
-include/llvm/Analysis/DIBuilder.h
include/llvm/Analysis/DOTGraphTraitsPass.h
-include/llvm/Analysis/DebugInfo.h
include/llvm/Analysis/DomPrinter.h
include/llvm/Analysis/DominanceFrontier.h
include/llvm/Analysis/DominatorInternals.h
@@ -134,6 +131,7 @@ include/llvm/Analysis/Lint.h
include/llvm/Analysis/Loads.h
include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
+include/llvm/Analysis/LoopInfoImpl.h
include/llvm/Analysis/LoopIterator.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/MemoryBuiltins.h
@@ -232,10 +230,11 @@ include/llvm/CodeGen/PBQP/Heuristics/Briggs.h
include/llvm/CodeGen/PBQP/Math.h
include/llvm/CodeGen/PBQP/Solution.h
include/llvm/CodeGen/Passes.h
-include/llvm/CodeGen/ProcessImplicitDefs.h
include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocPBQP.h
include/llvm/CodeGen/RegAllocRegistry.h
+include/llvm/CodeGen/RegisterClassInfo.h
+include/llvm/CodeGen/RegisterPressure.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/ResourcePriorityQueue.h
include/llvm/CodeGen/RuntimeLibcalls.h
@@ -259,6 +258,8 @@ include/llvm/Config/config.h
include/llvm/Config/llvm-config.h
include/llvm/Constant.h
include/llvm/Constants.h
+include/llvm/DIBuilder.h
+include/llvm/DebugInfo.h
include/llvm/DebugInfo/DIContext.h
include/llvm/DefaultPasses.h
include/llvm/DerivedTypes.h
@@ -277,6 +278,7 @@ include/llvm/GVMaterializer.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
include/llvm/GlobalVariable.h
+include/llvm/IRBuilder.h
include/llvm/InitializePasses.h
include/llvm/InlineAsm.h
include/llvm/InstrTypes.h
@@ -290,8 +292,10 @@ include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsHexagon.td
-include/llvm/IntrinsicsPTX.td
+include/llvm/IntrinsicsMips.td
+include/llvm/IntrinsicsNVVM.td
include/llvm/IntrinsicsPowerPC.td
+include/llvm/IntrinsicsR600.td
include/llvm/IntrinsicsX86.td
include/llvm/IntrinsicsXCore.td
include/llvm/LLVMContext.h
@@ -337,6 +341,7 @@ include/llvm/MC/MCParser/MCAsmParser.h
include/llvm/MC/MCParser/MCAsmParserExtension.h
include/llvm/MC/MCParser/MCParsedAsmOperand.h
include/llvm/MC/MCRegisterInfo.h
+include/llvm/MC/MCSchedule.h
include/llvm/MC/MCSection.h
include/llvm/MC/MCSectionCOFF.h
include/llvm/MC/MCSectionELF.h
@@ -352,6 +357,7 @@ include/llvm/MC/MCWinCOFFObjectWriter.h
include/llvm/MC/MachineLocation.h
include/llvm/MC/SectionKind.h
include/llvm/MC/SubtargetFeature.h
+include/llvm/MDBuilder.h
include/llvm/Metadata.h
include/llvm/Module.h
include/llvm/Object/Archive.h
@@ -411,14 +417,15 @@ include/llvm/Support/GCOV.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
include/llvm/Support/Host.h
-include/llvm/Support/IRBuilder.h
include/llvm/Support/IRReader.h
include/llvm/Support/IncludeFile.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
-include/llvm/Support/JSONParser.h
+include/llvm/Support/IntegersSubset.h
+include/llvm/Support/IntegersSubsetMapping.h
include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
+include/llvm/Support/Locale.h
include/llvm/Support/LockFileManager.h
include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
@@ -464,7 +471,6 @@ include/llvm/Support/Threading.h
include/llvm/Support/TimeValue.h
include/llvm/Support/Timer.h
include/llvm/Support/ToolOutputFile.h
-include/llvm/Support/TypeBuilder.h
include/llvm/Support/Valgrind.h
include/llvm/Support/ValueHandle.h
include/llvm/Support/Win64EH.h
@@ -478,6 +484,7 @@ include/llvm/SymbolTableListTraits.h
include/llvm/TableGen/Error.h
include/llvm/TableGen/Main.h
include/llvm/TableGen/Record.h
+include/llvm/TableGen/StringMatcher.h
include/llvm/TableGen/TableGenAction.h
include/llvm/TableGen/TableGenBackend.h
include/llvm/Target/Mangler.h
@@ -489,6 +496,7 @@ include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameLowering.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetIntrinsicInfo.h
+include/llvm/Target/TargetItinerary.td
include/llvm/Target/TargetJITInfo.h
include/llvm/Target/TargetLibraryInfo.h
include/llvm/Target/TargetLowering.h
@@ -511,7 +519,7 @@ include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/BuildLibCalls.h
include/llvm/Transforms/Utils/Cloning.h
include/llvm/Transforms/Utils/CmpInstAnalysis.h
-include/llvm/Transforms/Utils/FunctionUtils.h
+include/llvm/Transforms/Utils/CodeExtractor.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/ModuleUtils.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
@@ -523,14 +531,18 @@ include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Transforms/Vectorize.h
include/llvm/Type.h
+include/llvm/TypeBuilder.h
include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
lib/BugpointPasses.so
lib/LLVMHello.so
-lib/libLLVM-3.1svn.so
-lib/libLLVM-3.1svn.so.0
+lib/libLLVM-%%LLVM_RELEASE%%svn.so
+lib/libLLVM-%%LLVM_RELEASE%%svn.so.0
+lib/libLLVMAMDGPUCodeGen.a
+lib/libLLVMAMDGPUDesc.a
+lib/libLLVMAMDGPUInfo.a
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
@@ -579,12 +591,13 @@ lib/libLLVMMipsAsmParser.a
lib/libLLVMMipsAsmPrinter.a
lib/libLLVMMipsCodeGen.a
lib/libLLVMMipsDesc.a
+lib/libLLVMMipsDisassembler.a
lib/libLLVMMipsInfo.a
+lib/libLLVMNVPTXAsmPrinter.a
+lib/libLLVMNVPTXCodeGen.a
+lib/libLLVMNVPTXDesc.a
+lib/libLLVMNVPTXInfo.a
lib/libLLVMObject.a
-lib/libLLVMPTXAsmPrinter.a
-lib/libLLVMPTXCodeGen.a
-lib/libLLVMPTXDesc.a
-lib/libLLVMPTXInfo.a
lib/libLLVMPowerPCAsmPrinter.a
lib/libLLVMPowerPCCodeGen.a
lib/libLLVMPowerPCDesc.a
@@ -616,121 +629,168 @@ lib/libLTO.a
lib/libLTO.so
lib/libprofile_rt.a
lib/libprofile_rt.so
-%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
+%%PORTDOCS%%%%DOCSDIR%%/html/.buildinfo
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.html
+%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Atomics.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Atomics.txt
%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.html
+%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.txt
%%PORTDOCS%%%%DOCSDIR%%/html/BranchWeightMetadata.html
+%%PORTDOCS%%%%DOCSDIR%%/html/BranchWeightMetadata.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Bugpoint.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Bugpoint.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CMake.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CMake.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CodeGenerator.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/FileCheck.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/bugpoint.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/index.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/lit.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llc.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/lli.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-as.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-build.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-config.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-cov.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-diff.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ld.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-link.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-stress.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/manpage.css
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/opt.html
-%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/tblgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.txt
%%PORTDOCS%%%%DOCSDIR%%/html/CommandLine.html
%%PORTDOCS%%%%DOCSDIR%%/html/CompilerWriterInfo.html
%%PORTDOCS%%%%DOCSDIR%%/html/DebuggingJITedCode.html
%%PORTDOCS%%%%DOCSDIR%%/html/DeveloperPolicy.html
+%%PORTDOCS%%%%DOCSDIR%%/html/DeveloperPolicy.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ExceptionHandling.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ExceptionHandling.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ExtendingLLVM.html
%%PORTDOCS%%%%DOCSDIR%%/html/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/FileCheck.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FileCheck.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GCCFEBuildInstrs.html
%%PORTDOCS%%%%DOCSDIR%%/html/GarbageCollection.html
%%PORTDOCS%%%%DOCSDIR%%/html/GetElementPtr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/GetElementPtr.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.txt
%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToAddABuilder.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.html
%%PORTDOCS%%%%DOCSDIR%%/html/LLVMBuild.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LangImpl8.html
%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.html
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.txt
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.txt
%%PORTDOCS%%%%DOCSDIR%%/html/MakefileGuide.html
+%%PORTDOCS%%%%DOCSDIR%%/html/MakefileGuide.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/OCamlLangImpl8.html
%%PORTDOCS%%%%DOCSDIR%%/html/Packaging.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Packaging.txt
%%PORTDOCS%%%%DOCSDIR%%/html/Passes.html
%%PORTDOCS%%%%DOCSDIR%%/html/ProgrammersManual.html
%%PORTDOCS%%%%DOCSDIR%%/html/Projects.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Projects.txt
%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
%%PORTDOCS%%%%DOCSDIR%%/html/SegmentedStacks.html
+%%PORTDOCS%%%%DOCSDIR%%/html/SegmentedStacks.txt
%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.html
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.txt
%%PORTDOCS%%%%DOCSDIR%%/html/TestSuiteMakefileGuide.html
%%PORTDOCS%%%%DOCSDIR%%/html/TestingGuide.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMBackend.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMPass.html
-%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/html/img/Debugging.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/img/libdeps.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/img/lines.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/img/objdeps.gif
-%%PORTDOCS%%%%DOCSDIR%%/html/img/venusflytrap.jpg
+%%PORTDOCS%%%%DOCSDIR%%/html/ajax-loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/html/bugpoint.html
+%%PORTDOCS%%%%DOCSDIR%%/html/bugpoint.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/html/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/html/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/html/contents.png
+%%PORTDOCS%%%%DOCSDIR%%/html/design_and_overview.html
+%%PORTDOCS%%%%DOCSDIR%%/html/design_and_overview.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/development_process.html
+%%PORTDOCS%%%%DOCSDIR%%/html/development_process.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/down-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/down.png
+%%PORTDOCS%%%%DOCSDIR%%/html/file.png
+%%PORTDOCS%%%%DOCSDIR%%/html/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/html/lines.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/lit.html
+%%PORTDOCS%%%%DOCSDIR%%/html/lit.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llc.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/lli.html
+%%PORTDOCS%%%%DOCSDIR%%/html/lli.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-ar.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-ar.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-as.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-as.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-bcanalyzer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-bcanalyzer.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-build.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-build.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-config.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-config.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-cov.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-cov.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-diff.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-diff.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-dis.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-dis.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-extract.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-extract.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-link.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-link.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-nm.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-nm.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-prof.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-prof.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-ranlib.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-ranlib.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-stress.html
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-stress.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/llvm-theme.css
%%PORTDOCS%%%%DOCSDIR%%/html/llvm.css
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl3.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl4.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl5-cfg.png
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl5.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl6.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl7.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl8.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl1.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl2.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl3.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl4.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl5.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl8.html
-%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/index.html
-%%PORTDOCS%%%%DOCSDIR%%/ps/FileCheck.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/bugpoint.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/lit.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llc.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/lli.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ar.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-as.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-build.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-config.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-cov.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-diff.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-dis.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-extract.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ld.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-link.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-nm.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-prof.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ranlib.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-stress.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/opt.ps
-%%PORTDOCS%%%%DOCSDIR%%/ps/tblgen.ps
+%%PORTDOCS%%%%DOCSDIR%%/html/logo.png
+%%PORTDOCS%%%%DOCSDIR%%/html/mailing_lists.html
+%%PORTDOCS%%%%DOCSDIR%%/html/mailing_lists.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/navigation.png
+%%PORTDOCS%%%%DOCSDIR%%/html/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/html/opt.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opt.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/html/programming.html
+%%PORTDOCS%%%%DOCSDIR%%/html/programming.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/html/search.html
+%%PORTDOCS%%%%DOCSDIR%%/html/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/html/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/html/subsystems.html
+%%PORTDOCS%%%%DOCSDIR%%/html/subsystems.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/tblgen.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tblgen.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/html/up-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/up.png
+%%PORTDOCS%%%%DOCSDIR%%/html/userguides.html
+%%PORTDOCS%%%%DOCSDIR%%/html/userguides.txt
+%%PORTDOCS%%%%DOCSDIR%%/html/websupport.js
@dirrm include/llvm/Transforms/Utils
@dirrm include/llvm/Transforms/IPO
@dirrm include/llvm/Transforms
@@ -753,9 +813,5 @@ lib/libprofile_rt.so
@dirrm include/llvm-c/Transforms
@dirrm include/llvm-c
@dirrm include/llvm
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/ps
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/tutorial
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/img
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/html/CommandGuide
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%