aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-03-27 13:52:07 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-03-27 13:52:07 +0000
commit0f0fcedda9eb7615986453a3e57b70002afceab3 (patch)
tree67934889a410d7bdf01a1b21846be614a333d4af /devel/llvm-devel
parent38d61adadda33c5a67a08eec90cdd837ba299a66 (diff)
downloadports-0f0fcedda9eb7615986453a3e57b70002afceab3.tar.gz
ports-0f0fcedda9eb7615986453a3e57b70002afceab3.zip
Upgrade to r67766.
The most visiable change is that what was bin/clang is now installed as libexec/clang-cc and bin/clang is the new C++ driver which will eventually replace ccc.
Notes
Notes: svn path=/head/; revision=231116
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile5
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/pkg-plist9
3 files changed, 10 insertions, 10 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 10d4625d1280..11963d1d0587 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.if defined(BOOTSTRAP)
SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | grep Revision | cut -d' ' -f2
.else
-SVN_REV= 66031
+SVN_REV= 67766
.endif
GNU_CONFIGURE= yes
@@ -117,7 +117,8 @@ PLIST_FILE_LIST= bin/bugpoint \
lib/libLTO.so \
lib/libLLVM* \
lib/libclang* \
- lib/plugin_llvm*
+ lib/plugin_llvm* \
+ libexec/clang-cc
PLIST_DIR_LIST= bin/ccclib \
include/llvm-c \
include/llvm \
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index c4731f452a59..f6ca0ab632a6 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.6.r66031.tar.bz2) = 51044a5dad8853a6e126df3fb1be51c5
-SHA256 (llvm-2.6.r66031.tar.bz2) = 9f10097556f39687fd69ef5c78fd6684516fee6b50cdca9ade6b3f4472de4693
-SIZE (llvm-2.6.r66031.tar.bz2) = 7456953
+MD5 (llvm-2.6.r67766.tar.bz2) = 9a173e38f458e24b380118b547047b8b
+SHA256 (llvm-2.6.r67766.tar.bz2) = 5edf5eac14583e4d1d62b7b6f8ba6d7a1306747062e8e2ed841a682b940ae8f7
+SIZE (llvm-2.6.r67766.tar.bz2) = 7555248
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 47228b969386..b105797f82cd 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -22,7 +22,6 @@ bin/ccclib/Util.pyc
bin/ccclib/__init__.py
bin/ccclib/__init__.pyc
bin/clang
-bin/clang-driver
bin/gccas
bin/gccld
bin/llc
@@ -50,6 +49,7 @@ include/llvm-c/Core.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm-c/Target.h
+include/llvm-c/Transforms/IPO.h
include/llvm-c/Transforms/Scalar.h
include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
@@ -90,10 +90,6 @@ include/llvm/ADT/Tree.h
include/llvm/ADT/Trie.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
-include/llvm/ADT/hash_map.cmake
-include/llvm/ADT/hash_map.h
-include/llvm/ADT/hash_set.cmake
-include/llvm/ADT/hash_set.h
include/llvm/ADT/ilist.h
include/llvm/ADT/ilist_node.h
include/llvm/ADT/iterator.cmake
@@ -115,6 +111,7 @@ include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
+include/llvm/Analysis/LiveValues.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/LoopVR.h
@@ -298,6 +295,7 @@ include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
include/llvm/Support/PredIteratorCache.h
+include/llvm/Support/PrettyStackTrace.h
include/llvm/Support/Recycler.h
include/llvm/Support/RecyclingAllocator.h
include/llvm/Support/Registry.h
@@ -433,6 +431,7 @@ lib/libclangRewrite.a
lib/libclangSema.a
lib/plugin_llvmc_Base.o
lib/plugin_llvmc_Clang.o
+libexec/clang-cc
%%DATADIR%%/scanview.css
%%DATADIR%%/sorttable.js
%%DOCSDIR%%/html.tar.gz