aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-03-03 21:05:18 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-03-03 21:05:18 +0000
commite79bca44d7215af538a9cea3ab4e6fa6b32b6d21 (patch)
tree7d3517ee427c13a1ec286be18203c5027912f297 /devel/llvm-devel
parentfdf9836e89bd6cec8f5c7cef48cfe7413c35db66 (diff)
downloadports-e79bca44d7215af538a9cea3ab4e6fa6b32b6d21.tar.gz
ports-e79bca44d7215af538a9cea3ab4e6fa6b32b6d21.zip
Catch a few files and directories I should have noticed during the
previous update. Reported by: QAT
Notes
Notes: svn path=/head/; revision=229438
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile56
-rw-r--r--devel/llvm-devel/pkg-plist5
2 files changed, 36 insertions, 25 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 0d2e7eaafdd7..b94866d2fe5e 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= llvm
DISTVERSION= 2.6.r${SVN_REV}
+PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -101,36 +102,41 @@ regression-test: ${BUILD_COOKIE}
${SH} -c ${TEST_CMD}; \
fi
-MANUAL_BINS= bin/bugpoint \
- bin/ccc \
- bin/ccc-analyzer \
- bin/clang \
- bin/gccas \
- bin/gccld \
- bin/llc \
- bin/lli \
- bin/opt \
- bin/scan-build
-MANUAL_LIBS= lib/libLTO.so
+PLIST_FILE_LIST= bin/bugpoint \
+ bin/ccc \
+ bin/ccc-analyzer \
+ bin/clang* \
+ bin/gccas \
+ bin/gccld \
+ bin/llc \
+ bin/lli \
+ bin/llvm* \
+ bin/opt \
+ bin/scan-build \
+ lib/CompilerDriver.o \
+ lib/LLVM* \
+ lib/libLTO.so \
+ lib/libLLVM* \
+ lib/libclang* \
+ lib/plugin_llvm*
+PLIST_DIR_LIST= bin/ccclib \
+ include/llvm-c \
+ include/llvm \
+ lib/clang
build-plist:
${RM} ${PLIST}
cd ${PREFIX} && \
- (ls ${MANUAL_BINS} bin/llvm* bin/ccclib/* ${MANUAL_LIBS} \
- lib/LLVM* lib/libLLVM* lib/plugin_llvm* lib/libclang* ; \
- ${FIND} include/llvm-c -type f; ${FIND} include/llvm lib/clang \
- -type f) | \
+ (ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
${SORT} >> ${PLIST}
- ${FIND} ${DATADIR} -type f | ${SORT} | \
- ${SED} -e 's|${DATADIR}|%%DATADIR%%|' >> ${PLIST}
- ${FIND} ${DOCSDIR} -type f | ${SORT} | \
- ${SED} -e 's|${DOCSDIR}|%%DOCSDIR%%|' >> ${PLIST}
+ ${FIND} ${DATADIR} ${DOCSDIR} -type f | \
+ ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+ -e 's|${DOCSDIR}|%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
cd ${PREFIX} && \
- (echo bin/ccclib; \
- ${FIND} include/llvm-c -type d; ${FIND} include/llvm -type d) | \
+ ${FIND} ${PLIST_DIR_LIST} -type d | \
${SORT} -r | ${SED} -e 's|^|@dirrm |' >> ${PLIST}
- ${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} -e 's|${DATADIR}|%%DATADIR%%|' -e 's|^|@dirrm |' >> ${PLIST}
- ${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
- ${SED} -e 's|${DOCSDIR}|%%DOCSDIR%%|' -e 's|^|@dirrm |' >> ${PLIST}
+ ${FIND} ${DATADIR} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+ -e 's|${DOCSDIR}|%%DOCSDIR%%|' \
+ -e 's|^|@dirrm |' >> ${PLIST}
.include <bsd.port.post.mk>
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index b8e43c62a878..366b6a3725fb 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -22,6 +22,7 @@ bin/ccclib/Util.pyc
bin/ccclib/__init__.py
bin/ccclib/__init__.pyc
bin/clang
+bin/clang-driver
bin/gccas
bin/gccld
bin/llc
@@ -370,6 +371,7 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
+lib/CompilerDriver.o
lib/LLVMARMAsmPrinter.o
lib/LLVMARMCodeGen.o
lib/LLVMAlphaAsmPrinter.o
@@ -546,6 +548,9 @@ lib/plugin_llvmc_Clang.o
%%DOCSDIR%%/ps/llvmgxx.ps
%%DOCSDIR%%/ps/opt.ps
%%DOCSDIR%%/ps/tblgen.ps
+@dirrm lib/clang/1.0/include
+@dirrm lib/clang/1.0
+@dirrm lib/clang
@dirrm include/llvm/Transforms/Utils
@dirrm include/llvm/Transforms/IPO
@dirrm include/llvm/Transforms