aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-10-24 23:03:59 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-10-24 23:03:59 +0000
commit95e3ccce00139d07a42ae452916cf042c4b664bc (patch)
tree2ad6ba37ed969bcf995dafeace4ddcc0b81d1aa2 /devel/llvm29
parentebb9460b06f6e52920074d94fbc3399e1776e168 (diff)
downloadports-95e3ccce00139d07a42ae452916cf042c4b664bc.tar.gz
ports-95e3ccce00139d07a42ae452916cf042c4b664bc.zip
Upgrade to LLVM 2.6.
Notes
Notes: svn path=/head/; revision=243273
Diffstat (limited to 'devel/llvm29')
-rw-r--r--devel/llvm29/Makefile35
-rw-r--r--devel/llvm29/distinfo9
-rw-r--r--devel/llvm29/pkg-plist164
3 files changed, 148 insertions, 60 deletions
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
index 98b6a81dec47..9cd67a3f04cb 100644
--- a/devel/llvm29/Makefile
+++ b/devel/llvm29/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= llvm
-PORTVERSION= 2.5
+PORTVERSION= 2.6
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
MAINTAINER= brooks@FreeBSD.org
COMMENT= Low Level Virtual Machine
-CONFLICTS= llvm-2.4.s* llvm-2.6.r*
-
.if defined(PACKAGE_BUILDING) || defined(MAINTAINER_MODE)
BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
.endif
@@ -22,9 +20,13 @@ BUILD_DEPENDS= runtest:${PORTSDIR}/misc/dejagnu
BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.endif
+CONFLICTS= llvm-2.[12345]* llvm-2.7.r*
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
+MAKE_JOBS_SAFE= yes
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
@@ -58,14 +60,6 @@ post-patch:
${REINPLACE_CMD} -e 's|%%DOCSRCDIR%%|${DOCSRCDIR}|' \
${WRKSRC}/Makefile
-post-build:
- cd ${WRKSRC}/docs/CommandGuide && \
- ${GMAKE} man
-
-post-install:
- cd ${WRKSRC}/docs/CommandGuide && \
- ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1/
-
TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check)'
regression-test: ${BUILD_COOKIE}
if [ `${ID} -u` = 0 ]; then \
@@ -82,23 +76,28 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/lli \
bin/llvm* \
bin/opt \
- lib/LLVM* \
+ bin/tblgen \
+ lib/libCompilerDriver.a \
+ lib/libLTO.* \
lib/libLLVM* \
- lib/plugin_llvm*
+ lib/libplugin_llvmc* \
+ lib/libprofile_rt.so
PLIST_DIR_LIST= include/llvm-c \
include/llvm
build-plist:
- ${RM} ${PLIST}
+ ${RM} -f ${PLIST}
cd ${PREFIX} && \
(ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
${SORT} >> ${PLIST}
- ${FIND} ${DOCSDIR} -type f | \
- ${SED} -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
+ ${FIND} ${DATADIR} ${DOCSDIR} -type f | \
+ ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+ -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | ${SORT} >> ${PLIST}
cd ${PREFIX} && \
${FIND} ${PLIST_DIR_LIST} -type d | \
${SORT} -r | ${SED} -e 's|^|@dirrm |' >> ${PLIST}
${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
- ${SED} -e 's|^|%%PORTDOCS%%@dirrm |' \
- -e 's|${DOCSDIR}|%%DOCSDIR%%|' >> ${PLIST}
+ ${SED} -e 's|${DATADIR}|%%DATADIR%%|' \
+ -e 's|${DOCSDIR}|%%DOCSDIR%%|' \
+ -e 's|^|%%PORTDOCS%%@dirrm |' >> ${PLIST}
.include <bsd.port.post.mk>
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
index 745bcc4590ec..2ca85665166e 100644
--- a/devel/llvm29/distinfo
+++ b/devel/llvm29/distinfo
@@ -1,3 +1,6 @@
-MD5 (llvm-2.5.tar.gz) = 55df2ea8665c8094ad2ef85187b9fc74
-SHA256 (llvm-2.5.tar.gz) = 8f3d69e63bc5d1ee2c2ee49ff07ccb7e070070a0e937813d2a6179b9e2e173ed
-SIZE (llvm-2.5.tar.gz) = 6660609
+MD5 (llvm-2.6.tar.gz) = 34a11e807add0f4555f691944e1a404a
+SHA256 (llvm-2.6.tar.gz) = 4cd9257350c5ff8b9b139d19497e2396c0604eef0e5d6504f5c1463b09bf2d84
+SIZE (llvm-2.6.tar.gz) = 7790380
+MD5 (clang-2.6.tar.gz) = 09d696bf23bb4a3cf6af3c7341cdd946
+SHA256 (clang-2.6.tar.gz) = 98e22f4f5877fb3c73abb9ddcb3065ba9c94a21146387da7f905e6fd559d39ea
+SIZE (clang-2.6.tar.gz) = 3857138
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index 7da13f24fff8..42334cc7b087 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -18,6 +18,7 @@ bin/llvm-ranlib
bin/llvm-stub
bin/llvmc
bin/opt
+bin/tblgen
include/llvm-c/Analysis.h
include/llvm-c/BitReader.h
include/llvm-c/BitWriter.h
@@ -25,6 +26,7 @@ include/llvm-c/Core.h
include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm-c/Target.h
+include/llvm-c/Transforms/IPO.h
include/llvm-c/Transforms/Scalar.h
include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
@@ -32,6 +34,7 @@ include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DenseMap.h
+include/llvm/ADT/DenseMapInfo.h
include/llvm/ADT/DenseSet.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
@@ -45,6 +48,7 @@ include/llvm/ADT/IndexedMap.h
include/llvm/ADT/IntrusiveRefCntPtr.h
include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PointerIntPair.h
+include/llvm/ADT/PointerUnion.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/PriorityQueue.h
include/llvm/ADT/SCCIterator.h
@@ -60,15 +64,13 @@ include/llvm/ADT/SparseBitVector.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
+include/llvm/ADT/StringRef.h
include/llvm/ADT/StringSet.h
-include/llvm/ADT/Tree.h
include/llvm/ADT/Trie.h
+include/llvm/ADT/Triple.h
+include/llvm/ADT/Twine.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
-include/llvm/ADT/hash_map.cmake
-include/llvm/ADT/hash_map.h
-include/llvm/ADT/hash_set.cmake
-include/llvm/ADT/hash_set.h
include/llvm/ADT/ilist.h
include/llvm/ADT/ilist_node.h
include/llvm/ADT/iterator.cmake
@@ -85,16 +87,20 @@ include/llvm/Analysis/DebugInfo.h
include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
+include/llvm/Analysis/IVUsers.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LibCallAliasAnalysis.h
include/llvm/Analysis/LibCallSemantics.h
+include/llvm/Analysis/LiveValues.h
+include/llvm/Analysis/LoopDependenceAnalysis.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/LoopVR.h
include/llvm/Analysis/MemoryDependenceAnalysis.h
include/llvm/Analysis/Passes.h
+include/llvm/Analysis/PointerTracking.h
include/llvm/Analysis/PostDominators.h
include/llvm/Analysis/ProfileInfo.h
include/llvm/Analysis/ProfileInfoLoader.h
@@ -128,10 +134,11 @@ include/llvm/CMakeLists.txt
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/BreakCriticalMachineEdge.h
include/llvm/CodeGen/CallingConvLower.h
include/llvm/CodeGen/DAGISelHeader.h
-include/llvm/CodeGen/DebugLoc.h
+include/llvm/CodeGen/Dump.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FastISel.h
@@ -141,7 +148,9 @@ include/llvm/CodeGen/GCMetadataPrinter.h
include/llvm/CodeGen/GCStrategy.h
include/llvm/CodeGen/GCs.h
include/llvm/CodeGen/IntrinsicLowering.h
+include/llvm/CodeGen/JITCodeEmitter.h
include/llvm/CodeGen/LatencyPriorityQueue.h
+include/llvm/CodeGen/LazyLiveness.h
include/llvm/CodeGen/LinkAllAsmWriterComponents.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
@@ -151,10 +160,12 @@ include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachORelocation.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
+include/llvm/CodeGen/MachineCodeInfo.h
include/llvm/CodeGen/MachineConstantPool.h
include/llvm/CodeGen/MachineDominators.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
+include/llvm/CodeGen/MachineFunctionAnalysis.h
include/llvm/CodeGen/MachineFunctionPass.h
include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
@@ -167,6 +178,7 @@ include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
+include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocRegistry.h
@@ -174,8 +186,6 @@ include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
-include/llvm/CodeGen/ScheduleDAGInstrs.h
-include/llvm/CodeGen/ScheduleDAGSDNodes.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
@@ -184,10 +194,18 @@ include/llvm/CodeGen/SelectionDAGNodes.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/CompilerDriver/Action.h
+include/llvm/CompilerDriver/BuiltinOptions.h
include/llvm/CompilerDriver/Common.td
include/llvm/CompilerDriver/CompilationGraph.h
+include/llvm/CompilerDriver/Error.h
+include/llvm/CompilerDriver/ForceLinkage.h
+include/llvm/CompilerDriver/ForceLinkageMacros.h
+include/llvm/CompilerDriver/Main.inc
include/llvm/CompilerDriver/Plugin.h
include/llvm/CompilerDriver/Tool.h
+include/llvm/Config/AsmParsers.def
+include/llvm/Config/AsmPrinters.def
+include/llvm/Config/Targets.def
include/llvm/Config/alloca.h
include/llvm/Config/config.h
include/llvm/Config/config.h.cmake
@@ -204,6 +222,7 @@ include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
+include/llvm/ExecutionEngine/JITEventListener.h
include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/Function.h
include/llvm/GlobalAlias.h
@@ -220,16 +239,32 @@ include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
include/llvm/IntrinsicsAlpha.td
+include/llvm/IntrinsicsBlackfin.td
include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
include/llvm/IntrinsicsXCore.td
+include/llvm/LLVMContext.h
include/llvm/LinkAllPasses.h
include/llvm/LinkAllVMCore.h
include/llvm/Linker.h
+include/llvm/MC/MCAsmLexer.h
+include/llvm/MC/MCAsmParser.h
+include/llvm/MC/MCAssembler.h
+include/llvm/MC/MCContext.h
+include/llvm/MC/MCInst.h
+include/llvm/MC/MCSection.h
+include/llvm/MC/MCSectionELF.h
+include/llvm/MC/MCSectionMachO.h
+include/llvm/MC/MCStreamer.h
+include/llvm/MC/MCSymbol.h
+include/llvm/MC/MCValue.h
+include/llvm/MC/SectionKind.h
+include/llvm/Metadata.h
include/llvm/Module.h
include/llvm/ModuleProvider.h
include/llvm/OperandTraits.h
+include/llvm/Operator.h
include/llvm/Pass.h
include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
@@ -238,7 +273,6 @@ include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
-include/llvm/Support/Annotation.h
include/llvm/Support/CFG.h
include/llvm/Support/CallSite.h
include/llvm/Support/Casting.h
@@ -251,11 +285,14 @@ include/llvm/Support/DataFlow.h
include/llvm/Support/DataTypes.h
include/llvm/Support/DataTypes.h.cmake
include/llvm/Support/Debug.h
+include/llvm/Support/DebugLoc.h
include/llvm/Support/Dwarf.h
include/llvm/Support/DynamicLinker.h
include/llvm/Support/ELF.h
+include/llvm/Support/ErrorHandling.h
include/llvm/Support/FileUtilities.h
include/llvm/Support/Format.h
+include/llvm/Support/FormattedStream.h
include/llvm/Support/GetElementPtrTypeIterator.h
include/llvm/Support/GraphWriter.h
include/llvm/Support/IRBuilder.h
@@ -266,30 +303,39 @@ include/llvm/Support/ManagedStatic.h
include/llvm/Support/Mangler.h
include/llvm/Support/MathExtras.h
include/llvm/Support/MemoryBuffer.h
+include/llvm/Support/MemoryObject.h
include/llvm/Support/MutexGuard.h
include/llvm/Support/NoFolder.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
+include/llvm/Support/PointerLikeTypeTraits.h
include/llvm/Support/PredIteratorCache.h
+include/llvm/Support/PrettyStackTrace.h
include/llvm/Support/Recycler.h
include/llvm/Support/RecyclingAllocator.h
include/llvm/Support/Registry.h
include/llvm/Support/RegistryParser.h
include/llvm/Support/SlowOperationInformer.h
+include/llvm/Support/SourceMgr.h
include/llvm/Support/StableBasicBlockNumbering.h
+include/llvm/Support/StandardPasses.h
include/llvm/Support/Streams.h
include/llvm/Support/StringPool.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/TargetFolder.h
include/llvm/Support/Timer.h
+include/llvm/Support/TypeBuilder.h
+include/llvm/Support/ValueHandle.h
include/llvm/Support/raw_ostream.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
+include/llvm/System/Atomic.h
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
+include/llvm/System/Errno.h
include/llvm/System/Host.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
@@ -298,14 +344,18 @@ include/llvm/System/Mutex.h
include/llvm/System/Path.h
include/llvm/System/Process.h
include/llvm/System/Program.h
+include/llvm/System/RWMutex.h
include/llvm/System/Signals.h
include/llvm/System/Solaris.h
+include/llvm/System/ThreadLocal.h
+include/llvm/System/Threading.h
include/llvm/System/TimeValue.h
+include/llvm/Target/COFFTargetAsmInfo.h
include/llvm/Target/DarwinTargetAsmInfo.h
-include/llvm/Target/ELFTargetAsmInfo.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
include/llvm/Target/TargetAsmInfo.h
+include/llvm/Target/TargetAsmParser.h
include/llvm/Target/TargetCallingConv.td
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
@@ -313,14 +363,17 @@ include/llvm/Target/TargetFrameInfo.h
include/llvm/Target/TargetInstrDesc.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
+include/llvm/Target/TargetIntrinsicInfo.h
include/llvm/Target/TargetJITInfo.h
include/llvm/Target/TargetLowering.h
+include/llvm/Target/TargetLoweringObjectFile.h
include/llvm/Target/TargetMachOWriterInfo.h
include/llvm/Target/TargetMachine.h
-include/llvm/Target/TargetMachineRegistry.h
include/llvm/Target/TargetOptions.h
include/llvm/Target/TargetRegisterInfo.h
+include/llvm/Target/TargetRegistry.h
include/llvm/Target/TargetSchedule.td
+include/llvm/Target/TargetSelect.h
include/llvm/Target/TargetSelectionDAG.td
include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
@@ -328,6 +381,7 @@ include/llvm/Transforms/IPO/InlinerPass.h
include/llvm/Transforms/Instrumentation.h
include/llvm/Transforms/RSProfiling.h
include/llvm/Transforms/Scalar.h
+include/llvm/Transforms/Utils/AddrModeMatcher.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/BasicInliner.h
include/llvm/Transforms/Utils/Cloning.h
@@ -335,6 +389,7 @@ include/llvm/Transforms/Utils/FunctionUtils.h
include/llvm/Transforms/Utils/InlineCost.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
+include/llvm/Transforms/Utils/SSI.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
@@ -344,53 +399,79 @@ include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
include/llvm/ValueSymbolTable.h
-lib/LLVMARMAsmPrinter.o
-lib/LLVMARMCodeGen.o
-lib/LLVMAlphaAsmPrinter.o
-lib/LLVMAlphaCodeGen.o
-lib/LLVMCBackend.o
-lib/LLVMCellSPUAsmPrinter.o
-lib/LLVMCellSPUCodeGen.o
-lib/LLVMCppBackend.o
-lib/LLVMExecutionEngine.o
-lib/LLVMHello.a
-lib/LLVMHello.la
-lib/LLVMHello.so
-lib/LLVMHello.so.0
-lib/LLVMIA64.o
-lib/LLVMInterpreter.o
-lib/LLVMJIT.o
-lib/LLVMMSIL.o
-lib/LLVMMips.o
-lib/LLVMPIC16.o
-lib/LLVMPowerPCAsmPrinter.o
-lib/LLVMPowerPCCodeGen.o
-lib/LLVMSparcAsmPrinter.o
-lib/LLVMSparcCodeGen.o
-lib/LLVMX86AsmPrinter.o
-lib/LLVMX86CodeGen.o
-lib/LLVMXCore.o
+lib/libCompilerDriver.a
+lib/libLLVMARMAsmPrinter.a
+lib/libLLVMARMCodeGen.a
+lib/libLLVMARMInfo.a
+lib/libLLVMAlphaAsmPrinter.a
+lib/libLLVMAlphaCodeGen.a
+lib/libLLVMAlphaInfo.a
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
+lib/libLLVMBlackfinAsmPrinter.a
+lib/libLLVMBlackfinCodeGen.a
+lib/libLLVMBlackfinInfo.a
+lib/libLLVMCBackend.a
+lib/libLLVMCBackendInfo.a
+lib/libLLVMCellSPUAsmPrinter.a
+lib/libLLVMCellSPUCodeGen.a
+lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
+lib/libLLVMCppBackend.a
+lib/libLLVMCppBackendInfo.a
lib/libLLVMDebugger.a
+lib/libLLVMExecutionEngine.a
+lib/libLLVMHello.so
lib/libLLVMInstrumentation.a
+lib/libLLVMInterpreter.a
+lib/libLLVMJIT.a
lib/libLLVMLinker.a
+lib/libLLVMMC.a
+lib/libLLVMMSIL.a
+lib/libLLVMMSILInfo.a
+lib/libLLVMMSP430AsmPrinter.a
+lib/libLLVMMSP430CodeGen.a
+lib/libLLVMMSP430Info.a
+lib/libLLVMMipsAsmPrinter.a
+lib/libLLVMMipsCodeGen.a
+lib/libLLVMMipsInfo.a
+lib/libLLVMPIC16AsmPrinter.a
+lib/libLLVMPIC16CodeGen.a
+lib/libLLVMPIC16Info.a
+lib/libLLVMPowerPCAsmPrinter.a
+lib/libLLVMPowerPCCodeGen.a
+lib/libLLVMPowerPCInfo.a
lib/libLLVMScalarOpts.a
lib/libLLVMSelectionDAG.a
+lib/libLLVMSparcAsmPrinter.a
+lib/libLLVMSparcCodeGen.a
+lib/libLLVMSparcInfo.a
lib/libLLVMSupport.a
lib/libLLVMSystem.a
+lib/libLLVMSystemZAsmPrinter.a
+lib/libLLVMSystemZCodeGen.a
+lib/libLLVMSystemZInfo.a
lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
+lib/libLLVMX86AsmParser.a
+lib/libLLVMX86AsmPrinter.a
+lib/libLLVMX86CodeGen.a
+lib/libLLVMX86Info.a
+lib/libLLVMXCoreAsmPrinter.a
+lib/libLLVMXCoreCodeGen.a
+lib/libLLVMXCoreInfo.a
lib/libLLVMipa.a
lib/libLLVMipo.a
-lib/plugin_llvmc_Base.o
-lib/plugin_llvmc_Clang.o
+lib/libLTO.a
+lib/libLTO.so
+lib/libplugin_llvmc_Base.a
+lib/libplugin_llvmc_Clang.a
+lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
%%PORTDOCS%%%%DOCSDIR%%/html/AliasAnalysis.html
%%PORTDOCS%%%%DOCSDIR%%/html/BitCodeFormat.html
@@ -399,6 +480,7 @@ lib/plugin_llvmc_Clang.o
%%PORTDOCS%%%%DOCSDIR%%/html/CMake.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodeGenerator.html
%%PORTDOCS%%%%DOCSDIR%%/html/CodingStandards.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/FileCheck.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/bugpoint.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llc.html
@@ -434,6 +516,7 @@ lib/plugin_llvmc_Clang.o
%%PORTDOCS%%%%DOCSDIR%%/html/GetElementPtr.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.html
+%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.html
%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.html
@@ -443,6 +526,7 @@ lib/plugin_llvmc_Clang.o
%%PORTDOCS%%%%DOCSDIR%%/html/Passes.html
%%PORTDOCS%%%%DOCSDIR%%/html/ProgrammersManual.html
%%PORTDOCS%%%%DOCSDIR%%/html/Projects.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes-2.6.html
%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
%%PORTDOCS%%%%DOCSDIR%%/html/SourceLevelDebugging.html
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
@@ -477,6 +561,7 @@ lib/plugin_llvmc_Clang.o
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl6.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/OCamlLangImpl7.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ps/FileCheck.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/bugpoint.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llc.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/lli.ps
@@ -503,6 +588,7 @@ lib/plugin_llvmc_Clang.o
@dirrm include/llvm/Target
@dirrm include/llvm/System
@dirrm include/llvm/Support
+@dirrm include/llvm/MC
@dirrm include/llvm/ExecutionEngine
@dirrm include/llvm/Debugger
@dirrm include/llvm/Config