aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-05-16 05:33:50 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-05-16 05:33:50 +0000
commitd45880e902a1009571e20547f61b1a446e7885b4 (patch)
tree9eac909b0c3389adbfbab0396124e4aeb601aaa7 /devel/llvm29
parent6969bae17233ffeec73dfec87a4af394ae186faa (diff)
downloadports-d45880e902a1009571e20547f61b1a446e7885b4.tar.gz
ports-d45880e902a1009571e20547f61b1a446e7885b4.zip
Update to 1.7
Notes
Notes: svn path=/head/; revision=162537
Diffstat (limited to 'devel/llvm29')
-rw-r--r--devel/llvm29/Makefile14
-rw-r--r--devel/llvm29/distinfo6
-rw-r--r--devel/llvm29/pkg-plist35
3 files changed, 34 insertions, 21 deletions
diff --git a/devel/llvm29/Makefile b/devel/llvm29/Makefile
index 145b8a95d229..a20670171a77 100644
--- a/devel/llvm29/Makefile
+++ b/devel/llvm29/Makefile
@@ -6,16 +6,13 @@
#
PORTNAME= llvm
-PORTVERSION= 1.6
-PORTREVISION= 1
+PORTVERSION= 1.7
CATEGORIES= devel lang
-MASTER_SITES= http://llvm.cs.uiuc.edu/releases/${PORTVERSION}/
+MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
MAINTAINER= perky@FreeBSD.org
COMMENT= Low Level Virtual Machine
-BROKEN= Does not build
-
GNU_CONFIGURE= yes
USE_BISON= yes
USE_GMAKE= yes
@@ -24,9 +21,10 @@ MAKE_ENV= ENABLE_OPTIMIZED=1 # strips binaries
WRKSRC= ${WRKDIR}/llvm
MAN1= analyze.1 bugpoint.1 gccas.1 gccld.1 llc.1 lli.1 llvm-ar.1 \
- llvm-as.1 llvm-bcanalyzer.1 llvm-db.1 llvm-dis.1 \
- llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 llvm-prof.1 \
- llvm-ranlib.1 llvmc.1 llvmgcc.1 llvmgxx.1 opt.1 stkrc.1
+ llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
+ llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
+ llvm-prof.1 llvm-ranlib.1 llvmc.1 llvmgcc.1 llvmgxx.1 \
+ opt.1 stkrc.1
post-patch:
${REINPLACE_CMD} -e 's,\(OPTIONAL_DIRS.*\)examples,\1,g' \
diff --git a/devel/llvm29/distinfo b/devel/llvm29/distinfo
index 2bd188eda40f..e23e767a2c08 100644
--- a/devel/llvm29/distinfo
+++ b/devel/llvm29/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-1.6.tar.gz) = 68f41af7f4bae560ffb650da6f9f145d
-SHA256 (llvm-1.6.tar.gz) = 7f9ef39554a3b488d26eadea768b90900466eba887214c48737959c5f133ebc1
-SIZE (llvm-1.6.tar.gz) = 4238390
+MD5 (llvm-1.7.tar.gz) = 145d5215328e663570ef2488b04af11d
+SHA256 (llvm-1.7.tar.gz) = 0cddc689548beb5163ac305918b549b8f995a505476572eaf70fcbdaf1d00673
+SIZE (llvm-1.7.tar.gz) = 4598379
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index fd92ad2fce8e..47de718d16cd 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -9,6 +9,7 @@ bin/lli
bin/llvm-ar
bin/llvm-as
bin/llvm-bcanalyzer
+bin/llvm-config
bin/llvm-db
bin/llvm-dis
bin/llvm-extract
@@ -31,7 +32,6 @@ etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
etc/llvm/st
-include/llvm/ADT/.cvsignore
include/llvm/ADT/BitSetVector.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DepthFirstIterator.h
@@ -46,14 +46,12 @@ include/llvm/ADT/SetVector.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/Tree.h
+include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
include/llvm/ADT/hash_map
-include/llvm/ADT/hash_map.in
include/llvm/ADT/hash_set
-include/llvm/ADT/hash_set.in
include/llvm/ADT/ilist
include/llvm/ADT/iterator
-include/llvm/ADT/iterator.in
include/llvm/AbstractTypeUser.h
include/llvm/Analysis/AliasAnalysis.h
include/llvm/Analysis/AliasSetTracker.h
@@ -67,6 +65,7 @@ include/llvm/Analysis/DataStructure/DSNode.h
include/llvm/Analysis/DataStructure/DSSupport.h
include/llvm/Analysis/DataStructure/DataStructure.h
include/llvm/Analysis/Dominators.h
+include/llvm/Analysis/ET-Forest.h
include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
include/llvm/Analysis/IntervalIterator.h
@@ -87,6 +86,7 @@ include/llvm/Analysis/ValueNumbering.h
include/llvm/Analysis/Verifier.h
include/llvm/Argument.h
include/llvm/Assembly/AsmAnnotationWriter.h
+include/llvm/Assembly/AutoUpgrade.h
include/llvm/Assembly/CachedWriter.h
include/llvm/Assembly/Parser.h
include/llvm/Assembly/PrintModulePass.h
@@ -102,6 +102,7 @@ include/llvm/Bytecode/Writer.h
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFWriter.h
include/llvm/CodeGen/InstrScheduling.h
include/llvm/CodeGen/IntrinsicLowering.h
@@ -111,24 +112,26 @@ include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
+include/llvm/CodeGen/MachineDebugInfo.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
include/llvm/CodeGen/MachineFunctionPass.h
include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
+include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
+include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
include/llvm/CodeGen/ValueSet.h
include/llvm/CodeGen/ValueTypes.h
-include/llvm/Config/.cvsignore
+include/llvm/CodeGen/ValueTypes.td
include/llvm/Config/alloca.h
include/llvm/Config/config.h
-include/llvm/Config/config.h.in
include/llvm/Constant.h
include/llvm/Constants.h
include/llvm/Debugger/Debugger.h
@@ -140,15 +143,22 @@ include/llvm/Debugger/SourceLanguage.h
include/llvm/DerivedTypes.h
include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
+include/llvm/ExecutionEngine/Interpreter.h
+include/llvm/ExecutionEngine/JIT.h
include/llvm/Function.h
include/llvm/GlobalValue.h
include/llvm/GlobalVariable.h
+include/llvm/InlineAsm.h
include/llvm/InstrTypes.h
include/llvm/Instruction.def
include/llvm/Instruction.h
include/llvm/Instructions.h
include/llvm/IntrinsicInst.h
+include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
+include/llvm/Intrinsics.td
+include/llvm/IntrinsicsPowerPC.td
+include/llvm/IntrinsicsX86.td
include/llvm/Linker.h
include/llvm/Module.h
include/llvm/ModuleProvider.h
@@ -156,7 +166,6 @@ include/llvm/Pass.h
include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassSupport.h
-include/llvm/Support/.cvsignore
include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/Annotation.h
include/llvm/Support/CFG.h
@@ -167,8 +176,8 @@ include/llvm/Support/Compressor.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataTypes.h
-include/llvm/Support/DataTypes.h.in
include/llvm/Support/Debug.h
+include/llvm/Support/Dwarf.h
include/llvm/Support/DynamicLinker.h
include/llvm/Support/ELF.h
include/llvm/Support/FileUtilities.h
@@ -192,6 +201,7 @@ include/llvm/Support/TypeInfo.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTable.h
include/llvm/SymbolTableListTraits.h
+include/llvm/System/Alarm.h
include/llvm/System/DynamicLibrary.h
include/llvm/System/LICENSE.TXT
include/llvm/System/MappedFile.h
@@ -218,6 +228,7 @@ include/llvm/Target/TargetSubtarget.h
include/llvm/Transforms/IPO.h
include/llvm/Transforms/Instrumentation.h
include/llvm/Transforms/LinkAllPasses.h
+include/llvm/Transforms/RSProfiling.h
include/llvm/Transforms/Scalar.h
include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/Cloning.h
@@ -226,9 +237,11 @@ include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Type.h
+include/llvm/TypeSymbolTable.h
include/llvm/Use.h
include/llvm/User.h
include/llvm/Value.h
+include/llvm/ValueSymbolTable.h
lib/LLVMAlpha.o
lib/LLVMAsmParser.o
lib/LLVMBCReader.o
@@ -244,8 +257,7 @@ lib/LLVMInterpreter.o
lib/LLVMJIT.o
lib/LLVMPowerPC.o
lib/LLVMSelectionDAG.o
-lib/LLVMSkeleton.o
-lib/LLVMSparcV8.o
+lib/LLVMSparc.o
lib/LLVMSparcV9.o
lib/LLVMSparcV9InstrSched.o
lib/LLVMSparcV9LiveVar.o
@@ -283,6 +295,7 @@ lib/stkr_compiler.o
%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
%%DOCSDIR%%/html/CommandGuide/llvm-as.html
%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
+%%DOCSDIR%%/html/CommandGuide/llvm-config.html
%%DOCSDIR%%/html/CommandGuide/llvm-db.html
%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
@@ -305,6 +318,7 @@ lib/stkr_compiler.o
%%DOCSDIR%%/html/GarbageCollection.html
%%DOCSDIR%%/html/GettingStarted.html
%%DOCSDIR%%/html/GettingStartedVS.html
+%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%DOCSDIR%%/html/HowToSubmitABug.html
%%DOCSDIR%%/html/LLVMVsTheWorld.html
%%DOCSDIR%%/html/LangRef.html
@@ -338,6 +352,7 @@ lib/stkr_compiler.o
%%DOCSDIR%%/ps/llvm-ar.ps
%%DOCSDIR%%/ps/llvm-as.ps
%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
+%%DOCSDIR%%/ps/llvm-config.ps
%%DOCSDIR%%/ps/llvm-db.ps
%%DOCSDIR%%/ps/llvm-dis.ps
%%DOCSDIR%%/ps/llvm-extract.ps