aboutsummaryrefslogtreecommitdiff
path: root/devel/log4cpp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-01 17:30:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-01 17:30:29 +0000
commit3acbb503cc28ad1d130f253208a605e2605d8a48 (patch)
treed202af3d69d6e5ee5bba4b883d92e3a54e1b0b4b /devel/log4cpp
parent79360788dff8416175028b234e778b7fc82c7b06 (diff)
downloadports-3acbb503cc28ad1d130f253208a605e2605d8a48.tar.gz
ports-3acbb503cc28ad1d130f253208a605e2605d8a48.zip
add log4cpp
A library of C++ classes for flexible logging to files, syslog, IDSA and other destinations.
Notes
Notes: svn path=/head/; revision=42138
Diffstat (limited to 'devel/log4cpp')
-rw-r--r--devel/log4cpp/Makefile21
-rw-r--r--devel/log4cpp/distinfo1
-rw-r--r--devel/log4cpp/pkg-comment1
-rw-r--r--devel/log4cpp/pkg-descr5
-rw-r--r--devel/log4cpp/pkg-plist27
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/log4cpp/Makefile b/devel/log4cpp/Makefile
new file mode 100644
index 000000000000..f51930154785
--- /dev/null
+++ b/devel/log4cpp/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# New ports collection makefile for: log4cpp
+# Date created: May 1, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= log4cpp
+PORTVERSION= 0.2.4b
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S,b,,}
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/log4cpp/distinfo b/devel/log4cpp/distinfo
new file mode 100644
index 000000000000..43d3b4f8e1a5
--- /dev/null
+++ b/devel/log4cpp/distinfo
@@ -0,0 +1 @@
+MD5 (log4cpp-0.2.4b.tar.gz) = 193c1454e2b4d414398d79def26dfedb
diff --git a/devel/log4cpp/pkg-comment b/devel/log4cpp/pkg-comment
new file mode 100644
index 000000000000..c03e215cc897
--- /dev/null
+++ b/devel/log4cpp/pkg-comment
@@ -0,0 +1 @@
+A library of C++ classes for flexible logging
diff --git a/devel/log4cpp/pkg-descr b/devel/log4cpp/pkg-descr
new file mode 100644
index 000000000000..016477ca5b12
--- /dev/null
+++ b/devel/log4cpp/pkg-descr
@@ -0,0 +1,5 @@
+A library of C++ classes for flexible logging to files, syslog, IDSA and
+other destinations. It is modeled after the Log for Java library
+(http://www.log4j.org), staying as close to their API as is reasonable.
+
+WWW: http://log4cpp.sourceforge.net/
diff --git a/devel/log4cpp/pkg-plist b/devel/log4cpp/pkg-plist
new file mode 100644
index 000000000000..5d92fc858c6a
--- /dev/null
+++ b/devel/log4cpp/pkg-plist
@@ -0,0 +1,27 @@
+bin/log4cpp-config
+include/log4cpp/Appender.hh
+include/log4cpp/AppenderSkeleton.hh
+include/log4cpp/BasicLayout.hh
+include/log4cpp/Category.hh
+include/log4cpp/Config.hh
+include/log4cpp/FileAppender.hh
+include/log4cpp/Filter.hh
+include/log4cpp/FixedContextCategory.hh
+include/log4cpp/HierarchyMaintainer.hh
+include/log4cpp/IdsaAppender.hh
+include/log4cpp/Layout.hh
+include/log4cpp/LayoutAppender.hh
+include/log4cpp/Log4cppCleanup.hh
+include/log4cpp/LoggingEvent.hh
+include/log4cpp/NDC.hh
+include/log4cpp/OstreamAppender.hh
+include/log4cpp/OstringStream.hh
+include/log4cpp/Priority.hh
+include/log4cpp/SimpleLayout.hh
+include/log4cpp/StringQueueAppender.hh
+include/log4cpp/SyslogAppender.hh
+@dirrm include/log4cpp
+lib/liblog4cpp.a
+lib/liblog4cpp.la
+lib/liblog4cpp.so
+lib/liblog4cpp.so.0