aboutsummaryrefslogtreecommitdiff
path: root/devel/log4cpp
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-11-29 17:27:32 +0000
committerSimon Barner <barner@FreeBSD.org>2005-11-29 17:27:32 +0000
commitf8db9aa290c9be094d1c183011efc3498322158a (patch)
tree98544d8815acc09b2391b0904da7cc0e55a1628b /devel/log4cpp
parent4a45171063953bd62b007489477e5abc15614642 (diff)
downloadports-f8db9aa290c9be094d1c183011efc3498322158a.tar.gz
ports-f8db9aa290c9be094d1c183011efc3498322158a.zip
- Fix build if doxygen is on the system, and thus the documentation is
is built and installed. Also adjust plist for this case. - Add support for NOPORTDOCS (disables dependency on doxygen) Reported by: Yann Golanski <yann@kierun.org> PR: ports/89726
Notes
Notes: svn path=/head/; revision=149917
Diffstat (limited to 'devel/log4cpp')
-rw-r--r--devel/log4cpp/Makefile47
-rw-r--r--devel/log4cpp/files/patch-doc_Makefile.in11
-rw-r--r--devel/log4cpp/pkg-plist4
3 files changed, 61 insertions, 1 deletions
diff --git a/devel/log4cpp/Makefile b/devel/log4cpp/Makefile
index bf72e6b42532..4bd2fd43ca4d 100644
--- a/devel/log4cpp/Makefile
+++ b/devel/log4cpp/Makefile
@@ -20,9 +20,54 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-pthreads --disable-html-docs
+MAKE_ENV+= RM=${RM}
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if exists (${LOCALBASE}/bin/doxygen) || !defined (NOPORTDOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+
+MAN3= log4cpp.3 log4cpp::Appender.3 log4cpp::AppenderSkeleton.3\
+ log4cpp::BasicConfigurator.3 log4cpp::BasicLayout.3 log4cpp::Category.3\
+ log4cpp::CategoryNameComponent.3 log4cpp::CategoryStream.3\
+ log4cpp::ConfigureFailure.3 log4cpp::FileAppender.3 log4cpp::Filter.3\
+ log4cpp::FixedContextCategory.3 log4cpp::FormatModifierComponent.3\
+ log4cpp::HierarchyMaintainer.3 log4cpp::IdsaAppender.3 log4cpp::Layout.3\
+ log4cpp::LayoutAppender.3 log4cpp::LoggingEvent.3\
+ log4cpp::MessageComponent.3 log4cpp::MillisSinceEpochComponent.3\
+ log4cpp::NDC.3 log4cpp::NDC::DiagnosticContext.3 log4cpp::NDCComponent.3\
+ log4cpp::NTEventLogAppender.3 log4cpp::OstreamAppender.3\
+ log4cpp::PatternLayout.3 log4cpp::PatternLayout::PatternComponent.3\
+ log4cpp::Priority.3 log4cpp::PriorityComponent.3\
+ log4cpp::ProcessorTimeComponent.3 log4cpp::Properties.3\
+ log4cpp::PropertyConfigurator.3 log4cpp::PropertyConfiguratorImpl.3\
+ log4cpp::RemoteSyslogAppender.3 log4cpp::RollingFileAppender.3\
+ log4cpp::SecondsSinceEpochComponent.3 log4cpp::SimpleConfigurator.3\
+ log4cpp::SimpleLayout.3 log4cpp::StringLiteralComponent.3\
+ log4cpp::StringQueueAppender.3 log4cpp::StringUtil.3\
+ log4cpp::SyslogAppender.3 log4cpp::ThreadNameComponent.3\
+ log4cpp::TimeStamp.3 log4cpp::TimeStampComponent.3\
+ log4cpp::Win32DebugAppender.3 log4cpp::threading.3\
+ log4cpp::threading::MSMutex.3 log4cpp::threading::MSScopedLock.3\
+ log4cpp::threading::Mutex.3 log4cpp::threading::ScopedLock.3\
+ log4cpp::threading::ThreadLocalDataHolder.3
+.else
+NOPORTDOCS= true
+CONFIGURE_ARGS+= --disable-doxygen
+.endif
+
+.if !exists (${LOCALBASE}/bin/doxygen) && !defined (NOPORTDOCS)
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} By default, this port uses doxygen to build its documentation.\
+It currently is not present your system, and if you do not want to install it, abort\
+this build by hitting CTRL+C and re-run the installation with -DNOPORTDOCS | ${FMT} 74
+ @${ECHO_CMD}
+ @sleep 3
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| -pedantic||g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/log4cpp/files/patch-doc_Makefile.in b/devel/log4cpp/files/patch-doc_Makefile.in
new file mode 100644
index 000000000000..0deaab037494
--- /dev/null
+++ b/devel/log4cpp/files/patch-doc_Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Tue Nov 29 17:28:32 2005
++++ doc/Makefile.in Tue Nov 29 17:33:03 2005
+@@ -96,7 +96,7 @@
+ SUBDIRS = html
+
+ man3dir = $(mandir)/man3
+-docdir = $(prefix)/doc/@PACKAGE_TARNAME@-@PACKAGE_VERSION@
++docdir = $(prefix)/share/doc/@PACKAGE_TARNAME@
+
+ EXTRA_DIST = \
+ mainPage.txt
diff --git a/devel/log4cpp/pkg-plist b/devel/log4cpp/pkg-plist
index c1965ff6e47a..5338505b7570 100644
--- a/devel/log4cpp/pkg-plist
+++ b/devel/log4cpp/pkg-plist
@@ -43,5 +43,9 @@ lib/liblog4cpp.a
lib/liblog4cpp.so
lib/liblog4cpp.so.4
share/aclocal/log4cpp.m4
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/default.css
+%%DOCSDIR%%/sflogo.png
@dirrm include/log4cpp/threading
@dirrm include/log4cpp
+@dirrm %%DOCSDIR%%