aboutsummaryrefslogtreecommitdiff
path: root/devel/log4cxx
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-16 13:47:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-16 13:47:07 +0000
commitaa16f3ce599f0ed3cbf70fa899cf4dc0b918d43a (patch)
treee9f5aadd61e053eea1cc5775022e82506fe96765 /devel/log4cxx
parent98e633300ab1aaa4b6fb63f875e918ccc491cedb (diff)
downloadports-aa16f3ce599f0ed3cbf70fa899cf4dc0b918d43a.tar.gz
ports-aa16f3ce599f0ed3cbf70fa899cf4dc0b918d43a.zip
Log4cxx is a port to C++ of the Log4j project. The goal is have the same
functionnalities and interfaces of log4j. PR: ports/76287 Submitted by: Thaddeus Covert <tcovert+ports@sahuagin.net>
Notes
Notes: svn path=/head/; revision=126582
Diffstat (limited to 'devel/log4cxx')
-rw-r--r--devel/log4cxx/Makefile69
-rw-r--r--devel/log4cxx/distinfo2
-rw-r--r--devel/log4cxx/files/patch-docs-Makefile.am11
-rw-r--r--devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h12
-rw-r--r--devel/log4cxx/pkg-descr4
-rw-r--r--devel/log4cxx/pkg-plist123
6 files changed, 221 insertions, 0 deletions
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
new file mode 100644
index 000000000000..3ebaa263ae8e
--- /dev/null
+++ b/devel/log4cxx/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: log4cxx
+# Date created: 2005-01-12
+# Whom: Thaddeus Covert <tcovert@grimmy.sahuagin.net>
+#
+# $FreeBSD$
+
+PORTNAME= log4cxx
+PORTVERSION= 0.9.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= logging/${PORTNAME}
+
+MAINTAINER= tcovert@sahuagin.net
+COMMENT= Log4cxx is a port to C++ of the Log4j project
+
+.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
+.else
+CONFIGURE_ARGS+= --disable-doxygen
+.endif
+
+.if exists(${LOCALBASE}/lib/libboost_regex.so)
+WITH_BOOST= yes
+.endif
+
+.if defined(WITH_BOOST)
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/regex.hpp:${PORTSDIR}/devel/boost
+CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+.endif
+
+USE_AUTOMAKE_VER= 15
+USE_AUTOCONF_VER= 253
+AUTOMAKE_ARGS= --add-missing
+USE_LIBTOOL_VER=13
+LIBTOOL_VARS= --force --automake
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -I${LOCALBASE}/lib
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}"
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not compile on FreeBSD 4.x (missing swprintf in libc)
+.endif
+
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL})
+
+post-patch:
+ @${REINPLACE_CMD} "s#\$$(DESTDIR)\$$(htmldir)#${DOCSDIR}/html#" ${WRKSRC}/docs/Makefile.am
+
+post-install:
+.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
+ ${MKDIR} ${DOCSDIR}
+ for f in ${PORTDOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/log4cxx/distinfo b/devel/log4cxx/distinfo
new file mode 100644
index 000000000000..41a94eaea966
--- /dev/null
+++ b/devel/log4cxx/distinfo
@@ -0,0 +1,2 @@
+MD5 (log4cxx-0.9.7.tar.gz) = fd09abc90b8c0c8af1d5146a75590792
+SIZE (log4cxx-0.9.7.tar.gz) = 256449
diff --git a/devel/log4cxx/files/patch-docs-Makefile.am b/devel/log4cxx/files/patch-docs-Makefile.am
new file mode 100644
index 000000000000..4811d088feb4
--- /dev/null
+++ b/devel/log4cxx/files/patch-docs-Makefile.am
@@ -0,0 +1,11 @@
+--- docs/Makefile.am.orig Thu Jan 13 22:28:59 2005
++++ docs/Makefile.am Thu Jan 13 22:29:35 2005
+@@ -10,7 +10,7 @@
+
+ install-data-hook:
+ $(mkinstalldirs) $(DESTDIR)$(htmldir)
+- cp -dpR html/* $(DESTDIR)$(htmldir)
++ cp -PpR html/* $(DESTDIR)$(htmldir)
+
+ # Automake's "distcheck" is sensitive to having files left over
+ # after "make uninstall", so we have to clean up the install hook.
diff --git a/devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h b/devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h
new file mode 100644
index 000000000000..b3a869f09542
--- /dev/null
+++ b/devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h
@@ -0,0 +1,12 @@
+--- include/log4cxx/helpers/tchar.h.orig Wed Jan 12 17:56:51 2005
++++ include/log4cxx/helpers/tchar.h Wed Jan 12 17:57:04 2005
+@@ -83,6 +83,9 @@
+ #include <malloc.h>
+ #define USES_CONVERSION void * _dst = _alloca(1024);
+ #endif
++#elif defined( __FreeBSD__ )
++ #include <stdlib.h>
++ #define USES_CONVERSION void * _dst = alloca(1024);
+ #else
+ #include <alloca.h>
+ #define USES_CONVERSION void * _dst = alloca(1024);
diff --git a/devel/log4cxx/pkg-descr b/devel/log4cxx/pkg-descr
new file mode 100644
index 000000000000..6b1c4c7ff278
--- /dev/null
+++ b/devel/log4cxx/pkg-descr
@@ -0,0 +1,4 @@
+Log4cxx is a C++ port of the Log4j project.
+The goal is to have the same functionality and interfaces as log4j.
+
+WWW: http://logging.apache.org/log4cxx/
diff --git a/devel/log4cxx/pkg-plist b/devel/log4cxx/pkg-plist
new file mode 100644
index 000000000000..c32ace6bb4d5
--- /dev/null
+++ b/devel/log4cxx/pkg-plist
@@ -0,0 +1,123 @@
+bin/simplesocketserver
+include/log4cxx/appender.h
+include/log4cxx/appenderskeleton.h
+include/log4cxx/asyncappender.h
+include/log4cxx/basicconfigurator.h
+include/log4cxx/config.h
+include/log4cxx/config/propertysetter.h
+include/log4cxx/config_auto.h
+include/log4cxx/config_msvc.h
+include/log4cxx/consoleappender.h
+include/log4cxx/dailyrollingfileappender.h
+include/log4cxx/db/odbcappender.h
+include/log4cxx/defaultcategoryfactory.h
+include/log4cxx/fileappender.h
+include/log4cxx/helpers/absolutetimedateformat.h
+include/log4cxx/helpers/appenderattachableimpl.h
+include/log4cxx/helpers/boundedfifo.h
+include/log4cxx/helpers/class.h
+include/log4cxx/helpers/condition.h
+include/log4cxx/helpers/criticalsection.h
+include/log4cxx/helpers/cyclicbuffer.h
+include/log4cxx/helpers/datagrampacket.h
+include/log4cxx/helpers/datagramsocket.h
+include/log4cxx/helpers/dateformat.h
+include/log4cxx/helpers/datelayout.h
+include/log4cxx/helpers/datetimedateformat.h
+include/log4cxx/helpers/event.h
+include/log4cxx/helpers/exception.h
+include/log4cxx/helpers/filewatchdog.h
+include/log4cxx/helpers/formattinginfo.h
+include/log4cxx/helpers/gnomexml.h
+include/log4cxx/helpers/inetaddress.h
+include/log4cxx/helpers/intializationutil.h
+include/log4cxx/helpers/iso8601dateformat.h
+include/log4cxx/helpers/loader.h
+include/log4cxx/helpers/locale.h
+include/log4cxx/helpers/loglog.h
+include/log4cxx/helpers/msxml.h
+include/log4cxx/helpers/mutex.h
+include/log4cxx/helpers/object.h
+include/log4cxx/helpers/objectimpl.h
+include/log4cxx/helpers/objectptr.h
+include/log4cxx/helpers/onlyonceerrorhandler.h
+include/log4cxx/helpers/optionconverter.h
+include/log4cxx/helpers/patternconverter.h
+include/log4cxx/helpers/patternparser.h
+include/log4cxx/helpers/properties.h
+include/log4cxx/helpers/propertyresourcebundle.h
+include/log4cxx/helpers/relativetimedateformat.h
+include/log4cxx/helpers/resourcebundle.h
+include/log4cxx/helpers/semaphore.h
+include/log4cxx/helpers/serversocket.h
+include/log4cxx/helpers/socket.h
+include/log4cxx/helpers/socketimpl.h
+include/log4cxx/helpers/socketinputstream.h
+include/log4cxx/helpers/socketoutputstream.h
+include/log4cxx/helpers/strictmath.h
+include/log4cxx/helpers/stringhelper.h
+include/log4cxx/helpers/stringtokenizer.h
+include/log4cxx/helpers/syslogwriter.h
+include/log4cxx/helpers/system.h
+include/log4cxx/helpers/tchar.h
+include/log4cxx/helpers/thread.h
+include/log4cxx/helpers/threadspecificdata.h
+include/log4cxx/helpers/timezone.h
+include/log4cxx/helpers/transform.h
+include/log4cxx/helpers/xml.h
+include/log4cxx/hierarchy.h
+include/log4cxx/htmllayout.h
+include/log4cxx/layout.h
+include/log4cxx/level.h
+include/log4cxx/logger.h
+include/log4cxx/logmanager.h
+include/log4cxx/mdc.h
+include/log4cxx/ndc.h
+include/log4cxx/net/smtpappender.h
+include/log4cxx/net/socketappender.h
+include/log4cxx/net/sockethubappender.h
+include/log4cxx/net/socketnode.h
+include/log4cxx/net/syslogappender.h
+include/log4cxx/net/telnetappender.h
+include/log4cxx/net/xmlsocketappender.h
+include/log4cxx/nt/nteventlogappender.h
+include/log4cxx/patternlayout.h
+include/log4cxx/propertyconfigurator.h
+include/log4cxx/provisionnode.h
+include/log4cxx/rollingfileappender.h
+include/log4cxx/simplelayout.h
+include/log4cxx/spi/appenderattachable.h
+include/log4cxx/spi/configurator.h
+include/log4cxx/spi/defaultrepositoryselector.h
+include/log4cxx/spi/errorhandler.h
+include/log4cxx/spi/filter.h
+include/log4cxx/spi/hierarchyeventlistener.h
+include/log4cxx/spi/loggerfactory.h
+include/log4cxx/spi/loggerrepository.h
+include/log4cxx/spi/loggingevent.h
+include/log4cxx/spi/optionhandler.h
+include/log4cxx/spi/repositoryselector.h
+include/log4cxx/spi/rootcategory.h
+include/log4cxx/spi/triggeringeventevaluator.h
+include/log4cxx/ttcclayout.h
+include/log4cxx/varia/denyallfilter.h
+include/log4cxx/varia/fallbackerrorhandler.h
+include/log4cxx/varia/levelmatchfilter.h
+include/log4cxx/varia/levelrangefilter.h
+include/log4cxx/varia/stringmatchfilter.h
+include/log4cxx/writerappender.h
+include/log4cxx/xml/domconfigurator.h
+include/log4cxx/xml/xmllayout.h
+lib/liblog4cxx.a
+lib/liblog4cxx.la
+lib/liblog4cxx.so
+lib/liblog4cxx.so.9
+@dirrm include/log4cxx/xml
+@dirrm include/log4cxx/varia
+@dirrm include/log4cxx/spi
+@dirrm include/log4cxx/nt
+@dirrm include/log4cxx/net
+@dirrm include/log4cxx/helpers
+@dirrm include/log4cxx/db
+@dirrm include/log4cxx/config
+@dirrm include/log4cxx