aboutsummaryrefslogtreecommitdiff
path: root/devel/log4cxx
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-04-05 21:24:53 +0000
committerRene Ladan <rene@FreeBSD.org>2010-04-05 21:24:53 +0000
commitcc96ba97cbb40a4616969e6c33fdf26c427e1c3f (patch)
treea094d8e0ee49853d4d00b68f102f737d4599b682 /devel/log4cxx
parent7d440b5f3b8e1a9d3c45beb791304446992ca71b (diff)
downloadports-cc96ba97cbb40a4616969e6c33fdf26c427e1c3f.tar.gz
ports-cc96ba97cbb40a4616969e6c33fdf26c427e1c3f.zip
Update to 0.10.0
- add build dependency on devel/apr - clean up Makefile PR: ports/144968 Submitted by: rene Approved by: tabthorpe, maintainer timeout
Notes
Notes: svn path=/head/; revision=252270
Diffstat (limited to 'devel/log4cxx')
-rw-r--r--devel/log4cxx/Makefile25
-rw-r--r--devel/log4cxx/distinfo6
-rw-r--r--devel/log4cxx/files/patch-docs-Makefile.am11
-rw-r--r--devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h12
-rw-r--r--devel/log4cxx/files/patch-include-log4cxx-xml-domconfigurator.h14
-rw-r--r--devel/log4cxx/pkg-plist123
6 files changed, 111 insertions, 80 deletions
diff --git a/devel/log4cxx/Makefile b/devel/log4cxx/Makefile
index 4c8c653a38b3..dbb9229c3f56 100644
--- a/devel/log4cxx/Makefile
+++ b/devel/log4cxx/Makefile
@@ -5,15 +5,17 @@
# $FreeBSD$
PORTNAME= log4cxx
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTVERSION= 0.10.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_APACHE}
-MASTER_SITE_SUBDIR= logging/${PORTNAME}
+MASTER_SITE_SUBDIR= logging/${PORTNAME}/${PORTVERSION}
+DISTNAME= apache-${PORTNAME}-${PORTVERSION}
MAINTAINER= tcovert@sahuagin.net
COMMENT= Log4cxx is a port to C++ of the Log4j project
+BUILD_DEPENDS= ${LOCALBASE}/bin/apr-1-config:${PORTSDIR}/devel/apr
+
.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
.else
@@ -26,18 +28,13 @@ WITH_BOOST= yes
.if defined(WITH_BOOST)
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/regex.hpp:${PORTSDIR}/devel/boost-libs
-CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
.endif
-USE_AUTOTOOLS= automake:15 autoconf:262 libtool:22
-AUTOMAKE_ARGS= --add-missing
-LIBTOOL_VARS= --force --automake
-MAKE_JOBS_UNSAFE= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= automake:15:env autoconf:262:env libtool:22:env
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -I${LOCALBASE}/lib
+MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}"
USE_LDCONFIG= yes
.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
@@ -45,11 +42,9 @@ PORTDOCS= *
.endif
pre-configure:
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL})
@${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' ${WRKSRC}/aclocal.m4
-
-post-patch:
- @${REINPLACE_CMD} "s#\$$(DESTDIR)\$$(htmldir)#${DOCSDIR}/html#" ${WRKSRC}/docs/Makefile.am
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|$$(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.am
+ @(cd ${WRKSRC} && ./autogen.sh)
post-install:
.if !defined(NOPORTDOCS) && defined(WITH_DOXYGEN)
diff --git a/devel/log4cxx/distinfo b/devel/log4cxx/distinfo
index e4deec8805cb..b9882bac39c7 100644
--- a/devel/log4cxx/distinfo
+++ b/devel/log4cxx/distinfo
@@ -1,3 +1,3 @@
-MD5 (log4cxx-0.9.7.tar.gz) = fd09abc90b8c0c8af1d5146a75590792
-SHA256 (log4cxx-0.9.7.tar.gz) = 5b41b2fc267595bdb0fa4cd1152309413bc70e6d9196293113ebb82751eb7ec6
-SIZE (log4cxx-0.9.7.tar.gz) = 256449
+MD5 (apache-log4cxx-0.10.0.tar.gz) = b30ffb8da3665178e68940ff7a61084c
+SHA256 (apache-log4cxx-0.10.0.tar.gz) = 0de0396220a9566a580166e66b39674cb40efd2176f52ad2c65486c99c920c8c
+SIZE (apache-log4cxx-0.10.0.tar.gz) = 1667425
diff --git a/devel/log4cxx/files/patch-docs-Makefile.am b/devel/log4cxx/files/patch-docs-Makefile.am
deleted file mode 100644
index 4811d088feb4..000000000000
--- a/devel/log4cxx/files/patch-docs-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- docs/Makefile.am.orig Thu Jan 13 22:28:59 2005
-+++ docs/Makefile.am Thu Jan 13 22:29:35 2005
-@@ -10,7 +10,7 @@
-
- install-data-hook:
- $(mkinstalldirs) $(DESTDIR)$(htmldir)
-- cp -dpR html/* $(DESTDIR)$(htmldir)
-+ cp -PpR html/* $(DESTDIR)$(htmldir)
-
- # Automake's "distcheck" is sensitive to having files left over
- # after "make uninstall", so we have to clean up the install hook.
diff --git a/devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h b/devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h
deleted file mode 100644
index b3a869f09542..000000000000
--- a/devel/log4cxx/files/patch-include-log4cxx-helpers-tchar.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- include/log4cxx/helpers/tchar.h.orig Wed Jan 12 17:56:51 2005
-+++ include/log4cxx/helpers/tchar.h Wed Jan 12 17:57:04 2005
-@@ -83,6 +83,9 @@
- #include <malloc.h>
- #define USES_CONVERSION void * _dst = _alloca(1024);
- #endif
-+#elif defined( __FreeBSD__ )
-+ #include <stdlib.h>
-+ #define USES_CONVERSION void * _dst = alloca(1024);
- #else
- #include <alloca.h>
- #define USES_CONVERSION void * _dst = alloca(1024);
diff --git a/devel/log4cxx/files/patch-include-log4cxx-xml-domconfigurator.h b/devel/log4cxx/files/patch-include-log4cxx-xml-domconfigurator.h
deleted file mode 100644
index 121811a5710b..000000000000
--- a/devel/log4cxx/files/patch-include-log4cxx-xml-domconfigurator.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
---- include/log4cxx/xml/domconfigurator.h.orig 2008-08-12 23:36:20.000000000 +0200
-+++ include/log4cxx/xml/domconfigurator.h 2008-08-12 23:36:28.000000000 +0200
-@@ -208,7 +208,7 @@
- spi::LoggerRepositoryPtr& repository);
-
- protected:
-- String DOMConfigurator::subst(const String& value);
-+ String subst(const String& value);
-
- protected:
- void * appenderBag;
-
-
diff --git a/devel/log4cxx/pkg-plist b/devel/log4cxx/pkg-plist
index c32ace6bb4d5..f2105bb12ac5 100644
--- a/devel/log4cxx/pkg-plist
+++ b/devel/log4cxx/pkg-plist
@@ -1,89 +1,158 @@
-bin/simplesocketserver
include/log4cxx/appender.h
include/log4cxx/appenderskeleton.h
include/log4cxx/asyncappender.h
include/log4cxx/basicconfigurator.h
-include/log4cxx/config.h
include/log4cxx/config/propertysetter.h
-include/log4cxx/config_auto.h
-include/log4cxx/config_msvc.h
include/log4cxx/consoleappender.h
include/log4cxx/dailyrollingfileappender.h
include/log4cxx/db/odbcappender.h
-include/log4cxx/defaultcategoryfactory.h
+include/log4cxx/defaultconfigurator.h
+include/log4cxx/defaultloggerfactory.h
+include/log4cxx/file.h
include/log4cxx/fileappender.h
+include/log4cxx/filter/andfilter.h
+include/log4cxx/filter/denyallfilter.h
+include/log4cxx/filter/expressionfilter.h
+include/log4cxx/filter/levelmatchfilter.h
+include/log4cxx/filter/levelrangefilter.h
+include/log4cxx/filter/locationinfofilter.h
+include/log4cxx/filter/mapfilter.h
+include/log4cxx/filter/propertyfilter.h
+include/log4cxx/filter/stringmatchfilter.h
include/log4cxx/helpers/absolutetimedateformat.h
include/log4cxx/helpers/appenderattachableimpl.h
-include/log4cxx/helpers/boundedfifo.h
+include/log4cxx/helpers/aprinitializer.h
+include/log4cxx/helpers/bufferedoutputstream.h
+include/log4cxx/helpers/bufferedwriter.h
+include/log4cxx/helpers/bytearrayinputstream.h
+include/log4cxx/helpers/bytearrayoutputstream.h
+include/log4cxx/helpers/bytebuffer.h
+include/log4cxx/helpers/cacheddateformat.h
+include/log4cxx/helpers/charsetdecoder.h
+include/log4cxx/helpers/charsetencoder.h
include/log4cxx/helpers/class.h
+include/log4cxx/helpers/classregistration.h
include/log4cxx/helpers/condition.h
-include/log4cxx/helpers/criticalsection.h
include/log4cxx/helpers/cyclicbuffer.h
include/log4cxx/helpers/datagrampacket.h
include/log4cxx/helpers/datagramsocket.h
+include/log4cxx/helpers/date.h
include/log4cxx/helpers/dateformat.h
include/log4cxx/helpers/datelayout.h
include/log4cxx/helpers/datetimedateformat.h
-include/log4cxx/helpers/event.h
include/log4cxx/helpers/exception.h
+include/log4cxx/helpers/fileinputstream.h
+include/log4cxx/helpers/fileoutputstream.h
include/log4cxx/helpers/filewatchdog.h
-include/log4cxx/helpers/formattinginfo.h
-include/log4cxx/helpers/gnomexml.h
include/log4cxx/helpers/inetaddress.h
-include/log4cxx/helpers/intializationutil.h
+include/log4cxx/helpers/inputstream.h
+include/log4cxx/helpers/inputstreamreader.h
+include/log4cxx/helpers/integer.h
include/log4cxx/helpers/iso8601dateformat.h
include/log4cxx/helpers/loader.h
include/log4cxx/helpers/locale.h
include/log4cxx/helpers/loglog.h
-include/log4cxx/helpers/msxml.h
+include/log4cxx/helpers/messagebuffer.h
include/log4cxx/helpers/mutex.h
include/log4cxx/helpers/object.h
include/log4cxx/helpers/objectimpl.h
+include/log4cxx/helpers/objectoutputstream.h
+include/log4cxx/helpers/pool.h
include/log4cxx/helpers/objectptr.h
include/log4cxx/helpers/onlyonceerrorhandler.h
include/log4cxx/helpers/optionconverter.h
-include/log4cxx/helpers/patternconverter.h
-include/log4cxx/helpers/patternparser.h
+include/log4cxx/helpers/outputstream.h
+include/log4cxx/helpers/outputstreamwriter.h
include/log4cxx/helpers/properties.h
include/log4cxx/helpers/propertyresourcebundle.h
+include/log4cxx/helpers/reader.h
include/log4cxx/helpers/relativetimedateformat.h
include/log4cxx/helpers/resourcebundle.h
-include/log4cxx/helpers/semaphore.h
include/log4cxx/helpers/serversocket.h
+include/log4cxx/helpers/simpledateformat.h
include/log4cxx/helpers/socket.h
-include/log4cxx/helpers/socketimpl.h
-include/log4cxx/helpers/socketinputstream.h
include/log4cxx/helpers/socketoutputstream.h
+include/log4cxx/helpers/strftimedateformat.h
include/log4cxx/helpers/strictmath.h
include/log4cxx/helpers/stringhelper.h
include/log4cxx/helpers/stringtokenizer.h
-include/log4cxx/helpers/syslogwriter.h
include/log4cxx/helpers/system.h
+include/log4cxx/helpers/synchronized.h
+include/log4cxx/helpers/syslogwriter.h
+include/log4cxx/helpers/systemerrwriter.h
+include/log4cxx/helpers/systemoutwriter.h
include/log4cxx/helpers/tchar.h
include/log4cxx/helpers/thread.h
+include/log4cxx/helpers/threadlocal.h
include/log4cxx/helpers/threadspecificdata.h
include/log4cxx/helpers/timezone.h
+include/log4cxx/helpers/transcoder.h
include/log4cxx/helpers/transform.h
+include/log4cxx/helpers/writer.h
include/log4cxx/helpers/xml.h
include/log4cxx/hierarchy.h
include/log4cxx/htmllayout.h
include/log4cxx/layout.h
include/log4cxx/level.h
+include/log4cxx/log4cxx.h
include/log4cxx/logger.h
include/log4cxx/logmanager.h
+include/log4cxx/logstring.h
include/log4cxx/mdc.h
include/log4cxx/ndc.h
include/log4cxx/net/smtpappender.h
include/log4cxx/net/socketappender.h
+include/log4cxx/net/socketappenderskeleton.h
include/log4cxx/net/sockethubappender.h
-include/log4cxx/net/socketnode.h
include/log4cxx/net/syslogappender.h
include/log4cxx/net/telnetappender.h
include/log4cxx/net/xmlsocketappender.h
include/log4cxx/nt/nteventlogappender.h
+include/log4cxx/nt/outputdebugstringappender.h
+include/log4cxx/pattern/classnamepatternconverter.h
+include/log4cxx/pattern/datepatternconverter.h
+include/log4cxx/pattern/filedatepatternconverter.h
+include/log4cxx/pattern/filelocationpatternconverter.h
+include/log4cxx/pattern/formattinginfo.h
+include/log4cxx/pattern/fulllocationpatternconverter.h
+include/log4cxx/pattern/integerpatternconverter.h
+include/log4cxx/pattern/levelpatternconverter.h
+include/log4cxx/pattern/linelocationpatternconverter.h
+include/log4cxx/pattern/lineseparatorpatternconverter.h
+include/log4cxx/pattern/literalpatternconverter.h
+include/log4cxx/pattern/loggerpatternconverter.h
+include/log4cxx/pattern/loggingeventpatternconverter.h
+include/log4cxx/pattern/messagepatternconverter.h
+include/log4cxx/pattern/methodlocationpatternconverter.h
+include/log4cxx/pattern/nameabbreviator.h
+include/log4cxx/pattern/namepatternconverter.h
+include/log4cxx/pattern/ndcpatternconverter.h
+include/log4cxx/pattern/patternconverter.h
+include/log4cxx/pattern/patternparser.h
+include/log4cxx/pattern/propertiespatternconverter.h
+include/log4cxx/pattern/relativetimepatternconverter.h
+include/log4cxx/pattern/threadpatternconverter.h
+include/log4cxx/pattern/throwableinformationpatternconverter.h
include/log4cxx/patternlayout.h
+include/log4cxx/portability.h
+include/log4cxx/private/log4cxx_private.h
include/log4cxx/propertyconfigurator.h
include/log4cxx/provisionnode.h
+include/log4cxx/rolling/action.h
+include/log4cxx/rolling/filerenameaction.h
+include/log4cxx/rolling/filterbasedtriggeringpolicy.h
+include/log4cxx/rolling/fixedwindowrollingpolicy.h
+include/log4cxx/rolling/gzcompressaction.h
+include/log4cxx/rolling/manualtriggeringpolicy.h
+include/log4cxx/rolling/rollingfileappender.h
+include/log4cxx/rolling/rollingfileappenderskeleton.h
+include/log4cxx/rolling/rollingpolicy.h
+include/log4cxx/rolling/rollingpolicybase.h
+include/log4cxx/rolling/rolloverdescription.h
+include/log4cxx/rolling/sizebasedtriggeringpolicy.h
+include/log4cxx/rolling/timebasedrollingpolicy.h
+include/log4cxx/rolling/triggeringpolicy.h
+include/log4cxx/rolling/zipcompressaction.h
include/log4cxx/rollingfileappender.h
include/log4cxx/simplelayout.h
include/log4cxx/spi/appenderattachable.h
@@ -92,32 +161,36 @@ include/log4cxx/spi/defaultrepositoryselector.h
include/log4cxx/spi/errorhandler.h
include/log4cxx/spi/filter.h
include/log4cxx/spi/hierarchyeventlistener.h
+include/log4cxx/spi/location/locationinfo.h
include/log4cxx/spi/loggerfactory.h
include/log4cxx/spi/loggerrepository.h
include/log4cxx/spi/loggingevent.h
include/log4cxx/spi/optionhandler.h
include/log4cxx/spi/repositoryselector.h
-include/log4cxx/spi/rootcategory.h
+include/log4cxx/spi/rootlogger.h
include/log4cxx/spi/triggeringeventevaluator.h
+include/log4cxx/stream.h
include/log4cxx/ttcclayout.h
-include/log4cxx/varia/denyallfilter.h
include/log4cxx/varia/fallbackerrorhandler.h
-include/log4cxx/varia/levelmatchfilter.h
-include/log4cxx/varia/levelrangefilter.h
-include/log4cxx/varia/stringmatchfilter.h
include/log4cxx/writerappender.h
include/log4cxx/xml/domconfigurator.h
include/log4cxx/xml/xmllayout.h
lib/liblog4cxx.a
lib/liblog4cxx.la
lib/liblog4cxx.so
-lib/liblog4cxx.so.9
+lib/liblog4cxx.so.10
+libdata/pkgconfig/liblog4cxx.pc
@dirrm include/log4cxx/xml
@dirrm include/log4cxx/varia
+@dirrm include/log4cxx/spi/location
@dirrm include/log4cxx/spi
+@dirrm include/log4cxx/rolling
+@dirrm include/log4cxx/private
+@dirrm include/log4cxx/pattern
@dirrm include/log4cxx/nt
@dirrm include/log4cxx/net
@dirrm include/log4cxx/helpers
+@dirrm include/log4cxx/filter
@dirrm include/log4cxx/db
@dirrm include/log4cxx/config
@dirrm include/log4cxx