aboutsummaryrefslogtreecommitdiff
path: root/devel/lua50-posix
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:59:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-15 16:59:09 +0000
commit03c45c0a0d2292a754362d73b7810331897ab562 (patch)
tree2c59f55f52a0d76b9b4b18798e2c8751dae656ab /devel/lua50-posix
parent2ec89cef7172c1d9d698c7222dfcc4482579bafd (diff)
downloadports-03c45c0a0d2292a754362d73b7810331897ab562.tar.gz
ports-03c45c0a0d2292a754362d73b7810331897ab562.zip
LuaPosix is a Lua extension library that provides support for POSIX.
PR: ports/94987 Submitted by: Andrew Turner <andrew@fubar.geek.nz>
Notes
Notes: svn path=/head/; revision=159630
Diffstat (limited to 'devel/lua50-posix')
-rw-r--r--devel/lua50-posix/Makefile27
-rw-r--r--devel/lua50-posix/distinfo3
-rw-r--r--devel/lua50-posix/files/patch-Makefile20
-rw-r--r--devel/lua50-posix/files/patch-posix.lua8
-rw-r--r--devel/lua50-posix/pkg-descr1
-rw-r--r--devel/lua50-posix/pkg-plist6
6 files changed, 65 insertions, 0 deletions
diff --git a/devel/lua50-posix/Makefile b/devel/lua50-posix/Makefile
new file mode 100644
index 000000000000..0e10e63b3bbc
--- /dev/null
+++ b/devel/lua50-posix/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: lua50-posix
+# Date created: 27 March 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lua50-posix
+PORTVERSION= 5.0
+CATEGORIES= devel
+MASTER_SITES= http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/
+DISTFILES= lposix.tar.gz
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= A POSIX layer for Lua
+
+BUILD_DEPENDS= ${LOCALBASE}/include/lua.h:${PORTSDIR}/lang/lua
+
+WRKSRC= ${WRKDIR}/posix
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/share/lua/5.0
+ @ ${INSTALL_DATA} ${WRKSRC}/posix.lua ${PREFIX}/share/lua/5.0
+ @ ${MKDIR} ${PREFIX}/lib/lua/5.0
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/lposix.so ${PREFIX}/lib/lua/5.0
+
+.include <bsd.port.mk>
diff --git a/devel/lua50-posix/distinfo b/devel/lua50-posix/distinfo
new file mode 100644
index 000000000000..87ec6b660a1a
--- /dev/null
+++ b/devel/lua50-posix/distinfo
@@ -0,0 +1,3 @@
+MD5 (lposix.tar.gz) = f22871247e444412a901d179028a0d82
+SHA256 (lposix.tar.gz) = e5140e19df90069b579be7983506e2461b6678e9e80b82545b6ca8070fd318a3
+SIZE (lposix.tar.gz) = 9651
diff --git a/devel/lua50-posix/files/patch-Makefile b/devel/lua50-posix/files/patch-Makefile
new file mode 100644
index 000000000000..8c8f05bddff7
--- /dev/null
+++ b/devel/lua50-posix/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Mon Mar 27 12:25:04 2006
++++ Makefile Mon Mar 27 12:43:24 2006
+@@ -1,7 +1,7 @@
+ # makefile for POSIX library for Lua
+
+ # change these to reflect your Lua installation
+-LUA= /tmp/lhf/lua-5.0
++LUA= ${PREFIX}
+ LUAINC= $(LUA)/include
+ LUALIB= $(LUA)/lib
+ LUABIN= $(LUA)/bin
+@@ -21,7 +21,7 @@
+ all: test
+
+ test: $T
+- $(LUABIN)/lua -l$(MYNAME) test.lua
++ LD_PRELOAD=${PREFIX}/lib/liblua.so:${PREFIX}/lib/liblualib.so $(LUABIN)/lua -l$(MYNAME) test.lua
+
+ $T: $(OBJS)
+ $(CC) -o $@ -shared $(OBJS)
diff --git a/devel/lua50-posix/files/patch-posix.lua b/devel/lua50-posix/files/patch-posix.lua
new file mode 100644
index 000000000000..175746fb81df
--- /dev/null
+++ b/devel/lua50-posix/files/patch-posix.lua
@@ -0,0 +1,8 @@
+--- posix.lua.orig Tue Apr 11 23:59:52 2006
++++ posix.lua Wed Apr 12 00:00:49 2006
+@@ -8,3 +8,5 @@
+ end
+
+ so"posix"
++
++return posix
diff --git a/devel/lua50-posix/pkg-descr b/devel/lua50-posix/pkg-descr
new file mode 100644
index 000000000000..4832b76b0ee3
--- /dev/null
+++ b/devel/lua50-posix/pkg-descr
@@ -0,0 +1 @@
+LuaPosix is a Lua extension library that provides support for POSIX.
diff --git a/devel/lua50-posix/pkg-plist b/devel/lua50-posix/pkg-plist
new file mode 100644
index 000000000000..036b7a2881f3
--- /dev/null
+++ b/devel/lua50-posix/pkg-plist
@@ -0,0 +1,6 @@
+share/lua/5.0/posix.lua
+lib/lua/5.0/lposix.so
+@dirrmtry share/lua/5.0
+@dirrmtry share/lua
+@dirrmtry lib/lua/5.0
+@dirrmtry lib/lua