aboutsummaryrefslogtreecommitdiff
path: root/devel/m4
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-03-09 06:12:07 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-03-09 06:12:07 +0000
commit902ed3bd26956ccaf851fd2857479fcff47c9cdf (patch)
treee14cc7871be188915b0591245db71202641214c5 /devel/m4
parent0ac4fba2507eeb47a90a2618c6a94abdfc2ba2a4 (diff)
downloadports-902ed3bd26956ccaf851fd2857479fcff47c9cdf.tar.gz
ports-902ed3bd26956ccaf851fd2857479fcff47c9cdf.zip
Update to 1.4.14 (bugfix release mostly)
Remove patch that's now included in upstream release; add gnulib patch for posix_spawn check (will be in next release) PR: ports/144314 Tested by: exp-run by pav (twice)
Notes
Notes: svn path=/head/; revision=250747
Diffstat (limited to 'devel/m4')
-rw-r--r--devel/m4/Makefile2
-rw-r--r--devel/m4/distinfo6
-rw-r--r--devel/m4/files/patch-lib_spawn.in.h50
-rw-r--r--devel/m4/files/patch-src-output.c11
4 files changed, 54 insertions, 15 deletions
diff --git a/devel/m4/Makefile b/devel/m4/Makefile
index 17626d5c0761..66cf0a181d95 100644
--- a/devel/m4/Makefile
+++ b/devel/m4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= m4
-PORTVERSION= 1.4.13
+PORTVERSION= 1.4.14
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
diff --git a/devel/m4/distinfo b/devel/m4/distinfo
index 1dc9f1c0c6c0..9998d796d596 100644
--- a/devel/m4/distinfo
+++ b/devel/m4/distinfo
@@ -1,3 +1,3 @@
-MD5 (m4-1.4.13.tar.bz2) = 28f9ccd3ac4da45409251008b911d677
-SHA256 (m4-1.4.13.tar.bz2) = fcc6fe95e31476dae0fe17a941603c9876cffd0172c8985787388b99a5caec06
-SIZE (m4-1.4.13.tar.bz2) = 1008418
+MD5 (m4-1.4.14.tar.bz2) = e6fb7d08d50d87e796069cff12a52a93
+SHA256 (m4-1.4.14.tar.bz2) = 0885ffa93256353a96b1cf0bcbc4d639ed09953b687e6cc412c4048e656f4dd2
+SIZE (m4-1.4.14.tar.bz2) = 1125670
diff --git a/devel/m4/files/patch-lib_spawn.in.h b/devel/m4/files/patch-lib_spawn.in.h
new file mode 100644
index 000000000000..2e683dcb2a77
--- /dev/null
+++ b/devel/m4/files/patch-lib_spawn.in.h
@@ -0,0 +1,50 @@
+2010-03-02 Bruno Haible <bruno@clisp.org>
+
+ spawn: Don't override the system defined values on FreeBSD 8.
+ * lib/spawn.in.h (POSIX_SPAWN_RESETIDS, POSIX_SPAWN_SETPGROUP,
+ POSIX_SPAWN_SETSIGDEF, POSIX_SPAWN_SETSIGMASK,
+ POSIX_SPAWN_SETSCHEDPARAM, POSIX_SPAWN_SETSCHEDULER): Don't redefine
+ if HAVE_POSIX_SPAWN is 1.
+ Reported by Johan van Selst <johans@stack.nl> via Eric Blake.
+
+*** lib/spawn.in.h.orig Tue Mar 2 11:53:02 2010
+--- lib/spawn.in.h Tue Mar 2 11:48:54 2010
+***************
+*** 110,126 ****
+
+
+ /* Flags to be set in the `posix_spawnattr_t'. */
+! #if @REPLACE_POSIX_SPAWN@
+ /* Use the values from the system, for better compatibility. */
+ /* But this implementation does not support AIX extensions. */
+! # undef POSIX_SPAWN_FORK_HANDLERS
+! #else
+! # define POSIX_SPAWN_RESETIDS 0x01
+! # define POSIX_SPAWN_SETPGROUP 0x02
+! # define POSIX_SPAWN_SETSIGDEF 0x04
+! # define POSIX_SPAWN_SETSIGMASK 0x08
+! # define POSIX_SPAWN_SETSCHEDPARAM 0x10
+! # define POSIX_SPAWN_SETSCHEDULER 0x20
+ #endif
+ /* A GNU extension. Use the next free bit position. */
+ #define POSIX_SPAWN_USEVFORK \
+--- 110,128 ----
+
+
+ /* Flags to be set in the `posix_spawnattr_t'. */
+! #if !@HAVE_POSIX_SPAWN@
+! # if @REPLACE_POSIX_SPAWN@
+ /* Use the values from the system, for better compatibility. */
+ /* But this implementation does not support AIX extensions. */
+! # undef POSIX_SPAWN_FORK_HANDLERS
+! # else
+! # define POSIX_SPAWN_RESETIDS 0x01
+! # define POSIX_SPAWN_SETPGROUP 0x02
+! # define POSIX_SPAWN_SETSIGDEF 0x04
+! # define POSIX_SPAWN_SETSIGMASK 0x08
+! # define POSIX_SPAWN_SETSCHEDPARAM 0x10
+! # define POSIX_SPAWN_SETSCHEDULER 0x20
+! # endif
+ #endif
+ /* A GNU extension. Use the next free bit position. */
+ #define POSIX_SPAWN_USEVFORK \
diff --git a/devel/m4/files/patch-src-output.c b/devel/m4/files/patch-src-output.c
deleted file mode 100644
index 5d97ec428d22..000000000000
--- a/devel/m4/files/patch-src-output.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/output.c.orig 2007-07-05 03:56:06.000000000 +0000
-+++ src/output.c 2007-12-12 03:48:25.000000000 +0000
-@@ -254,2 +254,8 @@
- "Warning: cannot protect diversion across forks"));
-+ /* POSIX states that it is undefined whether an append stream starts
-+ * at offset 0 or at the end. We want the beginning.
-+ */
-+ else if (fseeko (file, 0, SEEK_SET) != 0)
-+ M4ERROR ((EXIT_FAILURE, errno,
-+ "cannot seek to beginning of diversion"));
- return file;