aboutsummaryrefslogtreecommitdiff
path: root/devel/make++/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-04-21 18:48:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-04-21 18:48:24 +0000
commitf3f7ffb70350e76cbd98247d9111f74f46de266d (patch)
tree67febfe5450aa9d53ba6ee22b98d2687c1367706 /devel/make++/Makefile
parentabc61d16d2ed93e08a04f9f316b236f5292a2097 (diff)
downloadports-f3f7ffb70350e76cbd98247d9111f74f46de266d.tar.gz
ports-f3f7ffb70350e76cbd98247d9111f74f46de266d.zip
- Update to version 2.0
PR: 166880 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=295215
Diffstat (limited to 'devel/make++/Makefile')
-rw-r--r--devel/make++/Makefile33
1 files changed, 20 insertions, 13 deletions
diff --git a/devel/make++/Makefile b/devel/make++/Makefile
index 7b0362148651..763721295e3c 100644
--- a/devel/make++/Makefile
+++ b/devel/make++/Makefile
@@ -7,10 +7,11 @@
#
PORTNAME= make++
-DISTVERSION= 1.40.1a
+PORTVERSION= 2.0
CATEGORIES= devel perl5
-MASTER_SITES= SF/${PORTNAME:S/+/p/g}/${DISTVERSION:S/a//}
-DISTNAME= ${PORTNAME:S/+/p/g}-${DISTVERSION:S/\.a//}
+MASTER_SITES= SF/${PORTNAME:S/+/p/g}/${PORTVERSION}
+DISTNAME= ${PORTNAME:S/+/p/g}-${PORTVERSION}
+EXTRACT_SUFX= .txz
MAINTAINER= ports@FreeBSD.org
COMMENT= A drop-in replacement for GNU make
@@ -18,8 +19,7 @@ COMMENT= A drop-in replacement for GNU make
LICENSE= ART10 GPLv1 GPLv2 GPLv3
LICENSE_COMB= dual
-WRKSRC= ${WRKDIR}/${PORTNAME:S/+/p/g}-${DISTVERSION:R}
-
+USE_XZ= yes
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
@@ -28,14 +28,21 @@ DATADIR= ${PREFIX}/share/${PORTNAME:S/+/p/g}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/+/p/g}
MAN1= makepp.1 makepp_build_algorithm.1 \
- makepp_builtin.1 makepp_command.1 \
+ makepp_build_cache.1 makepp_build_check.1 \
+ makepp_builtin.1 makepp_builtins.1 \
+ makepp_command.1 makepp_compatibility.1 \
makepp_cookbook.1 makepp_extending.1 \
- makepp_functions.1 makepp_incompatibilities.1 \
- makepp_release_notes.1 makepp_repositories.1 \
- makepp_rules.1 makepp_scanning.1 \
- makepp_signatures.1 makepp_statements.1 \
- makepp_tutorial.1 makepp_tutorial_compilation.1 \
- makepp_variables.1 makeppclient.1
+ makepp_faq.1 makepp_functions.1 \
+ makepp_incompatibilities.1 makepp_release_notes.1 \
+ makepp_repositories.1 makepp_rules.1 \
+ makepp_sandboxes.1 makepp_scanning.1 \
+ makepp_signatures.1 makepp_speedup.1 \
+ makepp_statements.1 makepp_tutorial.1 \
+ makepp_tutorial_compilation.1 makepp_variables.1 \
+ makeppbuiltin.1 makeppclean.1 \
+ makeppgraph.1 makeppinfo.1 \
+ makepplog.1 makeppreplay.1 \
+ perl_performance.1
.include <bsd.port.pre.mk>
@@ -50,6 +57,6 @@ CONFIGURE_ARGS+=--htmldir=${DOCSDIR}/html
.endif
post-patch:
- @${REINPLACE_CMD} -e '/^all:/s|test||' ${WRKSRC}/config.pl
+ @${TOUCH} ${WRKSRC}/.test_done
.include <bsd.port.post.mk>