aboutsummaryrefslogtreecommitdiff
path: root/devel/mercurial
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-03 12:16:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-03 12:16:00 +0000
commit57545737cb90afafaf72a78a994de318a55b0a14 (patch)
treeddece04592ba9a4b8a185266fc0447338c5c7e4f /devel/mercurial
parentd2a50a43a96cf432c614abbaf6b05818cbc94b49 (diff)
downloadports-57545737cb90afafaf72a78a994de318a55b0a14.tar.gz
ports-57545737cb90afafaf72a78a994de318a55b0a14.zip
- Fix shebang
- Strip shared library - Bump PORTREVISION for package change PR: ports/184456 Submitted by: mandree
Notes
Notes: svn path=/head/; revision=335564
Diffstat (limited to 'devel/mercurial')
-rw-r--r--devel/mercurial/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/mercurial/Makefile b/devel/mercurial/Makefile
index c53ffbffb93a..c1e644d80b97 100644
--- a/devel/mercurial/Makefile
+++ b/devel/mercurial/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mercurial
PORTVERSION= 2.8.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://mercurial.selenic.com/release/
@@ -13,6 +14,7 @@ LICENSE= GPLv2
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
+USES= shebangfix
OPTIONS_DEFINE= CA_BUNDLE DATA DOCS NLS
OPTIONS_DEFAULT=DATA
@@ -55,6 +57,8 @@ CONTRIB_FILES= bash_completion \
vim/patchreview.vim
DOCS= CONTRIBUTORS README
+SHEBANG_FILES= contrib/tmplrewrite.py
+
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
NLS_USES= gettext
@@ -71,6 +75,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-setup.py
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${STAGEDIR}${PREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/doc/*.5 ${STAGEDIR}${PREFIX}/man/man5/
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/*.so
.if ${PORT_OPTIONS:MDATA}
${MKDIR} ${STAGEDIR}${DATADIR}
${MKDIR} ${STAGEDIR}${DATADIR}/contrib