aboutsummaryrefslogtreecommitdiff
path: root/devel/mkmf
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>1996-03-13 22:53:32 +0000
committerStefan Eßer <se@FreeBSD.org>1996-03-13 22:53:32 +0000
commit54b0fed67a1e52596705c7d6b3846f97eeb48509 (patch)
tree623bf33536ac98dd2f0cf97806d14693cbd1dd0d /devel/mkmf
parentc78185401f8b5ba62dc48d66a5f8d8369488c783 (diff)
downloadports-54b0fed67a1e52596705c7d6b3846f97eeb48509.tar.gz
ports-54b0fed67a1e52596705c7d6b3846f97eeb48509.zip
A port of Peter J. Nicklin's automatic Makefile generator.
Notes
Notes: svn path=/head/; revision=2835
Diffstat (limited to 'devel/mkmf')
-rw-r--r--devel/mkmf/Makefile17
-rw-r--r--devel/mkmf/distinfo1
-rw-r--r--devel/mkmf/files/patch-aa49
-rw-r--r--devel/mkmf/files/patch-ab28
-rw-r--r--devel/mkmf/pkg-comment14
-rw-r--r--devel/mkmf/pkg-descr1
-rw-r--r--devel/mkmf/pkg-plist8
7 files changed, 118 insertions, 0 deletions
diff --git a/devel/mkmf/Makefile b/devel/mkmf/Makefile
new file mode 100644
index 000000000000..a677f39c4c1e
--- /dev/null
+++ b/devel/mkmf/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: mkmf
+# Version required: 4.11
+# Date created: 14 Mar 1996
+# Whom: se
+#
+# $Id$
+#
+
+DISTNAME= mkmf
+PKGNAME= mkmf-4.11
+CATEGORIES+= devel
+MASTER_SITES= ftp://ftp.uni-koeln.de/util/
+
+MAINTAINER= se@FreeBSD.org
+
+.include <bsd.port.mk>
+
diff --git a/devel/mkmf/distinfo b/devel/mkmf/distinfo
new file mode 100644
index 000000000000..22489f1ddb7a
--- /dev/null
+++ b/devel/mkmf/distinfo
@@ -0,0 +1 @@
+MD5 (mkmf.tar.gz) = 56cc8cda58a3bbf577ef1a1b0f7ff00e
diff --git a/devel/mkmf/files/patch-aa b/devel/mkmf/files/patch-aa
new file mode 100644
index 000000000000..97b039a3eba4
--- /dev/null
+++ b/devel/mkmf/files/patch-aa
@@ -0,0 +1,49 @@
+*** Makefile.orig Tue Nov 26 17:16:37 1991
+--- Makefile Wed Mar 13 23:38:28 1996
+***************
+*** 1,3 ****
+! INSTALLDIR= /usr/contrib
+
+ SUBDIR= src templates
+--- 1,3 ----
+! INSTALLDIR= $(PREFIX)
+
+ SUBDIR= src templates
+*** src/Makefile.orig Wed May 26 09:19:57 1993
+--- src/Makefile Wed Mar 13 23:39:35 1996
+***************
+*** 5,11 ****
+ #CFLAGS= -O -DUNICOS5 -DINSTALLDIR=\"$(INSTALLDIR)\" # Cray Unicos 5.x
+
+! CFLAGS = -O -DBSD4X -DINSTALLDIR=\"$(INSTALLDIR)\" # Generic BSD
+
+! INSTALLDIR= /usr/contrib
+
+ PROG= mkmf
+--- 5,15 ----
+ #CFLAGS= -O -DUNICOS5 -DINSTALLDIR=\"$(INSTALLDIR)\" # Cray Unicos 5.x
+
+! #CFLAGS = -O -DBSD4X -DINSTALLDIR=\"$(INSTALLDIR)\" # Generic BSD
+
+! CFLAGS+= -DBSD4X -DINSTALLDIR=\"$(INSTALLDIR)\"
+!
+! INSTALLDIR= $(PREFIX)
+! BINDIR= $(INSTALLDIR)/bin
+! MANDIR= $(INSTALLDIR)/man/man
+
+ PROG= mkmf
+*** templates/Makefile~ Tue Nov 26 17:16:50 1991
+--- templates/Makefile Wed Mar 13 23:42:36 1996
+***************
+*** 10,14 ****
+ C.p
+
+! INSTALLDIR= /usr/contrib
+
+ MKMFLIB= ${DESTDIR}$(INSTALLDIR)/lib/mkmf
+--- 10,14 ----
+ C.p
+
+! INSTALLDIR= $(PREFIX)
+
+ MKMFLIB= ${DESTDIR}$(INSTALLDIR)/lib/mkmf
diff --git a/devel/mkmf/files/patch-ab b/devel/mkmf/files/patch-ab
new file mode 100644
index 000000000000..8a2d5d507d2b
--- /dev/null
+++ b/devel/mkmf/files/patch-ab
@@ -0,0 +1,28 @@
+*** src/misc.c~ Wed May 26 06:51:17 1993
+--- src/misc.c Wed Mar 13 23:37:13 1996
+***************
+*** 68,76 ****
+ HASHBLK *htinstall(); /* install hash table entry */
+
+! if (gets(answerbuf) == NULL)
+ exit(1);
+ if (*answerbuf != '\0')
+ if (htinstall(mdefkey, answerbuf, mdefval, MDEFTABLE) == NULL)
+ exit(1);
+ }
+
+--- 68,81 ----
+ HASHBLK *htinstall(); /* install hash table entry */
+
+! if (fgets(answerbuf, ANSWERBUFSIZE, stdin) == NULL)
+ exit(1);
+ if (*answerbuf != '\0')
++ {
++ char *nlpos = strchr(answerbuf, '\n');
++ if (nlpos)
++ *nlpos = '\0';
+ if (htinstall(mdefkey, answerbuf, mdefval, MDEFTABLE) == NULL)
+ exit(1);
++ }
+ }
+
diff --git a/devel/mkmf/pkg-comment b/devel/mkmf/pkg-comment
new file mode 100644
index 000000000000..df82ceab261c
--- /dev/null
+++ b/devel/mkmf/pkg-comment
@@ -0,0 +1,14 @@
+The mkmf makefile editor creates program and library makefiles for the
+make(1) command. Mkmf has the following features:
+
+ - Automatically inserts source and object code file names in
+ makefiles.
+
+ - Provides standard makefile templates for programs and libraries.
+
+ - Allows user-defined makefile templates.
+
+ - Generates included file dependencies for C, C++, Pascal, and Fortran
+ source code
+
+ - Allows arbitrary editing of makefiles with a regular text editor
diff --git a/devel/mkmf/pkg-descr b/devel/mkmf/pkg-descr
new file mode 100644
index 000000000000..b1161f141c2d
--- /dev/null
+++ b/devel/mkmf/pkg-descr
@@ -0,0 +1 @@
+mkmf makefile editor (revision 4.11)
diff --git a/devel/mkmf/pkg-plist b/devel/mkmf/pkg-plist
new file mode 100644
index 000000000000..6177feecc142
--- /dev/null
+++ b/devel/mkmf/pkg-plist
@@ -0,0 +1,8 @@
+bin/mkmf
+lib/mkmf/C++.L
+lib/mkmf/C++.l
+lib/mkmf/C++.p
+lib/mkmf/C.L
+lib/mkmf/C.l
+lib/mkmf/C.p
+man/man1/mkmf.1.gz