aboutsummaryrefslogtreecommitdiff
path: root/devel/msp430-binutils
diff options
context:
space:
mode:
authorLev A. Serebryakov <lev@FreeBSD.org>2004-02-24 14:44:27 +0000
committerLev A. Serebryakov <lev@FreeBSD.org>2004-02-24 14:44:27 +0000
commit1861a670a6a0373bf6f03ed57161645cc947d4a7 (patch)
tree927c150bfe2f91c2a0c49774f46039c8c93b7deb /devel/msp430-binutils
parent3e244058762d901d10a0dc954cc6c8d23a6f37e7 (diff)
downloadports-1861a670a6a0373bf6f03ed57161645cc947d4a7.tar.gz
ports-1861a670a6a0373bf6f03ed57161645cc947d4a7.zip
New devices added, old ones fixed...
Notes
Notes: svn path=/head/; revision=101985
Diffstat (limited to 'devel/msp430-binutils')
-rw-r--r--devel/msp430-binutils/Makefile2
-rw-r--r--devel/msp430-binutils/files/patch-gas::config::tc-msp430.c39
-rw-r--r--devel/msp430-binutils/files/patch-ld::Makefile.am47
-rw-r--r--devel/msp430-binutils/files/patch-ld::Makefile.in51
-rw-r--r--devel/msp430-binutils/files/patch-ld::configure.tgt18
-rw-r--r--devel/msp430-binutils/files/patch-ld::emulparams::msp430x148.sh11
-rw-r--r--devel/msp430-binutils/files/patch-ld::emulparams::msp430x1610.sh18
-rw-r--r--devel/msp430-binutils/files/patch-ld::emulparams::msp430x1611.sh18
-rw-r--r--devel/msp430-binutils/files/patch-ld::emulparams::msp430x1612.sh18
-rw-r--r--devel/msp430-binutils/files/patch-ld::emulparams::msp430x168.sh11
-rw-r--r--devel/msp430-binutils/files/patch-ld::emulparams::msp430x448.sh11
-rw-r--r--devel/msp430-binutils/pkg-plist17
12 files changed, 164 insertions, 97 deletions
diff --git a/devel/msp430-binutils/Makefile b/devel/msp430-binutils/Makefile
index a93072eabb9b..0464411c11e9 100644
--- a/devel/msp430-binutils/Makefile
+++ b/devel/msp430-binutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= binutils
PORTVERSION= ${BINUTILVERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
diff --git a/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c b/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c
index f533a2d78172..457adecc0cab 100644
--- a/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c
+++ b/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c
@@ -1,8 +1,6 @@
--- gas/config/tc-msp430.c.orig Tue Mar 4 19:34:40 2003
-+++ gas/config/tc-msp430.c Mon Aug 11 17:21:43 2003
-@@ -69,72 +69,85 @@
- int isa;
- int mach;
++++ gas/config/tc-msp430.c Tue Feb 24 16:07:33 2004
+@@ -71,18 +71,19 @@
};
#define MSP430_ISA_11 11
@@ -26,10 +24,7 @@
#define CHECK_RELOC_MSP430 ((imm_op || byte_op)?BFD_RELOC_MSP430_16_BYTE:BFD_RELOC_MSP430_16)
#define CHECK_RELOC_MSP430_PCREL ((imm_op || byte_op)?BFD_RELOC_MSP430_16_PCREL_BYTE:BFD_RELOC_MSP430_16_PCREL)
-
- static struct mcu_type_s mcu_types[] =
- {
- {"msp1", MSP430_ISA_11, bfd_mach_msp11},
+@@ -93,20 +94,35 @@
{"msp2", MSP430_ISA_14, bfd_mach_msp14},
{"msp430x110", MSP430_ISA_11, bfd_mach_msp11},
{"msp430x112", MSP430_ISA_11, bfd_mach_msp11},
@@ -63,13 +58,14 @@
+ {"msp430x167", MSP430_ISA_16, bfd_mach_msp16},
+ {"msp430x168", MSP430_ISA_16, bfd_mach_msp16},
+ {"msp430x169", MSP430_ISA_16, bfd_mach_msp16},
++ {"msp430x1610", MSP430_ISA_16, bfd_mach_msp16},
++ {"msp430x1611", MSP430_ISA_16, bfd_mach_msp16},
++ {"msp430x1612", MSP430_ISA_16, bfd_mach_msp16},
+
{"msp430x311", MSP430_ISA_31, bfd_mach_msp31},
{"msp430x312", MSP430_ISA_31, bfd_mach_msp31},
{"msp430x313", MSP430_ISA_31, bfd_mach_msp31},
- {"msp430x314", MSP430_ISA_31, bfd_mach_msp31},
- {"msp430x315", MSP430_ISA_31, bfd_mach_msp31},
- {"msp430x323", MSP430_ISA_32, bfd_mach_msp32},
+@@ -116,23 +132,23 @@
{"msp430x325", MSP430_ISA_32, bfd_mach_msp32},
{"msp430x336", MSP430_ISA_33, bfd_mach_msp33},
{"msp430x337", MSP430_ISA_33, bfd_mach_msp33},
@@ -104,11 +100,7 @@
{NULL, 0, 0}
};
-
-
-@@ -184,18 +197,22 @@
- " -mmcu=[msp430-name] select microcontroller type\n"
- " msp430x110 msp430x112\n"
+@@ -186,14 +202,19 @@
" msp430x1101 msp430x1111\n"
" msp430x1121 msp430x1122 msp430x1132\n"
" msp430x122 msp430x123\n"
@@ -118,6 +110,7 @@
" msp430x147 msp430x148 msp430x149\n"
" msp430x155 msp430x156 msp430x157\n"
" msp430x167 msp430x168 msp430x169\n"
++ " msp430x1610 msp430x1611 msp430x1612\n"
" msp430x311 msp430x312 msp430x313 msp430x314 msp430x315\n"
" msp430x323 msp430x325\n"
" msp430x336 msp430x337\n"
@@ -127,11 +120,7 @@
" msp430x435 msp430x436 msp430x437\n"
" msp430x447 msp430x448 msp430x449\n"));
- show_mcu_list (stream);
- }
-@@ -977,15 +994,11 @@
- op->mode = OP_REG;
- }
+@@ -979,11 +1000,7 @@
else if (x == 4)
{
#ifdef PUSH_1X_WORKAROUND
@@ -144,11 +133,7 @@
{
/* Remove warning as confusing.
as_warn(_("Hardware push bug workaround")); */
- }
- else
-@@ -998,15 +1011,11 @@
- }
- }
+@@ -1000,11 +1017,7 @@
else if (x == 8)
{
#ifdef PUSH_1X_WORKAROUND
@@ -161,5 +146,3 @@
{
/* Remove warning as confusing.
as_warn(_("Hardware push bug workaround")); */
- }
- else
diff --git a/devel/msp430-binutils/files/patch-ld::Makefile.am b/devel/msp430-binutils/files/patch-ld::Makefile.am
index c35b0d3cee41..239225cba2f0 100644
--- a/devel/msp430-binutils/files/patch-ld::Makefile.am
+++ b/devel/msp430-binutils/files/patch-ld::Makefile.am
@@ -1,8 +1,6 @@
---- ld/Makefile.am 2003-04-24 20:36:07.000000000 +0800
-+++ ld/Makefile.am 2003-08-06 01:55:25.000000000 +0800
-@@ -250,50 +250,57 @@
- emipsidt.o \
- emipsidtl.o \
+--- ld/Makefile.am.orig Thu Apr 24 16:36:07 2003
++++ ld/Makefile.am Tue Feb 24 16:23:08 2004
+@@ -252,26 +252,33 @@
emipslit.o \
emipslnews.o \
emipspe.o \
@@ -42,12 +40,13 @@
+ emsp430x167.o \
+ emsp430x168.o \
+ emsp430x169.o \
++ emsp430x1610.o \
++ emsp430x1611.o \
++ emsp430x1612.o \
emsp430x311.o \
emsp430x312.o \
emsp430x313.o \
- emsp430x314.o \
- emsp430x315.o \
- emsp430x323.o \
+@@ -281,17 +288,20 @@
emsp430x325.o \
emsp430x336.o \
emsp430x337.o \
@@ -74,11 +73,7 @@
enews.o \
ens32knbsd.o \
eor32.o \
- eor32elf.o \
- epc532macha.o \
-@@ -1016,10 +1023,18 @@
- $(srcdir)/emultempl/elf32.em $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
- ${GENSCRIPTS} mn10300 "$(tdir_mn10300)"
+@@ -1018,6 +1028,14 @@
emn10200.c: $(srcdir)/emulparams/mn10200.sh \
$(srcdir)/emultempl/elf32.em $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
${GENSCRIPTS} mn10200 "$(tdir_mn10200)"
@@ -93,11 +88,7 @@
emsp430x1101.c: $(srcdir)/emulparams/msp430x1101.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
${GEN_DEPENDS}
- ${GENSCRIPTS} msp430x1101 "$(tdir_msp430x1101)"
- emsp430x1111.c: $(srcdir)/emulparams/msp430x1111.sh \
-@@ -1036,82 +1051,78 @@
- ${GENSCRIPTS} msp430x1122 "$(tdir_msp430x1122)"
- emsp430x1132.c: $(srcdir)/emulparams/msp430x1132.sh \
+@@ -1038,78 +1056,86 @@
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
${GEN_DEPENDS}
${GENSCRIPTS} msp430x1132 "$(tdir_msp430x1132)"
@@ -205,14 +196,22 @@
${GEN_DEPENDS}
- ${GENSCRIPTS} msp430x1232 "$(tdir_msp430x1232)"
+ ${GENSCRIPTS} msp430x169 "$(tdir_msp430x169)"
++emsp430x1610.c: $(srcdir)/emulparams/msp430x1610.sh \
++ $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc
++ ${GEN_DEPENDS}
++ ${GENSCRIPTS} msp430x1610 "$(tdir_msp430x1610)"
++emsp430x1611.c: $(srcdir)/emulparams/msp430x1611.sh \
++ $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc
++ ${GEN_DEPENDS}
++ ${GENSCRIPTS} msp430x1611 "$(tdir_msp430x1611)"
++emsp430x1612.c: $(srcdir)/emulparams/msp430x1612.sh \
++ $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc
++ ${GEN_DEPENDS}
++ ${GENSCRIPTS} msp430x1612 "$(tdir_msp430x1612)"
emsp430x311.c: $(srcdir)/emulparams/msp430x311.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430_3.sc \
${GEN_DEPENDS}
- ${GENSCRIPTS} msp430x311 "$(tdir_msp430x311)"
- emsp430x312.c: $(srcdir)/emulparams/msp430x312.sh \
-@@ -1144,46 +1155,66 @@
- ${GENSCRIPTS} msp430x336 "$(tdir_msp430x336)"
- emsp430x337.c: $(srcdir)/emulparams/msp430x337.sh \
+@@ -1146,42 +1172,62 @@
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430_3.sc \
${GEN_DEPENDS}
${GENSCRIPTS} msp430x337 "$(tdir_msp430x337)"
@@ -293,5 +292,3 @@
enews.c: $(srcdir)/emulparams/news.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/aout.sc ${GEN_DEPENDS}
${GENSCRIPTS} news "$(tdir_news)"
- ens32knbsd.c: $(srcdir)/emulparams/ns32knbsd.sh \
- $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/aout.sc ${GEN_DEPENDS}
diff --git a/devel/msp430-binutils/files/patch-ld::Makefile.in b/devel/msp430-binutils/files/patch-ld::Makefile.in
index dfe17e84853f..a9ee470df291 100644
--- a/devel/msp430-binutils/files/patch-ld::Makefile.in
+++ b/devel/msp430-binutils/files/patch-ld::Makefile.in
@@ -1,8 +1,6 @@
---- ld/Makefile.in 2003-04-24 20:36:07.000000000 +0800
-+++ ld/Makefile.in 2003-08-06 01:56:36.000000000 +0800
-@@ -364,50 +364,57 @@
- emipsidt.o \
- emipsidtl.o \
+--- ld/Makefile.in.orig Thu Apr 24 16:36:07 2003
++++ ld/Makefile.in Tue Feb 24 16:26:34 2004
+@@ -366,26 +366,33 @@
emipslit.o \
emipslnews.o \
emipspe.o \
@@ -25,10 +23,9 @@
emsp430x122.o \
emsp430x1222.o \
emsp430x123.o \
-- emsp430x1232.o \
+ emsp430x1232.o \
- emsp430x412.o \
- emsp430x413.o \
-+ emsp430x1232.o \
+ emsp430x133.o \
+ emsp430x135.o \
+ emsp430x1331.o \
@@ -42,12 +39,13 @@
+ emsp430x167.o \
+ emsp430x168.o \
+ emsp430x169.o \
++ emsp430x1610.o \
++ emsp430x1611.o \
++ emsp430x1612.o \
emsp430x311.o \
emsp430x312.o \
emsp430x313.o \
- emsp430x314.o \
- emsp430x315.o \
- emsp430x323.o \
+@@ -395,17 +402,20 @@
emsp430x325.o \
emsp430x336.o \
emsp430x337.o \
@@ -74,11 +72,7 @@
enews.o \
ens32knbsd.o \
eor32.o \
- eor32elf.o \
- epc532macha.o \
-@@ -1742,10 +1749,18 @@
- $(srcdir)/emultempl/elf32.em $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
- ${GENSCRIPTS} mn10300 "$(tdir_mn10300)"
+@@ -1744,6 +1754,14 @@
emn10200.c: $(srcdir)/emulparams/mn10200.sh \
$(srcdir)/emultempl/elf32.em $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
${GENSCRIPTS} mn10200 "$(tdir_mn10200)"
@@ -93,11 +87,7 @@
emsp430x1101.c: $(srcdir)/emulparams/msp430x1101.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
${GEN_DEPENDS}
- ${GENSCRIPTS} msp430x1101 "$(tdir_msp430x1101)"
- emsp430x1111.c: $(srcdir)/emulparams/msp430x1111.sh \
-@@ -1762,82 +1777,78 @@
- ${GENSCRIPTS} msp430x1122 "$(tdir_msp430x1122)"
- emsp430x1132.c: $(srcdir)/emulparams/msp430x1132.sh \
+@@ -1764,78 +1782,86 @@
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
${GEN_DEPENDS}
${GENSCRIPTS} msp430x1132 "$(tdir_msp430x1132)"
@@ -205,14 +195,22 @@
${GEN_DEPENDS}
- ${GENSCRIPTS} msp430x1232 "$(tdir_msp430x1232)"
+ ${GENSCRIPTS} msp430x169 "$(tdir_msp430x169)"
++emsp430x1610.c: $(srcdir)/emulparams/msp430x1610.sh \
++ $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
++ ${GEN_DEPENDS}
++ ${GENSCRIPTS} msp430x1610 "$(tdir_msp430x1610)"
++emsp430x1611.c: $(srcdir)/emulparams/msp430x1611.sh \
++ $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
++ ${GEN_DEPENDS}
++ ${GENSCRIPTS} msp430x1611 "$(tdir_msp430x1611)"
++emsp430x1612.c: $(srcdir)/emulparams/msp430x1612.sh \
++ $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430.sc \
++ ${GEN_DEPENDS}
++ ${GENSCRIPTS} msp430x1612 "$(tdir_msp430x1612)"
emsp430x311.c: $(srcdir)/emulparams/msp430x311.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430_3.sc \
${GEN_DEPENDS}
- ${GENSCRIPTS} msp430x311 "$(tdir_msp430x311)"
- emsp430x312.c: $(srcdir)/emulparams/msp430x312.sh \
-@@ -1870,46 +1881,66 @@
- ${GENSCRIPTS} msp430x336 "$(tdir_msp430x336)"
- emsp430x337.c: $(srcdir)/emulparams/msp430x337.sh \
+@@ -1872,42 +1898,62 @@
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/elf32msp430_3.sc \
${GEN_DEPENDS}
${GENSCRIPTS} msp430x337 "$(tdir_msp430x337)"
@@ -293,6 +291,3 @@
enews.c: $(srcdir)/emulparams/news.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/aout.sc ${GEN_DEPENDS}
${GENSCRIPTS} news "$(tdir_news)"
- ens32knbsd.c: $(srcdir)/emulparams/ns32knbsd.sh \
- $(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/aout.sc ${GEN_DEPENDS}
-
diff --git a/devel/msp430-binutils/files/patch-ld::configure.tgt b/devel/msp430-binutils/files/patch-ld::configure.tgt
index ba0804b7dc29..9269937229d3 100644
--- a/devel/msp430-binutils/files/patch-ld::configure.tgt
+++ b/devel/msp430-binutils/files/patch-ld::configure.tgt
@@ -1,23 +1,13 @@
---- ld/configure.tgt 2003-06-12 22:25:52.000000000 +0800
-+++ ld/configure.tgt 2003-08-06 01:53:13.000000000 +0800
-@@ -427,12 +427,12 @@
- mmix-*-*) targ_emul=mmo
- targ_extra_emuls=elf64mmix
+--- ld/configure.tgt.orig Thu Jun 12 18:25:52 2003
++++ ld/configure.tgt Tue Feb 24 16:10:38 2004
+@@ -429,8 +429,8 @@
;;
mn10200-*-*) targ_emul=mn10200 ;;
mn10300-*-*) targ_emul=mn10300 ;;
-msp430-*-*) targ_emul=msp430x149
- targ_extra_emuls="msp430x148 msp430x147 msp430x133 msp430x135 msp430x110 msp430x112 msp430x122 msp430x123 msp430x412 msp430x413 msp430x311 msp430x312 msp430x313 msp430x314 msp430x315 msp430x323 msp430x325 msp430x336 msp430x337 msp430x1101 msp430x1111 msp430x1121 msp430x1331 msp430x1351 msp430x435 msp430x436 msp430x437 msp430x447 msp430x448 msp430x449 msp430x1222 msp430x1232 msp430x169 msp430x168 msp430x167 msp430x155 msp430x156 msp430x157 msp430x1122 msp430x1132" ;;
+msp430-*-*) targ_emul=msp430x110
-+ targ_extra_emuls="msp430x112 msp430x1101 msp430x1111 msp430x1121 msp430x1122 msp430x1132 msp430x122 msp430x123 msp430x1222 msp430x1232 msp430x133 msp430x135 msp430x1331 msp430x1351 msp430x147 msp430x148 msp430x149 msp430x155 msp430x156 msp430x157 msp430x167 msp430x168 msp430x169 msp430x311 msp430x312 msp430x313 msp430x314 msp430x315 msp430x323 msp430x325 msp430x336 msp430x337 msp430x412 msp430x413 msp430xE423 msp430xE425 msp430xE427 msp430xW423 msp430xW425 msp430xW427 msp430x435 msp430x436 msp430x437 msp430x447 msp430x448 msp430x449" ;;
++ targ_extra_emuls="msp430x112 msp430x1101 msp430x1111 msp430x1121 msp430x1122 msp430x1132 msp430x122 msp430x123 msp430x1222 msp430x1232 msp430x133 msp430x135 msp430x1331 msp430x1351 msp430x147 msp430x148 msp430x149 msp430x155 msp430x156 msp430x157 msp430x167 msp430x168 msp430x169 msp430x1610 msp430x1611 msp430x1612 msp430x311 msp430x312 msp430x313 msp430x314 msp430x315 msp430x323 msp430x325 msp430x336 msp430x337 msp430x412 msp430x413 msp430xE423 msp430xE425 msp430xE427 msp430xW423 msp430xW425 msp430xW427 msp430x435 msp430x436 msp430x437 msp430x447 msp430x448 msp430x449" ;;
alpha*-*-freebsd*) targ_emul=elf64alpha_fbsd
targ_extra_emuls="elf64alpha alpha"
tdir_alpha=`echo ${targ_alias} | sed -e 's/freebsd/freebsdecoff/'`
- ;;
- alpha*-*-linuxecoff*) targ_emul=alpha targ_extra_emuls=elf64alpha
-Only in ld/emulparams: msp430xE423.sh
-Only in ld/emulparams: msp430xE425.sh
-Only in ld/emulparams: msp430xE427.sh
-Only in ld/emulparams: msp430xW423.sh
-Only in ld/emulparams: msp430xW425.sh
-Only in ld/emulparams: msp430xW427.sh
diff --git a/devel/msp430-binutils/files/patch-ld::emulparams::msp430x148.sh b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x148.sh
new file mode 100644
index 000000000000..33daf3380038
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x148.sh
@@ -0,0 +1,11 @@
+--- ld/emulparams/msp430x148.sh.orig Tue Feb 24 16:17:10 2004
++++ ld/emulparams/msp430x148.sh Tue Feb 24 16:17:22 2004
+@@ -7,7 +7,7 @@
+ TEMPLATE_NAME=generic
+
+ ROM_START=0x4000
+-ROM_SIZE=0xbef0
++ROM_SIZE=0xbfe0
+ RAM_START=0x0200
+ RAM_SIZE=0x07ff
+
diff --git a/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1610.sh b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1610.sh
new file mode 100644
index 000000000000..8667013511c7
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1610.sh
@@ -0,0 +1,18 @@
+--- ld/emulparams/msp430x1610.sh.orig Tue Feb 24 16:13:21 2004
++++ ld/emulparams/msp430x1610.sh Tue Feb 24 16:14:10 2004
+@@ -0,0 +1,15 @@
++ARCH=msp:16
++MACHINE=
++SCRIPT_NAME=elf32msp430
++OUTPUT_FORMAT="elf32-msp430"
++MAXPAGESIZE=1
++EMBEDDED=yes
++TEMPLATE_NAME=generic
++
++ROM_START=0x8000
++ROM_SIZE=0x7fe0
++RAM_START=0x1100
++RAM_SIZE=0x13ff
++
++STACK=0x1400
++
diff --git a/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1611.sh b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1611.sh
new file mode 100644
index 000000000000..0b9d34087d9a
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1611.sh
@@ -0,0 +1,18 @@
+--- ld/emulparams/msp430x1611.sh.orig Tue Feb 24 16:15:02 2004
++++ ld/emulparams/msp430x1611.sh Tue Feb 24 16:15:17 2004
+@@ -0,0 +1,15 @@
++ARCH=msp:16
++MACHINE=
++SCRIPT_NAME=elf32msp430
++OUTPUT_FORMAT="elf32-msp430"
++MAXPAGESIZE=1
++EMBEDDED=yes
++TEMPLATE_NAME=generic
++
++ROM_START=0x4000
++ROM_SIZE=0xbfe0
++RAM_START=0x1100
++RAM_SIZE=0x27ff
++
++STACK=0x2800
++
diff --git a/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1612.sh b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1612.sh
new file mode 100644
index 000000000000..107284d17a34
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x1612.sh
@@ -0,0 +1,18 @@
+--- ld/emulparams/msp430x1612.sh.orig Tue Feb 24 16:15:42 2004
++++ ld/emulparams/msp430x1612.sh Tue Feb 24 16:15:56 2004
+@@ -0,0 +1,15 @@
++ARCH=msp:16
++MACHINE=
++SCRIPT_NAME=elf32msp430
++OUTPUT_FORMAT="elf32-msp430"
++MAXPAGESIZE=1
++EMBEDDED=yes
++TEMPLATE_NAME=generic
++
++ROM_START=0x2800
++ROM_SIZE=0xd7e0
++RAM_START=0x1100
++RAM_SIZE=0x13ff
++
++STACK=0x1400
++
diff --git a/devel/msp430-binutils/files/patch-ld::emulparams::msp430x168.sh b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x168.sh
new file mode 100644
index 000000000000..6911931985f7
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x168.sh
@@ -0,0 +1,11 @@
+--- ld/emulparams/msp430x168.sh.orig Tue Feb 24 16:17:56 2004
++++ ld/emulparams/msp430x168.sh Tue Feb 24 16:18:04 2004
+@@ -7,7 +7,7 @@
+ TEMPLATE_NAME=generic
+
+ ROM_START=0x4000
+-ROM_SIZE=0xbef0
++ROM_SIZE=0xbfe0
+ RAM_START=0x0200
+ RAM_SIZE=0x07ff
+
diff --git a/devel/msp430-binutils/files/patch-ld::emulparams::msp430x448.sh b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x448.sh
new file mode 100644
index 000000000000..bbbc74f2995b
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-ld::emulparams::msp430x448.sh
@@ -0,0 +1,11 @@
+--- ld/emulparams/msp430x448.sh.orig Tue Feb 24 16:18:39 2004
++++ ld/emulparams/msp430x448.sh Tue Feb 24 16:18:46 2004
+@@ -7,7 +7,7 @@
+ TEMPLATE_NAME=generic
+
+ ROM_START=0x4000
+-ROM_SIZE=0xbef0
++ROM_SIZE=0xbfe0
+ RAM_START=0x0200
+ RAM_SIZE=0x07ff
+
diff --git a/devel/msp430-binutils/pkg-plist b/devel/msp430-binutils/pkg-plist
index f5959547b6c8..8aa138344309 100644
--- a/devel/msp430-binutils/pkg-plist
+++ b/devel/msp430-binutils/pkg-plist
@@ -1,4 +1,4 @@
-@comment $FreeBSD: /tmp/pcvs/ports/devel/msp430-binutils/pkg-plist,v 1.5 2003-10-15 13:18:19 lev Exp $
+@comment $FreeBSD: /tmp/pcvs/ports/devel/msp430-binutils/pkg-plist,v 1.6 2004-02-24 14:44:26 lev Exp $
%%BINUTILS_TARG%%/bin/addr2line
%%BINUTILS_TARG%%/bin/ar
%%BINUTILS_TARG%%/bin/as
@@ -132,6 +132,21 @@
%%BINUTILS_TARG%%/lib/ldscripts/msp430x169.xn
%%BINUTILS_TARG%%/lib/ldscripts/msp430x169.xr
%%BINUTILS_TARG%%/lib/ldscripts/msp430x169.xu
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1610.x
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1610.xbn
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1610.xn
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1610.xr
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1610.xu
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1611.x
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1611.xbn
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1611.xn
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1611.xr
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1611.xu
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1612.x
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1612.xbn
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1612.xn
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1612.xr
+%%BINUTILS_TARG%%/lib/ldscripts/msp430x1612.xu
%%BINUTILS_TARG%%/lib/ldscripts/msp430x311.x
%%BINUTILS_TARG%%/lib/ldscripts/msp430x311.xbn
%%BINUTILS_TARG%%/lib/ldscripts/msp430x311.xn