aboutsummaryrefslogtreecommitdiff
path: root/devel/naturaldocs
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-27 08:53:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-27 08:53:37 +0000
commit6345e1bb029f183415e66d495023573abfab18d1 (patch)
tree13c310e105ba741f8c5d0f9a5f204ae2d718d41c /devel/naturaldocs
parentd5ad5ae32b1aefb703fa408611d05e832a07018d (diff)
downloadports-6345e1bb029f183415e66d495023573abfab18d1.tar.gz
ports-6345e1bb029f183415e66d495023573abfab18d1.zip
add NaturalDocs 1.21
An extensible, multi-language source code documentation generator
Notes
Notes: svn path=/head/; revision=102273
Diffstat (limited to 'devel/naturaldocs')
-rw-r--r--devel/naturaldocs/Makefile48
-rw-r--r--devel/naturaldocs/distinfo2
-rw-r--r--devel/naturaldocs/pkg-descr6
3 files changed, 56 insertions, 0 deletions
diff --git a/devel/naturaldocs/Makefile b/devel/naturaldocs/Makefile
new file mode 100644
index 000000000000..46e534948dd5
--- /dev/null
+++ b/devel/naturaldocs/Makefile
@@ -0,0 +1,48 @@
+# ex:ts=8
+# Ports collection makefile for: NaturalDocs
+# Date created: Feb 27, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= naturaldocs
+PORTVERSION= 1.21
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= NaturalDocs-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An extensible, multi-language source code documentation generator
+
+USE_ZIP= yes
+USE_PERL5_RUN= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+DOCSDIR= ${PREFIX}/share/doc/NaturalDocs
+PLIST_FILES= bin/NaturalDocs
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/NaturalDocs ${PREFIX}/bin
+ @${MKDIR} ${SITE_PERL}/NaturalDocs
+ @cd ${WRKSRC}/Modules/NaturalDocs && \
+ ${FIND} * -type d -exec ${MKDIR} ${SITE_PERL}/NaturalDocs/{} \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} ${SITE_PERL}/NaturalDocs/{} \;
+ @${FIND} ${SITE_PERL}/NaturalDocs -type f | \
+ ${SED} -e "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/NaturalDocs -type d | ${SORT} -r | \
+ ${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/Help && \
+ ${FIND} * -type d -exec ${MKDIR} ${DOCSDIR}/{} \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${FIND} ${DOCSDIR} -type f | \
+ ${SED} -e "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type d | ${SORT} -r | \
+ ${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/naturaldocs/distinfo b/devel/naturaldocs/distinfo
new file mode 100644
index 000000000000..26285ff1e9d4
--- /dev/null
+++ b/devel/naturaldocs/distinfo
@@ -0,0 +1,2 @@
+MD5 (NaturalDocs-1.21.zip) = c471f1a3d22b25b5bedd7abc0e670cfe
+SIZE (NaturalDocs-1.21.zip) = 246144
diff --git a/devel/naturaldocs/pkg-descr b/devel/naturaldocs/pkg-descr
new file mode 100644
index 000000000000..60191eab5aeb
--- /dev/null
+++ b/devel/naturaldocs/pkg-descr
@@ -0,0 +1,6 @@
+Natural Docs is an extensible, multi-language source code documentation
+generator. The syntax is transparent so that the comments in the source
+code read just as easily as the generated documentation. Also focuses
+on automation and high-quality output.
+
+WWW: http://www.naturaldocs.org/