aboutsummaryrefslogtreecommitdiff
path: root/devel/newt
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-03 15:33:06 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-03 15:33:06 +0000
commitce800d8632419b939b49cc4d032e53dd8ea99757 (patch)
tree5ca256330d45d966b0438fbfd09d5ba6c72e2861 /devel/newt
parentbb7792598c94e181e84e764bdd5c4751c4a17541 (diff)
downloadports-ce800d8632419b939b49cc4d032e53dd8ea99757.tar.gz
ports-ce800d8632419b939b49cc4d032e53dd8ea99757.zip
Unbreak after r1.651 of bsd.port.mk.
The port Makefile uses multiple .c files in the ${CPP} line, which cpp can't cope with. Modify the port Makefile so that it uses CPP=${CC} -E again, like before r1.651. Submitted by: pointyhat
Notes
Notes: svn path=/head/; revision=263978
Diffstat (limited to 'devel/newt')
-rw-r--r--devel/newt/files/patch-ab27
1 files changed, 21 insertions, 6 deletions
diff --git a/devel/newt/files/patch-ab b/devel/newt/files/patch-ab
index 8cec608542d4..d73d4a146e1d 100644
--- a/devel/newt/files/patch-ab
+++ b/devel/newt/files/patch-ab
@@ -1,13 +1,25 @@
---- Makefile.in 2009-09-24 11:03:09.000000000 -0400
-+++ Makefile.in 2010-01-06 01:33:55.000000000 -0500
-@@ -51,5 +51,5 @@
+--- Makefile.in.orig 2009-09-24 17:03:09.000000000 +0200
++++ Makefile.in 2010-11-03 15:56:33.000000000 +0100
+@@ -2,7 +2,7 @@ LIBS = -lslang
+ LIBTCL = -ltcl8.4
+
+ CC = @CC@
+-CPP = @CPP@
++CPP = $(CC) -E
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@
+
+@@ -50,7 +50,7 @@ else
+ TARGET=depend $(PROGS)
endif
-all: $(TARGET) _snackmodule.so
+all: $(TARGET)
test: test.o $(LIBNEWT)
-@@ -68,11 +68,11 @@
+ $(CC) -g -o test test.o $(LIBNEWT) $(LIBS)
+@@ -67,19 +67,19 @@ showchars: showchars.o $(LIBNEWT)
+ showkey: showkey.o $(LIBNEWT)
$(CC) -g -o showkey showkey.o $(LIBNEWT) $(LIBS)
+ifdef PYTHONVERS
@@ -25,14 +37,16 @@
+endif
whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
-@@ -80,5 +80,5 @@
+ $(CC) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
- $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lpopt
+ $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) $(LIBS) -lpopt
$(LIBNEWT): $(LIBOBJS)
-@@ -119,18 +119,18 @@
+ ar rv $@ $^
+@@ -118,20 +118,20 @@ install: $(LIBNEWT) install-sh whiptail
+ install -m 644 $(LIBNEWT) $(instroot)/$(libdir)
install -m 755 whiptail $(instroot)/$(bindir)
install -m 644 whiptail.1 $(instroot)/$(man1dir)
- make -C po datadir=$(instroot)/$(datadir) install
@@ -60,3 +74,4 @@
+endif
Makefile: newt.spec
+ echo "You need to rerun ./configure before continuing"