aboutsummaryrefslogtreecommitdiff
path: root/devel/oaf
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /devel/oaf
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Notes
Notes: svn path=/head/; revision=62821
Diffstat (limited to 'devel/oaf')
-rw-r--r--devel/oaf/Makefile13
-rw-r--r--devel/oaf/files/patch-aa17
2 files changed, 13 insertions, 17 deletions
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 3905b08914b8..7f6472c36f6b 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -19,23 +19,20 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gtk12 orbit libxml
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-USE_GNOMELIBS= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
- --disable-more-warnings --disable-gtk-doc
+ --disable-more-warnings
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= oafd.1
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/oaf/files/patch-aa b/devel/oaf/files/patch-aa
index 1d0c2fab43c1..e0caa8a8ec2c 100644
--- a/devel/oaf/files/patch-aa
+++ b/devel/oaf/files/patch-aa
@@ -1,15 +1,14 @@
---- Makefile.in.orig Wed May 10 02:42:25 2000
-+++ Makefile.in Thu Jun 1 14:21:12 2000
-@@ -95,10 +95,10 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Fri Jul 5 11:27:26 2002
++++ Makefile.in Fri Jul 5 11:28:17 2002
+@@ -145,7 +145,7 @@
+ oafconfig_DATA = oaf-config.xml oaf-config.xml.sample $(NULL)
- EXTRA_DIST = oaf-config.in oaf.m4 oafConf.sh.in oafConf.sh
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = oafConf.sh
--m4datadir = $(datadir)/aclocal
-+m4datadir = $(prefix)/share/aclocal
- m4data_DATA = oaf.m4
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ m4datadir = $(prefix)/share/aclocal