aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-lacaml
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
commit42542fb07642b8336e808272918f3ae46aa67e0b (patch)
tree98ff235c33c6493aa26457284f122652c38935f7 /devel/ocaml-lacaml
parent4c9cd257fd4e6eca46807a43e128d298429ee3cd (diff)
downloadports-42542fb07642b8336e808272918f3ae46aa67e0b.tar.gz
ports-42542fb07642b8336e808272918f3ae46aa67e0b.zip
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=197075
Diffstat (limited to 'devel/ocaml-lacaml')
-rw-r--r--devel/ocaml-lacaml/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index 00e6b754d018..95ddb92c5497 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -30,8 +30,8 @@ CFLAGS+= -fPIC
MAKE_ENV+= OCAMLMKLIB_FLAGS="-L${LOCALBASE}/lib"
DOCS= README TODO
-DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
@@ -53,20 +53,20 @@ post-extract:
post-install:
@${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
@${FIND} ${EXAMPLESDIR}/ ! -type d | \
- ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${FIND} ${DOCSDIR}/ ! -type d | \
- ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
# XXX: temporary workaround for non-standard PREFIX
@${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
>> ${TMPPLIST}