aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-lwt/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-01-13 16:54:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-01-13 16:54:55 +0000
commit9468432a48314313f7585654ac6db575a0b6648a (patch)
tree545ac8faaf58a17f5075028cc7de936c43e387a2 /devel/ocaml-lwt/Makefile
parent7dab44519c236716f2931f748b67aa53dbd55ed4 (diff)
downloadports-9468432a48314313f7585654ac6db575a0b6648a.tar.gz
ports-9468432a48314313f7585654ac6db575a0b6648a.zip
Fix ports using PREFIX in their depends instead of LOCALBASE.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=431402
Diffstat (limited to 'devel/ocaml-lwt/Makefile')
-rw-r--r--devel/ocaml-lwt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/ocaml-lwt/Makefile b/devel/ocaml-lwt/Makefile
index 838ef48d476d..4e10ef16d410 100644
--- a/devel/ocaml-lwt/Makefile
+++ b/devel/ocaml-lwt/Makefile
@@ -38,7 +38,7 @@ CONFIGURE_ARGS= --destdir "${STAGEDIR}" \
--disable-glib
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
OPTIONS_DEFINE= DOCS
@@ -61,7 +61,7 @@ do-build:
cd ${WRKSRC}; ocaml setup.ml -build
do-install:
- ${MKDIR} ${STAGEDIR}${SA_DIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}
cd ${WRKSRC}; ocaml setup.ml -install
.include <bsd.port.mk>