aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-pcre
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 01:47:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 01:47:26 +0000
commiteec877278cc0215ac0f3685b53fa3b59d6c09eec (patch)
tree87e6597d0b069b48d04022f1ae2bc5be6f6c8446 /devel/ocaml-pcre
parentc3e7756474be76ea14e09542c217671ab2c300c4 (diff)
downloadports-eec877278cc0215ac0f3685b53fa3b59d6c09eec.tar.gz
ports-eec877278cc0215ac0f3685b53fa3b59d6c09eec.zip
fix package
Notes
Notes: svn path=/head/; revision=104562
Diffstat (limited to 'devel/ocaml-pcre')
-rw-r--r--devel/ocaml-pcre/Makefile5
-rw-r--r--devel/ocaml-pcre/pkg-install9
2 files changed, 14 insertions, 0 deletions
diff --git a/devel/ocaml-pcre/Makefile b/devel/ocaml-pcre/Makefile
index dcc6bc1181ae..846591be95a3 100644
--- a/devel/ocaml-pcre/Makefile
+++ b/devel/ocaml-pcre/Makefile
@@ -37,7 +37,12 @@ DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.endif
+PKGDEINSTALL= ${PKGINSTALL}
+
post-install:
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/pcre -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/pcre" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ocamlfind remove pcre 2>/dev/null || true" >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/devel/ocaml-pcre/pkg-install b/devel/ocaml-pcre/pkg-install
new file mode 100644
index 000000000000..0e6794709dfd
--- /dev/null
+++ b/devel/ocaml-pcre/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" ]; then
+ echo "${PKG_PREFIX}/lib/ocaml/site-lib/pcre" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
+elif [ "$2" = "DEINSTALL" ]; then
+ mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
+ grep -v pcre ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
+ rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
+fi