aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-sdl
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:50:30 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:50:30 +0000
commita6e8291c822ab175f67257ca928010d66270b53e (patch)
tree91c68f26ec100e24adb9c1cbdffef4bfd9ffac66 /devel/ocaml-sdl
parentabbcaea61d2e945789c0be0e2ed9b4c3c6302d65 (diff)
downloadports-a6e8291c822ab175f67257ca928010d66270b53e.tar.gz
ports-a6e8291c822ab175f67257ca928010d66270b53e.zip
- Update to 0.9.1.
- Add LICENSE. - Add MAKE_JOBS_SAFE. - Trim header. PR: ports/172233 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=309293
Diffstat (limited to 'devel/ocaml-sdl')
-rw-r--r--devel/ocaml-sdl/Makefile76
-rw-r--r--devel/ocaml-sdl/distinfo4
-rw-r--r--devel/ocaml-sdl/pkg-plist61
3 files changed, 55 insertions, 86 deletions
diff --git a/devel/ocaml-sdl/Makefile b/devel/ocaml-sdl/Makefile
index 784f6731471c..d8749c9858c1 100644
--- a/devel/ocaml-sdl/Makefile
+++ b/devel/ocaml-sdl/Makefile
@@ -1,14 +1,8 @@
-# ex:ts=8
-# Ports collection makefile for: ocaml-sdl
-# Date created: Jun 1, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= sdl
-PORTVERSION= 0.7.2
-PORTREVISION= 11
+PORTVERSION= 0.9.1
CATEGORIES= devel
MASTER_SITES= SF/ocaml${PORTNAME}/OCamlSDL/ocaml${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ocaml-
@@ -17,34 +11,70 @@ DISTNAME= ocamlsdl-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An OCaml interface to the SDL
-BUILD_DEPENDS= lablgl:${PORTSDIR}/graphics/ocaml-lablgl
+LICENSE= LGPL21
+
+BUILD_DEPENDS= ocaml-lablgl>0:${PORTSDIR}/graphics/ocaml-lablgl
+
+OPTIONS_DEFINE= SDL_GFX SDL_IMAGE SDL_MIXER SDL_TTF DOCS
+OPTIONS_DEFAULT=SDL_GFX SDL_IMAGE SDL_MIXER SDL_TTF
+SDL_GFX_DESC= Enable SDL_gfx support
+SDL_IMAGE_DESC= Enable SDL_image support
+SDL_MIXER_DESC= Enable SDL_mixer support
+SDL_TTF_DESC= Enable SDL_ttf support
-USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
+USE_OCAMLFIND_PLIST=yes
USE_OCAML_LDCONFIG=yes
-USE_SDL= sdl ttf image mixer
+
+USE_SDL= sdl
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS= --with-findlib
+CONFIGURE_ARGS= --with-lablgldir=${LOCALBASE} \
+ --with-sdl-prefix=${LOCALBASE} \
+ --with-installdir=${PREFIX}
+MAKE_JOBS_SAFE= yes
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/{PORTNAME}
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+INFO= ocamlsdl
PORTDOCS= *
-.if !defined(NOPORTDOCS)
-INFO= ocamlsdl
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSDL_GFX}
+USE_SDL+= gfx
+.else
+CONFIGURE_ARGS+=--disable-sdl-gfx
.endif
-.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MSDL_IMAGE}
+USE_SDL+= image
+.else
+CONFIGURE_ARGS+=--disable-sdl-image
+.endif
+
+.if ${PORT_OPTIONS:MSDL_MIXER}
+USE_SDL+= mixer
+.else
+CONFIGURE_ARGS+=--disable-sdl-mixer
+.endif
+
+.if ${PORT_OPTIONS:MSDL_TTF}
+USE_SDL+= ttf
+.else
+CONFIGURE_ARGS+=--disable-sdl-ttf
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_DIRSTRY+= ${OCAML_DOCSDIR:S,^${PREFIX}/,,}
+.endif
post-install:
-.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/doc/ocamlsdl.info ${PREFIX}/${INFO_PATH}
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/ocamlsdl.info ${PREFIX}/${INFO_PATH}
+ (cd ${WRKSRC}/doc/html && ${INSTALL_DATA} * ${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ocaml-sdl/distinfo b/devel/ocaml-sdl/distinfo
index 7880f3a36d7a..f82c3fe047a3 100644
--- a/devel/ocaml-sdl/distinfo
+++ b/devel/ocaml-sdl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocamlsdl-0.7.2.tar.gz) = e7eec23b7c7b873bdc7fe9b618808bbebf50949f4c19d5df0a16979b2582643d
-SIZE (ocamlsdl-0.7.2.tar.gz) = 215193
+SHA256 (ocamlsdl-0.9.1.tar.gz) = abfb295b263dc11e97fffdd88ea1a28b46df8cc2b196777093e4fe7f509e4f8f
+SIZE (ocamlsdl-0.9.1.tar.gz) = 226085
diff --git a/devel/ocaml-sdl/pkg-plist b/devel/ocaml-sdl/pkg-plist
deleted file mode 100644
index 52fb98a912a3..000000000000
--- a/devel/ocaml-sdl/pkg-plist
+++ /dev/null
@@ -1,61 +0,0 @@
-lib/ocaml/site-lib/sdl/META
-lib/ocaml/site-lib/sdl/dllsdlloaderstub.so
-lib/ocaml/site-lib/sdl/dllsdlmixerstub.so
-lib/ocaml/site-lib/sdl/dllsdlstub.so
-lib/ocaml/site-lib/sdl/dllsdlttfstub.so
-lib/ocaml/site-lib/sdl/libsdlloaderstub.a
-lib/ocaml/site-lib/sdl/libsdlmixerstub.a
-lib/ocaml/site-lib/sdl/libsdlstub.a
-lib/ocaml/site-lib/sdl/libsdlttfstub.a
-lib/ocaml/site-lib/sdl/sdl.a
-lib/ocaml/site-lib/sdl/sdl.cma
-lib/ocaml/site-lib/sdl/sdl.cmi
-lib/ocaml/site-lib/sdl/sdl.cmx
-lib/ocaml/site-lib/sdl/sdl.cmxa
-lib/ocaml/site-lib/sdl/sdl.mli
-lib/ocaml/site-lib/sdl/sdlcdrom.cmi
-lib/ocaml/site-lib/sdl/sdlcdrom.cmx
-lib/ocaml/site-lib/sdl/sdlcdrom.mli
-lib/ocaml/site-lib/sdl/sdlevent.cmi
-lib/ocaml/site-lib/sdl/sdlevent.cmx
-lib/ocaml/site-lib/sdl/sdlevent.mli
-lib/ocaml/site-lib/sdl/sdlgl.cmi
-lib/ocaml/site-lib/sdl/sdlgl.cmx
-lib/ocaml/site-lib/sdl/sdlgl.mli
-lib/ocaml/site-lib/sdl/sdljoystick.cmi
-lib/ocaml/site-lib/sdl/sdljoystick.cmx
-lib/ocaml/site-lib/sdl/sdljoystick.mli
-lib/ocaml/site-lib/sdl/sdlkey.cmi
-lib/ocaml/site-lib/sdl/sdlkey.cmx
-lib/ocaml/site-lib/sdl/sdlkey.mli
-lib/ocaml/site-lib/sdl/sdlloader.a
-lib/ocaml/site-lib/sdl/sdlloader.cma
-lib/ocaml/site-lib/sdl/sdlloader.cmi
-lib/ocaml/site-lib/sdl/sdlloader.cmx
-lib/ocaml/site-lib/sdl/sdlloader.cmxa
-lib/ocaml/site-lib/sdl/sdlloader.mli
-lib/ocaml/site-lib/sdl/sdlmixer.a
-lib/ocaml/site-lib/sdl/sdlmixer.cma
-lib/ocaml/site-lib/sdl/sdlmixer.cmi
-lib/ocaml/site-lib/sdl/sdlmixer.cmx
-lib/ocaml/site-lib/sdl/sdlmixer.cmxa
-lib/ocaml/site-lib/sdl/sdlmixer.mli
-lib/ocaml/site-lib/sdl/sdlmouse.cmi
-lib/ocaml/site-lib/sdl/sdlmouse.cmx
-lib/ocaml/site-lib/sdl/sdlmouse.mli
-lib/ocaml/site-lib/sdl/sdltimer.cmi
-lib/ocaml/site-lib/sdl/sdltimer.cmx
-lib/ocaml/site-lib/sdl/sdltimer.mli
-lib/ocaml/site-lib/sdl/sdlttf.a
-lib/ocaml/site-lib/sdl/sdlttf.cma
-lib/ocaml/site-lib/sdl/sdlttf.cmi
-lib/ocaml/site-lib/sdl/sdlttf.cmx
-lib/ocaml/site-lib/sdl/sdlttf.cmxa
-lib/ocaml/site-lib/sdl/sdlttf.mli
-lib/ocaml/site-lib/sdl/sdlvideo.cmi
-lib/ocaml/site-lib/sdl/sdlvideo.cmx
-lib/ocaml/site-lib/sdl/sdlvideo.mli
-lib/ocaml/site-lib/sdl/sdlwm.cmi
-lib/ocaml/site-lib/sdl/sdlwm.cmx
-lib/ocaml/site-lib/sdl/sdlwm.mli
-%%PORTDOCS%%@dirrmtry share/doc/ocaml