aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-typeconv
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-08 12:15:02 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-08 12:15:02 +0000
commitf18b24f425b124dfc88d9efc4be9ffbc2cd9fd35 (patch)
treefbb4183fd8c174721c56bcacbfe7ebac7761ef68 /devel/ocaml-typeconv
parent9182e7cc90cdfc17514f25b6c8989bba70ef75a5 (diff)
downloadports-f18b24f425b124dfc88d9efc4be9ffbc2cd9fd35.tar.gz
ports-f18b24f425b124dfc88d9efc4be9ffbc2cd9fd35.zip
- Add ocaml-typeconv, a mini library required for some
other preprocessing libraries. WWW: http://www.janestcapital.com/ocaml/index.html
Notes
Notes: svn path=/head/; revision=210844
Diffstat (limited to 'devel/ocaml-typeconv')
-rw-r--r--devel/ocaml-typeconv/Makefile35
-rw-r--r--devel/ocaml-typeconv/distinfo3
-rw-r--r--devel/ocaml-typeconv/pkg-descr7
3 files changed, 45 insertions, 0 deletions
diff --git a/devel/ocaml-typeconv/Makefile b/devel/ocaml-typeconv/Makefile
new file mode 100644
index 000000000000..456233276ed5
--- /dev/null
+++ b/devel/ocaml-typeconv/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ocaml-type-conv
+# Date created: 2008-04-08
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= type-conv
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://janestcapital.com/ocaml/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Type conversion routines for OCaml
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-typeconv/distinfo b/devel/ocaml-typeconv/distinfo
new file mode 100644
index 000000000000..fb4136dcaac0
--- /dev/null
+++ b/devel/ocaml-typeconv/distinfo
@@ -0,0 +1,3 @@
+MD5 (type-conv-1.0.0.tar.gz) = 703e7f74d9c01d5e49274011e846bba8
+SHA256 (type-conv-1.0.0.tar.gz) = 3435f00c1c56c9a4ba7a4281fd9f7eec5ee2cda75806498a11974a379e3f1870
+SIZE (type-conv-1.0.0.tar.gz) = 22456
diff --git a/devel/ocaml-typeconv/pkg-descr b/devel/ocaml-typeconv/pkg-descr
new file mode 100644
index 000000000000..59288aa141be
--- /dev/null
+++ b/devel/ocaml-typeconv/pkg-descr
@@ -0,0 +1,7 @@
+The type-conv mini library factors out functionality needed by different
+preprocessors that generate code from type specifications, because this
+functionality cannot be duplicated without losing the ability to use
+these preprocessors simultaneously.
+
+Author: Markus Mottl <markus.mottl@gmail.com>
+WWW: http://www.janestcapital.com/ocaml/index.html