aboutsummaryrefslogtreecommitdiff
path: root/devel/ocamlweb
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2008-07-17 21:46:48 +0000
committerHiroki Sato <hrs@FreeBSD.org>2008-07-17 21:46:48 +0000
commit3a244aa8ea9f9e8f76e2552be539750aab040c7f (patch)
treef78ef00fc207c100c0a245a37e5bf8f2be048a0a /devel/ocamlweb
parentdfa789c5dcc498a0b33c7fbc5d9821f72f28820f (diff)
downloadports-3a244aa8ea9f9e8f76e2552be539750aab040c7f.tar.gz
ports-3a244aa8ea9f9e8f76e2552be539750aab040c7f.zip
Style clean-ups including:
- Remove unnecessary mktexlsr calling. - Use PORTDOCS for additional docs. - Use TEXMFDIR for share/texmf. - Fix a typo in .if line.
Notes
Notes: svn path=/head/; revision=216982
Diffstat (limited to 'devel/ocamlweb')
-rw-r--r--devel/ocamlweb/Makefile15
-rw-r--r--devel/ocamlweb/files/patch-Makefile.in12
-rw-r--r--devel/ocamlweb/pkg-plist11
3 files changed, 25 insertions, 13 deletions
diff --git a/devel/ocamlweb/Makefile b/devel/ocamlweb/Makefile
index d31dbebd719d..d04d844d0b24 100644
--- a/devel/ocamlweb/Makefile
+++ b/devel/ocamlweb/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.34
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.lri.fr/~filliatr/ftp/ocamlweb/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DOCFILES}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTDOCS}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= hrs@FreeBSD.ORG
@@ -20,18 +20,23 @@ BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
GNU_CONFIGURE= yes
+PLIST_SUB+= TEXMFDIR=${TEXMFDIR} \
+ MKTEXLSR=${MKTEXLSR}
+
+TEXMFDIR?= share/texmf
+MKTEXLSR?= ${LOCALBASE}/bin/mktexlsr
.if !defined(NOPORTDOCS)
-DOCFILES= ${PORTNAME}-${PORTVERSION}-man.ps.gz
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+PORTDOCS= ${PORTNAME}-${PORTVERSION}-man.ps.gz
.endif
MAN1= ocamlweb.1
post-install:
-.if !defined{NOPORTDOCS}
+ ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/${DOCFILES} ${DOCSDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/ocamlweb/files/patch-Makefile.in b/devel/ocamlweb/files/patch-Makefile.in
index b7159e5c0bcf..e49ca6a3a855 100644
--- a/devel/ocamlweb/files/patch-Makefile.in
+++ b/devel/ocamlweb/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Mon Jul 7 17:23:47 2003
-+++ Makefile.in Fri Feb 11 03:23:16 2005
+--- Makefile.in.orig 2003-07-07 17:23:47.000000000 +0900
++++ Makefile.in 2008-07-18 06:33:04.000000000 +0900
@@ -9,11 +9,11 @@
# where to install the style file
@@ -14,3 +14,11 @@
# Version
MAJORVN=1
+@@ -80,7 +80,6 @@
+ cp doc/ocamlweb.1 $(MANDIR)/man1
+ mkdir -p $(TEXDIR)
+ cp ocamlweb.sty $(TEXDIR)
+- $(UPDATETEX)
+
+ install: install-indep
+ if test @OCAMLBEST@ = opt ; then \
diff --git a/devel/ocamlweb/pkg-plist b/devel/ocamlweb/pkg-plist
index dede68354caa..2faf1c61f28b 100644
--- a/devel/ocamlweb/pkg-plist
+++ b/devel/ocamlweb/pkg-plist
@@ -1,7 +1,6 @@
+@comment $FreeBSD$
bin/ocamlweb
-share/texmf/tex/latex/ocamlweb/ocamlweb.sty
-@dirrm share/texmf/tex/latex/ocamlweb
-%%PORTDOCS%%%%DOCSDIR%%/ocamlweb-%%PORTVERSION%%-man.ps.gz
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@exec %D/bin/mktexlsr
-@unexec %D/bin/mktexlsr
+%%TEXMFDIR%%/tex/latex/ocamlweb/ocamlweb.sty
+@dirrm %%TEXMFDIR%%/tex/latex/ocamlweb
+@exec %%MKTEXLSR%% %D/%%TEXMFDIR%%
+@unexec %%MKTEXLSR%% %D/%%TEXMFDIR%%