aboutsummaryrefslogtreecommitdiff
path: root/devel/ode
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-15 09:57:40 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-15 09:57:40 +0000
commit64f27831d3b2c6bb60adb149a84a641f4234171c (patch)
tree9710d83d06a29a1d4048802ec27fb1447d442e21 /devel/ode
parentb9c2737da77cc503d91bd70425c0009dbd6d18ae (diff)
downloadports-64f27831d3b2c6bb60adb149a84a641f4234171c.tar.gz
ports-64f27831d3b2c6bb60adb149a84a641f4234171c.zip
Add ode 0.039,
ODE is a free, industrial quality library for simulating articulated rigid body dynamics - for example ground vehicles, legged creatures, and moving objects in VR environments. It is fast, flexible, robust and platform independent, with advanced joints, contact with friction, and built-in collision detection. PR: ports/64288 Submitted by: David Yeske <dyeske@yahoo.com>
Notes
Notes: svn path=/head/; revision=104064
Diffstat (limited to 'devel/ode')
-rw-r--r--devel/ode/Makefile50
-rw-r--r--devel/ode/distinfo1
-rw-r--r--devel/ode/files/patch-Makefile28
-rw-r--r--devel/ode/pkg-descr10
-rw-r--r--devel/ode/pkg-plist25
5 files changed, 114 insertions, 0 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
new file mode 100644
index 000000000000..fea4c845bb87
--- /dev/null
+++ b/devel/ode/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ode
+# Date created: 11 Oct 2003
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ode
+PORTVERSION= 0.039
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= opende
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= Articulated rigid body dynamics library
+
+USE_X_PREFIX= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|malloc.h|stdlib.h|g' \
+ ${WRKSRC}/configurator.c
+
+ @${REINPLACE_CMD} -e \
+ 's|gcc|${CC}|; \
+ s|-fno-rtti||' \
+ ${WRKSRC}/OPCODE/Makefile
+
+ @${REINPLACE_CMD} -E -e \
+ 's|^CC.+$$|CC=${CC}|; \
+ s|-Wall||g; \
+ s|-L/usr/X11/lib|-lXext|; \
+ s|-L/usr/lib/X11R6||; \
+ s|-L/usr/lib/X11||; \
+ s|-L/usr/X11R6/lib|-L${X11BASE}/lib|; \
+ s|-fno-rtti||; \
+ s|-ffast-math|${CFLAGS} -I${X11BASE}/include|' \
+ ${WRKSRC}/config/makefile.unix-gcc
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/libode.a ${PREFIX}/lib
+ @${INSTALL_DATA} ${WRKSRC}/lib/libdrawstuff.a ${PREFIX}/lib
+ @${MKDIR} ${PREFIX}/include/ode
+ @${INSTALL_DATA} ${WRKSRC}/include/ode/*.h ${PREFIX}/include/ode
+
+.include <bsd.port.mk>
diff --git a/devel/ode/distinfo b/devel/ode/distinfo
new file mode 100644
index 000000000000..42e90aa9079d
--- /dev/null
+++ b/devel/ode/distinfo
@@ -0,0 +1 @@
+MD5 (ode-0.039.tgz) = 5a6675043791dc432eb56c58d87f6180
diff --git a/devel/ode/files/patch-Makefile b/devel/ode/files/patch-Makefile
new file mode 100644
index 000000000000..c20ead90b1c8
--- /dev/null
+++ b/devel/ode/files/patch-Makefile
@@ -0,0 +1,28 @@
+--- Makefile.orig Fri Jul 11 02:37:58 2003
++++ Makefile Thu Oct 16 21:14:17 2003
+@@ -280,13 +280,13 @@
+ -$(DEL_CMD) $(ODE_OBJECTS) $(ODE_TEST_EXE) $(ODE_LIB) $(DRAWSTUFF_OBJECTS) $(DRAWSTUFF_TEST_EXE) $(DRAWSTUFF_LIB) ode/test/*$(OBJ) drawstuff/dstest/*$(OBJ) $(CONFIGURATOR_EXE) $(CONFIG_H)
+
+ %$(OBJ): %.c
+- $(CC) $(C_FLAGS) $(C_INC)$(INCPATH) $(DEFINES) $(C_OPT)1 $(C_OUT)$@ $<
++ $(CC) $(C_FLAGS) $(C_INC)$(INCPATH) $(DEFINES) $(C_OUT)$@ $<
+
+ %$(OBJ): %.cpp
+- $(CC) $(C_FLAGS) $(C_INC)$(INCPATH) $(INC_OPCODE) $(DEFINES) $(C_OPT)$(OPT) $(C_OUT)$@ $<
++ $(CC) $(C_FLAGS) $(C_INC)$(INCPATH) $(INC_OPCODE) $(DEFINES) $(C_OUT)$@ $<
+
+ %.exe: %$(OBJ)
+- $(CC) $(C_EXEOUT)$@ $< $(ODE_LIB) $(OPCODE_LIB) $(DRAWSTUFF_LIB) $(RESOURCE_FILE) $(LINK_OPENGL) $(LINK_MATH)
++ $(CC) $(C_EXEOUT)$@ $< $(ODE_LIB) $(OPCODE_LIB) $(DRAWSTUFF_LIB) $(RESOURCE_FILE) $(LINK_OPENGL) $(LINK_MATH) ${LDFLAGS}
+
+
+ # windows specific rules
+@@ -308,7 +308,7 @@
+
+ # unix-gcc specific dependency making
+
+-DEP_RULE=gcc -M $(C_INC)$(INCPATH) $(DEFINES)
++DEP_RULE=${CC} -M $(C_INC)$(INCPATH) $(DEFINES)
+ depend:
+ $(DEP_RULE) $(ODE_SRC) $(ODE_PREGEN_SRC) $(ODE_OLD_COLLISION_SRC) $(ODE_NEW_COLLISION_SRC) | tools/process_deps ode/src/ > Makefile.deps
+ $(DEP_RULE) $(DRAWSTUFF_SRC) | tools/process_deps drawstuff/src/ >> Makefile.deps
diff --git a/devel/ode/pkg-descr b/devel/ode/pkg-descr
new file mode 100644
index 000000000000..d6985ee7a0c2
--- /dev/null
+++ b/devel/ode/pkg-descr
@@ -0,0 +1,10 @@
+ODE is a free, industrial quality library for simulating articulated
+rigid body dynamics - for example ground vehicles, legged creatures,
+and moving objects in VR environments. It is fast, flexible, robust
+and platform independent, with advanced joints, contact with friction,
+and built-in collision detection.
+
+WWW: http://opende.sourceforge.net/
+
+- David
+dyeske@yahoo.com
diff --git a/devel/ode/pkg-plist b/devel/ode/pkg-plist
new file mode 100644
index 000000000000..fc8ccd1a25d2
--- /dev/null
+++ b/devel/ode/pkg-plist
@@ -0,0 +1,25 @@
+lib/libdrawstuff.a
+lib/libode.a
+include/ode/collision.h
+include/ode/collision_space.h
+include/ode/collision_trimesh.h
+include/ode/common.h
+include/ode/config.h
+include/ode/contact.h
+include/ode/error.h
+include/ode/geom.h
+include/ode/mass.h
+include/ode/matrix.h
+include/ode/memory.h
+include/ode/misc.h
+include/ode/objects.h
+include/ode/ode.h
+include/ode/odecpp.h
+include/ode/odecpp_collision.h
+include/ode/odecpp_old.h
+include/ode/odecpp_old_collision.h
+include/ode/odemath.h
+include/ode/rotation.h
+include/ode/space.h
+include/ode/timer.h
+@dirrm include/ode