aboutsummaryrefslogtreecommitdiff
path: root/devel/openzz
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-13 19:06:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-13 19:06:04 +0000
commit26e9d9b4e85973ba05b42572f4a5345a554dd6d4 (patch)
treeb6690097f3cbf58139301e5ffcdaadca5d2e0800 /devel/openzz
parent227e98a41314356b5a5b746b0e90287ba695222e (diff)
downloadports-26e9d9b4e85973ba05b42572f4a5345a554dd6d4.tar.gz
ports-26e9d9b4e85973ba05b42572f4a5345a554dd6d4.zip
add openzz 1.0.2
An interpreted dynamic parser
Notes
Notes: svn path=/head/; revision=59027
Diffstat (limited to 'devel/openzz')
-rw-r--r--devel/openzz/Makefile24
-rw-r--r--devel/openzz/distinfo1
-rw-r--r--devel/openzz/files/patch-zlex.c10
-rw-r--r--devel/openzz/pkg-comment1
-rw-r--r--devel/openzz/pkg-descr6
-rw-r--r--devel/openzz/pkg-plist8
6 files changed, 50 insertions, 0 deletions
diff --git a/devel/openzz/Makefile b/devel/openzz/Makefile
new file mode 100644
index 000000000000..dad17ceea07f
--- /dev/null
+++ b/devel/openzz/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: openzz
+# Date created: May 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= openzz
+PORTVERSION= 1.0.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s/cfree/free/g" ${WRKSRC}/src/list.c
+
+.include <bsd.port.mk>
diff --git a/devel/openzz/distinfo b/devel/openzz/distinfo
new file mode 100644
index 000000000000..48908729139d
--- /dev/null
+++ b/devel/openzz/distinfo
@@ -0,0 +1 @@
+MD5 (openzz-1.0.2.tar.gz) = fc4e36eec6744d8f4b36637bd7c09b78
diff --git a/devel/openzz/files/patch-zlex.c b/devel/openzz/files/patch-zlex.c
new file mode 100644
index 000000000000..afda10c3109a
--- /dev/null
+++ b/devel/openzz/files/patch-zlex.c
@@ -0,0 +1,10 @@
+--- src/zlex.c.orig Tue May 14 02:39:53 2002
++++ src/zlex.c Tue May 14 02:40:04 2002
+@@ -33,7 +33,6 @@
+ #include <ctype.h>
+ //#include <varargs.h>
+ #include <stdarg.h>
+-#include <printf.h>
+ #include "avl.h"
+ #include "zlex.h"
+ #include "mem.h"
diff --git a/devel/openzz/pkg-comment b/devel/openzz/pkg-comment
new file mode 100644
index 000000000000..c20b91fdb45e
--- /dev/null
+++ b/devel/openzz/pkg-comment
@@ -0,0 +1 @@
+An interpreted dynamic parser
diff --git a/devel/openzz/pkg-descr b/devel/openzz/pkg-descr
new file mode 100644
index 000000000000..cf8793f21cac
--- /dev/null
+++ b/devel/openzz/pkg-descr
@@ -0,0 +1,6 @@
+OpenZz is a dynamic parser which allows its grammar to be extended by
+commands written in its own Zz language. Due to the interpreted and
+dynamic nature of the parser OpenZz can be used to develop both fast
+language prototypes and full compilers.
+
+WWW: http://openzz.sourceforge.net/
diff --git a/devel/openzz/pkg-plist b/devel/openzz/pkg-plist
new file mode 100644
index 000000000000..dd74fa4c1637
--- /dev/null
+++ b/devel/openzz/pkg-plist
@@ -0,0 +1,8 @@
+bin/ozz
+include/ozz/zz.h
+include/ozz/zzbind.h
+@dirrm include/ozz
+lib/libozz.a
+lib/libozz.la
+lib/libozz.so
+lib/libozz.so.1