aboutsummaryrefslogtreecommitdiff
path: root/devel/orbitcpp
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-10-29 08:57:07 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-10-29 08:57:07 +0000
commit1b4f516e45c4cdb9def4d20deb8233e2cf509d59 (patch)
tree3a4bbe0bb8b083573c1d89c67288507f9bcbe580 /devel/orbitcpp
parent56d67d9efe3ae48d71d2528f11194a769c1cb194 (diff)
downloadports-1b4f516e45c4cdb9def4d20deb8233e2cf509d59.tar.gz
ports-1b4f516e45c4cdb9def4d20deb8233e2cf509d59.zip
Add orbitcpp-0.30.1, C++ bindings for ORBit, a CORBA 2.2-compliant ORB
PR: 30232 Submitted by: Thomas Hentschel <bsd@hentschel.net>
Notes
Notes: svn path=/head/; revision=49318
Diffstat (limited to 'devel/orbitcpp')
-rw-r--r--devel/orbitcpp/Makefile23
-rw-r--r--devel/orbitcpp/distinfo1
-rw-r--r--devel/orbitcpp/files/patch-Makefile.in23
-rw-r--r--devel/orbitcpp/files/patch-ltmain.sh18
-rw-r--r--devel/orbitcpp/pkg-comment1
-rw-r--r--devel/orbitcpp/pkg-descr4
-rw-r--r--devel/orbitcpp/pkg-plist27
7 files changed, 97 insertions, 0 deletions
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
new file mode 100644
index 000000000000..bc705675a0db
--- /dev/null
+++ b/devel/orbitcpp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: orbitcpp
+# Date created: 30 August 2001
+# Whom: Thomas Hentschel <thomas at hentschel dot net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= orbitcpp
+PORTVERSION= 0.30.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= orbitcpp
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
+
+USE_GMAKE= yes
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/orbitcpp/distinfo b/devel/orbitcpp/distinfo
new file mode 100644
index 000000000000..ad566d7dde5a
--- /dev/null
+++ b/devel/orbitcpp/distinfo
@@ -0,0 +1 @@
+MD5 (orbitcpp-0.30.1.tar.gz) = 1268615115d6daf25e1aa92541ad5bcf
diff --git a/devel/orbitcpp/files/patch-Makefile.in b/devel/orbitcpp/files/patch-Makefile.in
new file mode 100644
index 000000000000..f72e9febd0d3
--- /dev/null
+++ b/devel/orbitcpp/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- Makefile.in Wed May 23 01:52:34 2001
++++ Makefile.in Thu Aug 30 19:57:42 2001
+@@ -92,7 +92,7 @@
+ idlbackenddir = @idlbackenddir@
+
+ AUTOMAKE_OPTIONS = 1.4 # required version of automake.
+-@HAVE_ORBIT_IDL_BACKENDDIR_TRUE@SUBDIRS = compiler orb services test
++@HAVE_ORBIT_IDL_BACKENDDIR_TRUE@SUBDIRS = compiler orb services
+ @HAVE_ORBIT_IDL_BACKENDDIR_FALSE@SUBDIRS = compiler orb
+ EXTRA_DIST = HACKING FAQ README README-0.30 orbitcpp.m4 Makefile.buildvars #KNOWN-BUGS
+
+@@ -118,7 +118,7 @@
+
+ TAR = tar
+ GZIP_ENV = --best
+-DIST_SUBDIRS = compiler orb services test compiler orb
++DIST_SUBDIRS = compiler orb services compiler orb
+ all: all-redirect
+ .SUFFIXES:
+ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
diff --git a/devel/orbitcpp/files/patch-ltmain.sh b/devel/orbitcpp/files/patch-ltmain.sh
new file mode 100644
index 000000000000..33bc7983f107
--- /dev/null
+++ b/devel/orbitcpp/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/orbitcpp/pkg-comment b/devel/orbitcpp/pkg-comment
new file mode 100644
index 000000000000..da2ebecc0cd1
--- /dev/null
+++ b/devel/orbitcpp/pkg-comment
@@ -0,0 +1 @@
+C++ bindings for ORBit, a CORBA 2.2-compliant ORB
diff --git a/devel/orbitcpp/pkg-descr b/devel/orbitcpp/pkg-descr
new file mode 100644
index 000000000000..63718b64ab19
--- /dev/null
+++ b/devel/orbitcpp/pkg-descr
@@ -0,0 +1,4 @@
+orbitcpp provides C++ bindings for ORBit, an open source CORBA
+2.2-compliant Object Request Broker.
+
+WWW: http://orbitcpp.sourceforge.net/
diff --git a/devel/orbitcpp/pkg-plist b/devel/orbitcpp/pkg-plist
new file mode 100644
index 000000000000..fffca2530e88
--- /dev/null
+++ b/devel/orbitcpp/pkg-plist
@@ -0,0 +1,27 @@
+bin/orbitcpp-config
+include/orb/orbitcpp.hh
+include/orb/orbitcpp_config.hh
+include/orb/orbitcpp_constants.hh
+include/orb/orbitcpp_exception.hh
+include/orb/orbitcpp_exceptionlist.hh
+include/orb/orbitcpp_object.hh
+include/orb/orbitcpp_orb.hh
+include/orb/orbitcpp_poa.hh
+include/orb/orbitcpp_sequence.hh
+include/orb/orbitcpp_smartptr.hh
+include/orb/orbitcpp_var_smartptr.hh
+include/orb/orbitcpp_tools.hh
+include/orb/orbitcpp_types.hh
+include/orb/orbitcpp_any.hh
+include/orb/orbitcpp_typecode.hh
+include/ORBitservices/CosNaming.hh
+lib/liborbitcpp.a
+lib/liborbitcpp.so
+lib/liborbitcpp.so.30
+lib/liborbitcppCosNaming.a
+lib/liborbitcppCosNaming.so
+lib/liborbitcppCosNaming.so.30
+lib/orbit-idl/liborbit-idl-c++-backend.a
+lib/orbit-idl/liborbit-idl-c++-backend.so
+lib/orbit-idl/liborbit-idl-c++-backend.so.0
+share/aclocal/orbitcpp.m4