aboutsummaryrefslogtreecommitdiff
path: root/devel/ossp-al
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-02-01 04:41:32 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-02-01 04:41:32 +0000
commitbb332e443186607cf41eeaebfe7036ee4872f856 (patch)
tree80b769320842be38d32a75a7dbf879970a65a7e7 /devel/ossp-al
parent15e5d1e02a8ae0f686af1e371af2bcbb9eb6e7f4 (diff)
downloadports-bb332e443186607cf41eeaebfe7036ee4872f856.tar.gz
ports-bb332e443186607cf41eeaebfe7036ee4872f856.zip
Data buffer that can move, assemble, and truncate chunks of data without
any copying.
Notes
Notes: svn path=/head/; revision=74408
Diffstat (limited to 'devel/ossp-al')
-rw-r--r--devel/ossp-al/Makefile29
-rw-r--r--devel/ossp-al/distinfo1
-rw-r--r--devel/ossp-al/files/manpages.mk1
-rw-r--r--devel/ossp-al/pkg-comment1
-rw-r--r--devel/ossp-al/pkg-descr10
-rw-r--r--devel/ossp-al/pkg-plist6
6 files changed, 48 insertions, 0 deletions
diff --git a/devel/ossp-al/Makefile b/devel/ossp-al/Makefile
new file mode 100644
index 000000000000..2c6ed0204609
--- /dev/null
+++ b/devel/ossp-al/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: ossp-al
+# Date created: 2003-01-31
+# Whom: Alan Eldridge <alane@geeksrus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= al
+PORTVERSION= 0.9.1
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/al/
+PKGNAMEPREFIX= ossp-
+
+MAINTAINER= alane@FreeBSD.org
+
+LIB_DEPENDS= ex.10:${.CURDIR}/../../devel/ossp-ex
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
+
+#EOF
diff --git a/devel/ossp-al/distinfo b/devel/ossp-al/distinfo
new file mode 100644
index 000000000000..435d1e26cb8a
--- /dev/null
+++ b/devel/ossp-al/distinfo
@@ -0,0 +1 @@
+MD5 (al-0.9.1.tar.gz) = eba90e56fe7248466b66306a65868ae7
diff --git a/devel/ossp-al/files/manpages.mk b/devel/ossp-al/files/manpages.mk
new file mode 100644
index 000000000000..2b06afd6a1fa
--- /dev/null
+++ b/devel/ossp-al/files/manpages.mk
@@ -0,0 +1 @@
+MAN3+= al.3
diff --git a/devel/ossp-al/pkg-comment b/devel/ossp-al/pkg-comment
new file mode 100644
index 000000000000..c89090a9a34c
--- /dev/null
+++ b/devel/ossp-al/pkg-comment
@@ -0,0 +1 @@
+Defines an abstract type of buffer that can move data without copying
diff --git a/devel/ossp-al/pkg-descr b/devel/ossp-al/pkg-descr
new file mode 100644
index 000000000000..0edc02fd456b
--- /dev/null
+++ b/devel/ossp-al/pkg-descr
@@ -0,0 +1,10 @@
+OSSP al defines an abstract data type of a data buffer that can assemble,
+move and truncate chunks of data in a stream but avoids actual copying. It
+was built to deal efficiently with communication streams between software
+modules. It especially provides flexible semantical data attribution through
+by-chunk labeling. It also has convenient chunk traversal methods and
+optional OSSP ex based exception handling.
+
+WWW: http://www.ossp.org/pkg/lib/al/
+
+-- AlanE@FreeBSD.org
diff --git a/devel/ossp-al/pkg-plist b/devel/ossp-al/pkg-plist
new file mode 100644
index 000000000000..632526bbd306
--- /dev/null
+++ b/devel/ossp-al/pkg-plist
@@ -0,0 +1,6 @@
+bin/al-config
+include/al.h
+lib/libal.a
+lib/libal.la
+lib/libal.so
+lib/libal.so.9