aboutsummaryrefslogtreecommitdiff
path: root/devel/p4p
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2006-11-28 21:11:47 +0000
committerLars Thegler <lth@FreeBSD.org>2006-11-28 21:11:47 +0000
commit5203cae857b9963d0b9bf319ed86799b0cae6afc (patch)
tree3d6884e7af7367d57e9a7c95b14805af0ce61d52 /devel/p4p
parente53355282d4115508f73ec414ee002d6d6e24785 (diff)
downloadports-5203cae857b9963d0b9bf319ed86799b0cae6afc.tar.gz
ports-5203cae857b9963d0b9bf319ed86799b0cae6afc.zip
- Fixed OSVERSION check [1]
- Fixed IGNORE spelling Noticed by: pointyhat via kris [1]
Notes
Notes: svn path=/head/; revision=178212
Diffstat (limited to 'devel/p4p')
-rw-r--r--devel/p4p/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
index 2038fcaceeac..2d55b14d7999 100644
--- a/devel/p4p/Makefile
+++ b/devel/p4p/Makefile
@@ -70,14 +70,18 @@ PLATFORM= freebsd54x86
.elif ${OSVERSION} > 400000
PLATFORM= freebsd4
.else
-INGORE= only supported on FreeBSD 4.x and greater
+IGNORE= only supported on FreeBSD 4.x and greater
.endif
.endif
+.if (${ARCH} == amd64) && (${OSVERSION} < 504000)
+IGNORE= amd64 is only supported on FreeBSD 5.4 and later
+.endif
+
# Add compatability dependencies.
.if ${OSVERSION} > 600000
LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
-.elif (${OSVERSION} < 540000) && (${OSVERSION} > 500000)
+.elif (${OSVERSION} < 504000) && (${OSVERSION} > 500000)
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.endif