aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-Cluster
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-21 08:32:14 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-21 08:32:14 +0000
commit652e7fd38f622838c40a83730be0734ce150ee03 (patch)
tree43aef24b0f1cd0c97a47c5436a5ebd179276f0be /devel/p5-Algorithm-Cluster
parenta38ea8ae19dd6db498997c8475734df33f376486 (diff)
downloadports-652e7fd38f622838c40a83730be0734ce150ee03.tar.gz
ports-652e7fd38f622838c40a83730be0734ce150ee03.zip
Add p5-Algorithm-Cluster 1.26,
This module is an interface to the C Clustering Library, a general purpose library implementing functions for hierarchical clustering (pairwise simple, complete, average, and centroid linkage), along with k-means and k-medians clustering, and 2D self-organizing maps. The library is distributed along with Cluster 3.0, an enhanced version of the famous Cluster program originally written by Michael Eisen while at Stanford University. The C clustering library was written by Michiel de Hoon. PR: ports/66970 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=109609
Diffstat (limited to 'devel/p5-Algorithm-Cluster')
-rw-r--r--devel/p5-Algorithm-Cluster/Makefile33
-rw-r--r--devel/p5-Algorithm-Cluster/distinfo2
-rw-r--r--devel/p5-Algorithm-Cluster/pkg-descr14
-rw-r--r--devel/p5-Algorithm-Cluster/pkg-plist7
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-Cluster/Makefile b/devel/p5-Algorithm-Cluster/Makefile
new file mode 100644
index 000000000000..ff2e00e3fd56
--- /dev/null
+++ b/devel/p5-Algorithm-Cluster/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Algorithm-Cluster
+# Date created: Fri May 21 15:21:09 CST 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Cluster
+PORTVERSION= 1.26
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A perl interface to C clustering library
+
+PERL_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN3= Algorithm::Cluster.3
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ "s|${PORTNAME}|Algorithm::Cluster|" ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-Cluster/distinfo b/devel/p5-Algorithm-Cluster/distinfo
new file mode 100644
index 000000000000..992326dc076b
--- /dev/null
+++ b/devel/p5-Algorithm-Cluster/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-Cluster-1.26.tar.gz) = d53ddb38d374a7bcaa43f9879299796e
+SIZE (Algorithm-Cluster-1.26.tar.gz) = 65103
diff --git a/devel/p5-Algorithm-Cluster/pkg-descr b/devel/p5-Algorithm-Cluster/pkg-descr
new file mode 100644
index 000000000000..2cb5d3ca5d7f
--- /dev/null
+++ b/devel/p5-Algorithm-Cluster/pkg-descr
@@ -0,0 +1,14 @@
+This module is an interface to the C Clustering Library, a general
+purpose library implementing functions for hierarchical clustering
+(pairwise simple, complete, average, and centroid linkage),
+along with k-means and k-medians clustering, and 2D self-organizing maps.
+The library is distributed along with Cluster 3.0, an enhanced version
+of the famous Cluster program originally written by Michael Eisen
+while at Stanford University. The C clustering library was written
+by Michiel de Hoon.
+
+This module is a Perl wrapper for the C clustering library for
+cDNA microarray data, Copyright (C) 2002 Michiel Jan Laurens de Hoon.
+
+Author: John Nolan <jpnolan@sonic.net>
+WWW: http://search.cpan.org/search?dist=Algorithm-Cluster
diff --git a/devel/p5-Algorithm-Cluster/pkg-plist b/devel/p5-Algorithm-Cluster/pkg-plist
new file mode 100644
index 000000000000..f857472737fd
--- /dev/null
+++ b/devel/p5-Algorithm-Cluster/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Algorithm/Cluster.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Cluster/Cluster.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Cluster/Cluster.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Cluster/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Cluster
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Algorithm 2>/dev/null || true