aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-LUHN
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-29 22:14:25 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-06-29 22:14:25 +0000
commit16e12760017f5079df05c948ada6827e3560cc30 (patch)
treef8a267e34f7b8aca1cfc31b34f16adecc98a2031 /devel/p5-Algorithm-LUHN
parent30a6cbe2691f381e7968673cf1ea8652a3e61b8a (diff)
downloadports-16e12760017f5079df05c948ada6827e3560cc30.tar.gz
ports-16e12760017f5079df05c948ada6827e3560cc30.zip
Add p5-Algorithm-LUHN.
This module calculates the Modulus 10 Double Add Double checksum, also known as the LUHN Formula. This algorithm is used to verify credit card numbers and Standard & Poor's security identifiers such as CUSIP and CSIN. You can find plenty of information about the algorithm by searching the web for "modulus 10 double add double". WWW: http://search.cpan.org/dist/Algorithm-LUHN/ PR: ports/82650 Submitted by: Aaron Dalton <aaron@daltons.ca>
Notes
Notes: svn path=/head/; revision=138214
Diffstat (limited to 'devel/p5-Algorithm-LUHN')
-rw-r--r--devel/p5-Algorithm-LUHN/Makefile22
-rw-r--r--devel/p5-Algorithm-LUHN/distinfo2
-rw-r--r--devel/p5-Algorithm-LUHN/pkg-descr11
-rw-r--r--devel/p5-Algorithm-LUHN/pkg-plist6
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-LUHN/Makefile b/devel/p5-Algorithm-LUHN/Makefile
new file mode 100644
index 000000000000..16aa9178f7de
--- /dev/null
+++ b/devel/p5-Algorithm-LUHN/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Algorithm-LUHN
+# Date created: 25 June 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-LUHN
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/T/TA/TAYERS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Calculate the Modulus 10 Double Add Double checksum
+
+MAN3= Algorithm::LUHN.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-LUHN/distinfo b/devel/p5-Algorithm-LUHN/distinfo
new file mode 100644
index 000000000000..5cf622f972e5
--- /dev/null
+++ b/devel/p5-Algorithm-LUHN/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-LUHN-1.00.tar.gz) = 411d2ddcf3c61172926498b446fe28ab
+SIZE (Algorithm-LUHN-1.00.tar.gz) = 3748
diff --git a/devel/p5-Algorithm-LUHN/pkg-descr b/devel/p5-Algorithm-LUHN/pkg-descr
new file mode 100644
index 000000000000..e681aee8a462
--- /dev/null
+++ b/devel/p5-Algorithm-LUHN/pkg-descr
@@ -0,0 +1,11 @@
+This module calculates the Modulus 10 Double Add Double checksum, also known
+as the LUHN Formula. This algorithm is used to verify credit card numbers and
+Standard & Poor's security identifiers such as CUSIP and CSIN.
+
+You can find plenty of information about the algorithm by searching the web
+for "modulus 10 double add double".
+
+WWW: http://search.cpan.org/dist/Algorithm-LUHN/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Algorithm-LUHN/pkg-plist b/devel/p5-Algorithm-LUHN/pkg-plist
new file mode 100644
index 000000000000..0e561b69d92b
--- /dev/null
+++ b/devel/p5-Algorithm-LUHN/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Algorithm/LUHN.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/LUHN/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/LUHN
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true
+