aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-AnyEvent-Filesys-Notify
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-04-02 05:31:18 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-04-02 05:31:18 +0000
commit1a7f12ff05a716054fcac9d52a29a9665064b9e2 (patch)
treebdaa68c7ee48173e8663acad127702ae11477e24 /devel/p5-AnyEvent-Filesys-Notify
parent0840b29a3c1a9a287e8cebafc262bca5fea2d480 (diff)
downloadports-1a7f12ff05a716054fcac9d52a29a9665064b9e2.tar.gz
ports-1a7f12ff05a716054fcac9d52a29a9665064b9e2.zip
An AnyEvent compatible module to monitor files/directories for changes
Notes
Notes: svn path=/head/; revision=251999
Diffstat (limited to 'devel/p5-AnyEvent-Filesys-Notify')
-rw-r--r--devel/p5-AnyEvent-Filesys-Notify/Makefile36
-rw-r--r--devel/p5-AnyEvent-Filesys-Notify/distinfo3
-rw-r--r--devel/p5-AnyEvent-Filesys-Notify/pkg-descr3
-rw-r--r--devel/p5-AnyEvent-Filesys-Notify/pkg-plist9
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-AnyEvent-Filesys-Notify/Makefile b/devel/p5-AnyEvent-Filesys-Notify/Makefile
new file mode 100644
index 000000000000..5615902e4385
--- /dev/null
+++ b/devel/p5-AnyEvent-Filesys-Notify/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: AnyEvent::Filesys::Notify
+# Date created: 02 Apr 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-Filesys-Notify
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for AnyEvent compat to monitor file/dir changes
+
+RUN_DEPENDS= \
+ p5-AnyEvent>0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-File-Find-Rule>0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-namespace-autoclean>0:${PORTSDIR}/devel/p5-namespace-autoclean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= AnyEvent::Filesys::Notify.3 \
+ AnyEvent::Filesys::Notify::Event.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-autodie>0:${PORTSDIR}/devel/p5-autodie
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-AnyEvent-Filesys-Notify/distinfo b/devel/p5-AnyEvent-Filesys-Notify/distinfo
new file mode 100644
index 000000000000..53eed3b6873c
--- /dev/null
+++ b/devel/p5-AnyEvent-Filesys-Notify/distinfo
@@ -0,0 +1,3 @@
+MD5 (AnyEvent-Filesys-Notify-0.05.tar.gz) = 0bc6d1323ce5d505376b28f902791bb0
+SHA256 (AnyEvent-Filesys-Notify-0.05.tar.gz) = 1d74774bb7073688fcdf8906b2dfcc6d1078d80cc9c085046dd050812416eb46
+SIZE (AnyEvent-Filesys-Notify-0.05.tar.gz) = 12258
diff --git a/devel/p5-AnyEvent-Filesys-Notify/pkg-descr b/devel/p5-AnyEvent-Filesys-Notify/pkg-descr
new file mode 100644
index 000000000000..60e2c5948dd8
--- /dev/null
+++ b/devel/p5-AnyEvent-Filesys-Notify/pkg-descr
@@ -0,0 +1,3 @@
+An AnyEvent compatible module to monitor files/directories for changes
+
+WWW: http://search.cpan.org/dist/AnyEvent-Filesys-Notify/
diff --git a/devel/p5-AnyEvent-Filesys-Notify/pkg-plist b/devel/p5-AnyEvent-Filesys-Notify/pkg-plist
new file mode 100644
index 000000000000..a6de3e432222
--- /dev/null
+++ b/devel/p5-AnyEvent-Filesys-Notify/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/AnyEvent/Filesys/Notify.pm
+%%SITE_PERL%%/AnyEvent/Filesys/Notify/Event.pm
+%%SITE_PERL%%/AnyEvent/Filesys/Notify/Role/Fallback.pm
+%%SITE_PERL%%/AnyEvent/Filesys/Notify/Role/Linux.pm
+%%SITE_PERL%%/AnyEvent/Filesys/Notify/Role/Mac.pm
+@dirrmtry %%SITE_PERL%%/AnyEvent/Filesys/Notify/Role
+@dirrmtry %%SITE_PERL%%/AnyEvent/Filesys/Notify
+@dirrmtry %%SITE_PERL%%/AnyEvent/Filesys
+@dirrmtry %%SITE_PERL%%/AnyEvent