aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-B-Hooks-EndOfScope/Makefile
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2008-10-26 11:31:16 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2008-10-26 11:31:16 +0000
commit8ae7a102bb9e5771411a1e4c19d265de231bbb4e (patch)
treeddb679fe4f92c3fdf501390fe72d4927face2043 /devel/p5-B-Hooks-EndOfScope/Makefile
parent4d7ea5de54232588c7a5e850a624e6c231e0cb66 (diff)
downloadports-8ae7a102bb9e5771411a1e4c19d265de231bbb4e.tar.gz
ports-8ae7a102bb9e5771411a1e4c19d265de231bbb4e.zip
This module allows you to execute code when perl finished compiling the
surrounding scope.
Notes
Notes: svn path=/head/; revision=222092
Diffstat (limited to 'devel/p5-B-Hooks-EndOfScope/Makefile')
-rw-r--r--devel/p5-B-Hooks-EndOfScope/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-B-Hooks-EndOfScope/Makefile b/devel/p5-B-Hooks-EndOfScope/Makefile
new file mode 100644
index 000000000000..9d04c92819e6
--- /dev/null
+++ b/devel/p5-B-Hooks-EndOfScope/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-B-Hooks-EndOfScope
+# Date created: 26 Oct 2008
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-Hooks-EndOfScope
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Execute code after a scope finished compilation
+
+RUN_DEPENDS= p5-Scope-Guard>0:${PORTSDIR}/devel/p5-Scope-Guard \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= B::Hooks::EndOfScope.3
+
+.include <bsd.port.mk>