aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-C-Scan/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-08-12 09:57:59 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-08-12 09:57:59 +0000
commit88f83d45d8c81a59ecaeffa54fcdf46dd391e189 (patch)
treefd0647f7d8a704838ad4cbecbfb2993433184bd2 /devel/p5-C-Scan/Makefile
parentca335ee595c60f4784cc8498e5b1feb294c135bb (diff)
downloadports-88f83d45d8c81a59ecaeffa54fcdf46dd391e189.tar.gz
ports-88f83d45d8c81a59ecaeffa54fcdf46dd391e189.zip
Update for perl version 5.00501. Requires latest bsd.port.mk. I'm
going to be a little verbose here about the changes so people who fix up the rest of the stuff can have an idea what to do. (1) Manpages are moved to version-specific subdirectories. Since they are all defined in MAN? macros, I just needed to add ${PERL_VERSION} to the end of MAN*PREFIX and delete them from the PLIST. (2) Most of the module files are moved to version-specific subdirectories. This is usually accomplished by adding "%%PERL_VER%%/" right after "site_perl/" in the PLIST. However, some things didn't move, and some moved more than one level (like, all the way into "site_perl/%%PERL_VER%%/auto/FooBar") so some fishing, err, find'ing was necessary. (3) Fix up dependencies. See (2) above. (4) While I was there, I changed some "@dirrm foobar"'s to "@unexec rmdir %D/foobar 2>/dev/null || true", so there won't be any warnings if a directory can't be removed due to other modules sharing it. Now all of devel/p5-* will install and deinstall without a single warning. I hope others will follow suit. :)
Notes
Notes: svn path=/head/; revision=12472
Diffstat (limited to 'devel/p5-C-Scan/Makefile')
-rw-r--r--devel/p5-C-Scan/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/p5-C-Scan/Makefile b/devel/p5-C-Scan/Makefile
index aaf87830d64d..a0e14e51fdb8 100644
--- a/devel/p5-C-Scan/Makefile
+++ b/devel/p5-C-Scan/Makefile
@@ -3,7 +3,7 @@
# Date created: October 20th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.9 1997/09/14 02:54:12 jfitz Exp $
+# $Id: Makefile,v 1.10 1998/04/04 13:55:57 vanilla Exp $
#
DISTNAME= C-Scan-0.5
@@ -14,12 +14,12 @@ MASTER_SITE_SUBDIR= C
MAINTAINER= jfitz@FreeBSD.ORG
-BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/Data/Flow.pm:${PORTSDIR}/devel/p5-Data-Flow
+BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Data/Flow.pm:${PORTSDIR}/devel/p5-Data-Flow
USE_PERL5= YES
MAN3= C::Scan.3
-MANPREFIX= ${PREFIX}/lib/perl5
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL