aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Cache
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-12-15 20:59:44 +0000
committerLars Thegler <lth@FreeBSD.org>2004-12-15 20:59:44 +0000
commitaf8e89779085b1129e28af803a47ac88d8024d6d (patch)
tree4fca65aac4a910799ac7da911cb96b792f83020c /devel/p5-Cache
parent52d5bb295d9d628c07effc1b315936eea19fbc14 (diff)
downloadports-af8e89779085b1129e28af803a47ac88d8024d6d.tar.gz
ports-af8e89779085b1129e28af803a47ac88d8024d6d.zip
Add p5-Cache 2.02, a Perl Cache interface.
Notes
Notes: svn path=/head/; revision=124155
Diffstat (limited to 'devel/p5-Cache')
-rw-r--r--devel/p5-Cache/Makefile50
-rw-r--r--devel/p5-Cache/distinfo2
-rw-r--r--devel/p5-Cache/pkg-descr6
-rw-r--r--devel/p5-Cache/pkg-plist23
4 files changed, 81 insertions, 0 deletions
diff --git a/devel/p5-Cache/Makefile b/devel/p5-Cache/Makefile
new file mode 100644
index 000000000000..1ad276ff047c
--- /dev/null
+++ b/devel/p5-Cache/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: devel/p5-Cache
+# Date created: 13 December 2004
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache
+PORTVERSION= 2.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Cache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A Perl Cache interface
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+ ${SITE_PERL}/Heap/Fibonacci.pm:${PORTSDIR}/devel/p5-Heap \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/File/NFSLock.pm:${PORTSDIR}/devel/p5-File-NFSLock \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Cache.3 \
+ Cache::Entry.3 \
+ Cache::File.3 \
+ Cache::File::Entry.3 \
+ Cache::File::Handle.3 \
+ Cache::File::Heap.3 \
+ Cache::IOString.3 \
+ Cache::Memory.3 \
+ Cache::Memory::Entry.3 \
+ Cache::Memory::HeapElem.3 \
+ Cache::Null.3 \
+ Cache::Null::Entry.3 \
+ Cache::RemovalStrategy.3 \
+ Cache::RemovalStrategy::FIFO.3 \
+ Cache::RemovalStrategy::LRU.3 \
+ Cache::Tester.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port requires perl 5.6.0 or later. Install lang/perl5 then try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Cache/distinfo b/devel/p5-Cache/distinfo
new file mode 100644
index 000000000000..e2b457eb2a42
--- /dev/null
+++ b/devel/p5-Cache/distinfo
@@ -0,0 +1,2 @@
+MD5 (Cache-2.02.tar.gz) = 47ba7a90a098048c540bb1626b240616
+SIZE (Cache-2.02.tar.gz) = 32854
diff --git a/devel/p5-Cache/pkg-descr b/devel/p5-Cache/pkg-descr
new file mode 100644
index 000000000000..d8aed0276e12
--- /dev/null
+++ b/devel/p5-Cache/pkg-descr
@@ -0,0 +1,6 @@
+The Cache modules are designed to assist a developer in persisting
+data for a specified period of time. Often these modules are used
+in web applications to store data locally to save repeated and
+redundant expensive calls to remote machines or databases.
+
+WWW: http://search.cpan.org/dist/Cache
diff --git a/devel/p5-Cache/pkg-plist b/devel/p5-Cache/pkg-plist
new file mode 100644
index 000000000000..3fa11c044518
--- /dev/null
+++ b/devel/p5-Cache/pkg-plist
@@ -0,0 +1,23 @@
+%%SITE_PERL%%/Cache.pm
+%%SITE_PERL%%/Cache/Entry.pm
+%%SITE_PERL%%/Cache/File.pm
+%%SITE_PERL%%/Cache/File/Entry.pm
+%%SITE_PERL%%/Cache/File/Handle.pm
+%%SITE_PERL%%/Cache/File/Heap.pm
+%%SITE_PERL%%/Cache/IOString.pm
+%%SITE_PERL%%/Cache/Memory.pm
+%%SITE_PERL%%/Cache/Memory/Entry.pm
+%%SITE_PERL%%/Cache/Memory/HeapElem.pm
+%%SITE_PERL%%/Cache/Null.pm
+%%SITE_PERL%%/Cache/Null/Entry.pm
+%%SITE_PERL%%/Cache/RemovalStrategy.pm
+%%SITE_PERL%%/Cache/RemovalStrategy/FIFO.pm
+%%SITE_PERL%%/Cache/RemovalStrategy/LRU.pm
+%%SITE_PERL%%/Cache/Tester.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Cache/RemovalStrategy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Cache/Memory 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Cache/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Cache/Null 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Cache 2>/dev/null || true