aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Check-ISA
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-09-07 04:18:35 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-09-07 04:18:35 +0000
commit6a791945658446b5c0a19b2396e068eba5ad487f (patch)
tree929e2941bbf4ddb132cbf2bf945065736d576fe7 /devel/p5-Check-ISA
parent1a3943593337c8a567f3b17eeb55fd21c39b5647 (diff)
downloadports-6a791945658446b5c0a19b2396e068eba5ad487f.tar.gz
ports-6a791945658446b5c0a19b2396e068eba5ad487f.zip
Add p5-Check-ISA, DWIM, correct checking of an object's class.
This module provides several functions to assist in testing whether a value is an object, and if so asking about its class. WWW: http://search.cpan.org/dist/Check-ISA/
Notes
Notes: svn path=/head/; revision=220054
Diffstat (limited to 'devel/p5-Check-ISA')
-rw-r--r--devel/p5-Check-ISA/Makefile26
-rw-r--r--devel/p5-Check-ISA/distinfo3
-rw-r--r--devel/p5-Check-ISA/pkg-descr4
-rw-r--r--devel/p5-Check-ISA/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-Check-ISA/Makefile b/devel/p5-Check-ISA/Makefile
new file mode 100644
index 000000000000..07d8dd421c51
--- /dev/null
+++ b/devel/p5-Check-ISA/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Check-ISA
+# Date created: 2008/09/06
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Check-ISA
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NU/NUFFIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= DWIM, correct checking of an object's class
+
+RUN_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Check::ISA.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Check-ISA/distinfo b/devel/p5-Check-ISA/distinfo
new file mode 100644
index 000000000000..6eced85e8016
--- /dev/null
+++ b/devel/p5-Check-ISA/distinfo
@@ -0,0 +1,3 @@
+MD5 (Check-ISA-0.04.tar.gz) = 7d118aadd4069b4287f309482776a2bd
+SHA256 (Check-ISA-0.04.tar.gz) = 48e9bdad799dfcbcd8b081a1f6c165d7fe5236f63290506cad44b27b74db2312
+SIZE (Check-ISA-0.04.tar.gz) = 5552
diff --git a/devel/p5-Check-ISA/pkg-descr b/devel/p5-Check-ISA/pkg-descr
new file mode 100644
index 000000000000..45835d1ebcd9
--- /dev/null
+++ b/devel/p5-Check-ISA/pkg-descr
@@ -0,0 +1,4 @@
+This module provides several functions to assist in testing whether a value
+is an object, and if so asking about its class.
+
+WWW: http://search.cpan.org/dist/Check-ISA/
diff --git a/devel/p5-Check-ISA/pkg-plist b/devel/p5-Check-ISA/pkg-plist
new file mode 100644
index 000000000000..2f068e2ad41f
--- /dev/null
+++ b/devel/p5-Check-ISA/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Check/ISA/.packlist
+%%SITE_PERL%%/Check/ISA.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Check/ISA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Check
+@dirrmtry %%SITE_PERL%%/Check