aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Component
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 01:29:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-14 01:29:04 +0000
commit14903618295916752251e5662bd09567f6714a0a (patch)
treedbc1f6d4b10765f8d802101220b9f6cb5adb62a1 /devel/p5-Class-Component
parentd0bc78295475d769c54bb6627f20e9059e9f7470 (diff)
downloadports-14903618295916752251e5662bd09567f6714a0a.tar.gz
ports-14903618295916752251e5662bd09567f6714a0a.zip
Class::Component is pluggable component framework. The compatibilities such
as dump and load such as YAML are good. WWW: http://search.cpan.org/dist/Class-Component/ PR: ports/122719 Submitted by: Tomoyuki Sakurai <cherry at trombik.org>
Notes
Notes: svn path=/head/; revision=211205
Diffstat (limited to 'devel/p5-Class-Component')
-rw-r--r--devel/p5-Class-Component/Makefile29
-rw-r--r--devel/p5-Class-Component/distinfo3
-rw-r--r--devel/p5-Class-Component/pkg-descr4
-rw-r--r--devel/p5-Class-Component/pkg-plist24
4 files changed, 60 insertions, 0 deletions
diff --git a/devel/p5-Class-Component/Makefile b/devel/p5-Class-Component/Makefile
new file mode 100644
index 000000000000..2ffaaea7d4b0
--- /dev/null
+++ b/devel/p5-Class-Component/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Class-Component
+# Date created: Fri Apr 11 16:34:55 2008
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Component
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cherry@trombik.org
+COMMENT= Pluggable component framework
+
+RUN_DEPENDS= p5-Carp-Clan>0:${PORTSDIR}/devel/p5-Carp-Clan \
+ p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Inspector>0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-UNIVERSAL-require>0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_CONFIGURE= Yes
+
+MAN3= Class::Component::Component::Plaggerize.3 \
+ Class::Component.3 \
+ Class::Component::Plugin.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Component/distinfo b/devel/p5-Class-Component/distinfo
new file mode 100644
index 000000000000..d691da38ba52
--- /dev/null
+++ b/devel/p5-Class-Component/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Component-0.15.tar.gz) = 2c4547864f878d0140d67dcca5f71e36
+SHA256 (Class-Component-0.15.tar.gz) = 75478f8b8302acad449daf76996be91afff9e7c5b47219ba08231b6155cee25e
+SIZE (Class-Component-0.15.tar.gz) = 28924
diff --git a/devel/p5-Class-Component/pkg-descr b/devel/p5-Class-Component/pkg-descr
new file mode 100644
index 000000000000..2628259047b9
--- /dev/null
+++ b/devel/p5-Class-Component/pkg-descr
@@ -0,0 +1,4 @@
+Class::Component is pluggable component framework. The compatibilities such
+as dump and load such as YAML are good.
+
+WWW: http://search.cpan.org/dist/Class-Component/
diff --git a/devel/p5-Class-Component/pkg-plist b/devel/p5-Class-Component/pkg-plist
new file mode 100644
index 000000000000..d81a1ba1751a
--- /dev/null
+++ b/devel/p5-Class-Component/pkg-plist
@@ -0,0 +1,24 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Class/Component/Attribute/Hook.pm
+%%SITE_PERL%%/Class/Component/Attribute/Method.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall/SingletonMethod.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall/InjectMethod.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall/Autoload.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize/Log.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize/PluginLoader.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize/ConfigLoader.pm
+%%SITE_PERL%%/Class/Component/Component/AutoloadPlugin.pm
+%%SITE_PERL%%/Class/Component/Component/DisableDynamicPlugin.pm
+%%SITE_PERL%%/Class/Component/Component/Plaggerize.pm
+%%SITE_PERL%%/Class/Component/Component/SingletonMethod.pm
+%%SITE_PERL%%/Class/Component/Component/Autocall.pm
+%%SITE_PERL%%/Class/Component/Attribute.pm
+%%SITE_PERL%%/Class/Component/Plugin.pm
+%%SITE_PERL%%/Class/Component.pm
+%%SITE_PERL%%/mach/auto/Class/Component/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Class/Component
+@dirrmtry %%SITE_PERL%%/Class/Component/Component/Plaggerize
+@dirrmtry %%SITE_PERL%%/Class/Component/Component/Autocall
+@dirrmtry %%SITE_PERL%%/Class/Component/Component
+@dirrmtry %%SITE_PERL%%/Class/Component/Attribute
+@dirrmtry %%SITE_PERL%%/Class/Component