aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Contract
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-18 03:20:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-18 03:20:10 +0000
commitacaf2d28e6f91234f646d308a56e33255c733801 (patch)
treef214f096026451161df52a86f124594fc14d6478 /devel/p5-Class-Contract
parentfe9678fff2f3758eeafce92f06ff6056a73c321b (diff)
downloadports-acaf2d28e6f91234f646d308a56e33255c733801.tar.gz
ports-acaf2d28e6f91234f646d308a56e33255c733801.zip
add p5-Class-Contract
Design-by-Contract OO in Perl PR: 31782 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=50169
Diffstat (limited to 'devel/p5-Class-Contract')
-rw-r--r--devel/p5-Class-Contract/Makefile38
-rw-r--r--devel/p5-Class-Contract/distinfo1
-rw-r--r--devel/p5-Class-Contract/files/patch-demo.pl8
-rw-r--r--devel/p5-Class-Contract/pkg-comment1
-rw-r--r--devel/p5-Class-Contract/pkg-descr8
-rw-r--r--devel/p5-Class-Contract/pkg-plist9
6 files changed, 65 insertions, 0 deletions
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
new file mode 100644
index 000000000000..7353cac2830a
--- /dev/null
+++ b/devel/p5-Class-Contract/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Class::Contract
+# Date created: 5 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Contract
+PORTVERSION= 1.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= dos2unix:${PORTSDIR}/converters/unix2dos
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::Contract.3 Class::Contract::Production.3
+
+post-extract:
+ @find ${WRKSRC} -type f -name "*.p[lm]" | xargs dos2unix -p
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}/examples
+ ${MV} ${WRKSRC}/demo.pl ${WRKSRC}/examples
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* \
+ ${PREFIX}/share/examples/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Contract/distinfo b/devel/p5-Class-Contract/distinfo
new file mode 100644
index 000000000000..07d3c51d1cd6
--- /dev/null
+++ b/devel/p5-Class-Contract/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Contract-1.14.tar.gz) = fef5c44e6a76d59e12a3b52edcce9a53
diff --git a/devel/p5-Class-Contract/files/patch-demo.pl b/devel/p5-Class-Contract/files/patch-demo.pl
new file mode 100644
index 000000000000..788c83802179
--- /dev/null
+++ b/devel/p5-Class-Contract/files/patch-demo.pl
@@ -0,0 +1,8 @@
+--- demo.pl.orig Mon Nov 5 17:24:22 2001
++++ demo.pl Mon Nov 5 17:24:29 2001
+@@ -1,4 +1,4 @@
+-#! /usr/local/bin/perl -w
++#!/usr/bin/perl -w
+
+ # NOTES:
+ # Invariants and pre- and post-conditions are expected
diff --git a/devel/p5-Class-Contract/pkg-comment b/devel/p5-Class-Contract/pkg-comment
new file mode 100644
index 000000000000..a4e70c336b64
--- /dev/null
+++ b/devel/p5-Class-Contract/pkg-comment
@@ -0,0 +1 @@
+Design-by-Contract OO in Perl
diff --git a/devel/p5-Class-Contract/pkg-descr b/devel/p5-Class-Contract/pkg-descr
new file mode 100644
index 000000000000..fb9dc3d35ab4
--- /dev/null
+++ b/devel/p5-Class-Contract/pkg-descr
@@ -0,0 +1,8 @@
+The Class::Contract module implements strong encapsulation, static
+inheritance, and design-by-contract condition checking for
+object-oriented Perl. The module provides a declarative syntax for
+attribute, method, constructor, and destructor definitions at both
+the object and class level. Pre-conditions, post-conditions, and
+class invariants are also fully supported.
+
+WWW: http://search.cpan.org/search?dist=Class-Contract
diff --git a/devel/p5-Class-Contract/pkg-plist b/devel/p5-Class-Contract/pkg-plist
new file mode 100644
index 000000000000..2faabd3cc5c4
--- /dev/null
+++ b/devel/p5-Class-Contract/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Contract/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Class/Contract.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/Contract/Production.pm
+%%PORTDOCS%%share/examples/Class-Contract/demo.pl
+%%PORTDOCS%%@dirrm share/examples/Class-Contract
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Class/Contract
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Contract
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true