aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Contract
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-02 13:30:21 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-02 13:30:21 +0000
commit69c8220883b4e3fd757d490f52e1f6c9e0dc1af7 (patch)
treeb8e73128a02dd30d683ac8b3f53a949a957c1d07 /devel/p5-Class-Contract
parentc1098ad83295300c143bce69a08441d703c8a199 (diff)
downloadports-69c8220883b4e3fd757d490f52e1f6c9e0dc1af7.tar.gz
ports-69c8220883b4e3fd757d490f52e1f6c9e0dc1af7.zip
Minor fixes
Notes
Notes: svn path=/head/; revision=60456
Diffstat (limited to 'devel/p5-Class-Contract')
-rw-r--r--devel/p5-Class-Contract/Makefile12
-rw-r--r--devel/p5-Class-Contract/files/patch-demo.pl8
2 files changed, 5 insertions, 15 deletions
diff --git a/devel/p5-Class-Contract/Makefile b/devel/p5-Class-Contract/Makefile
index 040105d4f9c2..7d04d8ce83a4 100644
--- a/devel/p5-Class-Contract/Makefile
+++ b/devel/p5-Class-Contract/Makefile
@@ -14,16 +14,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
-BUILD_DEPENDS= dos2unix:${PORTSDIR}/converters/unix2dos
-
PERL_CONFIGURE= yes
PLIST_SUB+= EXAMPLESDIR="share/examples/${PORTNAME}"
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Class::Contract.3 Class::Contract::Production.3
-post-extract:
- @find ${WRKSRC} -type f -name "*.p[lm]" | xargs dos2unix -p
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name "*.p[lm]" | \
+ xargs ${PERL} -pi -e 's/\x0d//g;'
pre-configure:
${MKDIR} ${WRKSRC}/examples
@@ -32,9 +31,8 @@ pre-configure:
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* \
- ${PREFIX}/share/examples/${PORTNAME}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/p5-Class-Contract/files/patch-demo.pl b/devel/p5-Class-Contract/files/patch-demo.pl
deleted file mode 100644
index 788c83802179..000000000000
--- a/devel/p5-Class-Contract/files/patch-demo.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- demo.pl.orig Mon Nov 5 17:24:22 2001
-+++ demo.pl Mon Nov 5 17:24:29 2001
-@@ -1,4 +1,4 @@
--#! /usr/local/bin/perl -w
-+#!/usr/bin/perl -w
-
- # NOTES:
- # Invariants and pre- and post-conditions are expected