aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-Hook
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 12:08:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 12:08:21 +0000
commita2ab06d103fdb7074dfb441646494e85b50da525 (patch)
tree80718e80969bdab21c510f3bda98d4c4884e8bc5 /devel/p5-Class-Hook
parent65dd0504c4cd36c62cf2e9434f60b1c1c3e22396 (diff)
downloadports-a2ab06d103fdb7074dfb441646494e85b50da525.tar.gz
ports-a2ab06d103fdb7074dfb441646494e85b50da525.zip
New port: Perl Class::Hook trace method calls to other classes
Perl module Class::Hook enables you to trace methods calls from your code to other classes. PR: ports/45255 Submitted by: Brian Skrab <brian@quynh-and-brian.org>
Notes
Notes: svn path=/head/; revision=74849
Diffstat (limited to 'devel/p5-Class-Hook')
-rw-r--r--devel/p5-Class-Hook/Makefile27
-rw-r--r--devel/p5-Class-Hook/distinfo1
-rw-r--r--devel/p5-Class-Hook/pkg-comment1
-rw-r--r--devel/p5-Class-Hook/pkg-descr16
-rw-r--r--devel/p5-Class-Hook/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-Class-Hook/Makefile b/devel/p5-Class-Hook/Makefile
new file mode 100644
index 000000000000..a044c7875626
--- /dev/null
+++ b/devel/p5-Class-Hook/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Class-Hook
+# Date created: Fri Nov 7 19:40:58 EST 2002
+# Whom: Brian Skrab <brian@quynh-and-brian.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Hook
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://cottage.quynh-and-brian.org/freebsd/ports/distfiles/
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= brian@quynh-and-brian.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Hook.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Hook/distinfo b/devel/p5-Class-Hook/distinfo
new file mode 100644
index 000000000000..2cdc71cdc317
--- /dev/null
+++ b/devel/p5-Class-Hook/distinfo
@@ -0,0 +1 @@
+MD5 (Class-Hook-0.01.tar.gz) = 2673eaf63bd9beb587c0425418fa926e
diff --git a/devel/p5-Class-Hook/pkg-comment b/devel/p5-Class-Hook/pkg-comment
new file mode 100644
index 000000000000..cf8363c4337e
--- /dev/null
+++ b/devel/p5-Class-Hook/pkg-comment
@@ -0,0 +1 @@
+Add hooks on methods from other classes
diff --git a/devel/p5-Class-Hook/pkg-descr b/devel/p5-Class-Hook/pkg-descr
new file mode 100644
index 000000000000..c7d9472e71f8
--- /dev/null
+++ b/devel/p5-Class-Hook/pkg-descr
@@ -0,0 +1,16 @@
+Class::Hook enables you to trace methods calls from your code to other classes.
+
+Instead of putting 'use Foo;' in your code, simply type 'use Class::Hook;'.
+The class Foo is unknown in your code. It will be magically catched by
+Class::Hook which will call Foo itself. You can see Class::Hook as a kind of
+relay.
+
+You can setup a subroutine to be called before any call to Foo->amethod and a
+subroutine to be called after the call. Your subs will receive all the
+information that Foo->amethod will receive, so you can trace everything
+between your code and Foo.
+
+WWW: http://search.cpan.org/search?dist=Class-Hook
+
+~brian skrab
+ brian@quynh-and-brian.org
diff --git a/devel/p5-Class-Hook/pkg-plist b/devel/p5-Class-Hook/pkg-plist
new file mode 100644
index 000000000000..eab3fc0bb924
--- /dev/null
+++ b/devel/p5-Class-Hook/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/Class/Hook.pm
+lib/perl5/site_perl/%%PERL_VER%%/Class/FOO.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Hook/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class/Hook
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Class 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Class 2>/dev/null || true