aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Config-Any
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2006-09-03 11:53:11 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2006-09-03 11:53:11 +0000
commit39827183a8c13293fb3019571d817d07fb1097b0 (patch)
tree68560e2570f929fa193c3da9f02ae2f46baf1933 /devel/p5-Config-Any
parent67b6ef7b739005d98faee33a6325f9e587fb9e6d (diff)
downloadports-39827183a8c13293fb3019571d817d07fb1097b0.tar.gz
ports-39827183a8c13293fb3019571d817d07fb1097b0.zip
New port: devel/p5-Config-Any, Load class configuration data from a number of file formats
Notes
Notes: svn path=/head/; revision=172036
Diffstat (limited to 'devel/p5-Config-Any')
-rw-r--r--devel/p5-Config-Any/Makefile35
-rw-r--r--devel/p5-Config-Any/distinfo3
-rw-r--r--devel/p5-Config-Any/pkg-descr15
-rw-r--r--devel/p5-Config-Any/pkg-plist9
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/p5-Config-Any/Makefile b/devel/p5-Config-Any/Makefile
new file mode 100644
index 000000000000..2f84f9c0cce8
--- /dev/null
+++ b/devel/p5-Config-Any/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-Config-Any
+# Date created: Sep 3, 2006
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Any
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Load class configuration data from a number of file formats
+
+RUN_DEPENDS= p5-Module-Pluggable>=3.01:${PORTSDIR}/devel/p5-Module-Pluggable
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Config::Any.3 \
+ Config::Any::General.3 \
+ Config::Any::INI.3 \
+ Config::Any::JSON.3 \
+ Config::Any::Perl.3 \
+ Config::Any::XML.3 \
+ Config::Any::YAML.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Config-Any/distinfo b/devel/p5-Config-Any/distinfo
new file mode 100644
index 000000000000..3ef20b745002
--- /dev/null
+++ b/devel/p5-Config-Any/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-Any-0.04.tar.gz) = 0e2c93c3b0659757c88cfe1ab3dfa46f
+SHA256 (Config-Any-0.04.tar.gz) = eae7d06c426271998c470b4827ccf23f234b22d01619bb42f1eac865c1a167b3
+SIZE (Config-Any-0.04.tar.gz) = 9260
diff --git a/devel/p5-Config-Any/pkg-descr b/devel/p5-Config-Any/pkg-descr
new file mode 100644
index 000000000000..3f256e320a4c
--- /dev/null
+++ b/devel/p5-Config-Any/pkg-descr
@@ -0,0 +1,15 @@
+Config::Any provides a facility for Perl applications and libraries to
+load configuration data from multiple different file formats. It sup-
+ports XML, YAML, JSON, Apache-style configuration, Windows INI files,
+and even Perl code.
+
+The rationale for this module is as follows: Perl programs are deployed
+on many different platforms and integrated with many different systems.
+Systems administrators and end users may prefer different configuration
+formats than the developers. The flexibility inherent in a multiple
+format configuration loader allows different users to make different
+choices, without generating extra work for the developers. As a devel-
+oper you only need to learn a single interface to be able to use the
+power of different configuration formats.
+
+WWW: http://search.cpan.org/dist/Config-Any/
diff --git a/devel/p5-Config-Any/pkg-plist b/devel/p5-Config-Any/pkg-plist
new file mode 100644
index 000000000000..080dcf826b0b
--- /dev/null
+++ b/devel/p5-Config-Any/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Config/Any.pm
+%%SITE_PERL%%/Config/Any/General.pm
+%%SITE_PERL%%/Config/Any/INI.pm
+%%SITE_PERL%%/Config/Any/JSON.pm
+%%SITE_PERL%%/Config/Any/Perl.pm
+%%SITE_PERL%%/Config/Any/XML.pm
+%%SITE_PERL%%/Config/Any/YAML.pm
+@dirrmtry %%SITE_PERL%%/Config/Any
+@dirrmtry %%SITE_PERL%%/Config